aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2021-04-15 15:37:20 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2021-04-15 15:37:52 +0000
commitb42828e7fd3e3d9505be516f919a586f18521f0d (patch)
treeaa3d587b63e137fa462c9b2a18d515991ff14e9d /ports-mgmt
parent90c799e7ef92a82e77d95a01375e2607c56a5c04 (diff)
downloadports-b42828e7fd3e3d9505be516f919a586f18521f0d.tar.gz
ports-b42828e7fd3e3d9505be516f919a586f18521f0d.zip
- Fix new jail and ports creation.
Brings in freebsd/poudriere@1c9357d08e35f2bb248533ce043b2e61920ebf9e
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/poudriere-devel/Makefile2
-rw-r--r--ports-mgmt/poudriere-devel/files/patch-1c9357d08e35f2bb248533ce043b2e61920ebf9e29
2 files changed, 30 insertions, 1 deletions
diff --git a/ports-mgmt/poudriere-devel/Makefile b/ports-mgmt/poudriere-devel/Makefile
index 4fc42ea54067..2337a91c8cdb 100644
--- a/ports-mgmt/poudriere-devel/Makefile
+++ b/ports-mgmt/poudriere-devel/Makefile
@@ -1,6 +1,6 @@
PORTNAME= poudriere
DISTVERSION= 3.3.99.20210303
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= ports-mgmt
MASTER_SITES= LOCAL/bdrewery/${PORTNAME}/ \
http://mirror.shatow.net/freebsd/${PORTNAME}/ \
diff --git a/ports-mgmt/poudriere-devel/files/patch-1c9357d08e35f2bb248533ce043b2e61920ebf9e b/ports-mgmt/poudriere-devel/files/patch-1c9357d08e35f2bb248533ce043b2e61920ebf9e
new file mode 100644
index 000000000000..487e88c71f87
--- /dev/null
+++ b/ports-mgmt/poudriere-devel/files/patch-1c9357d08e35f2bb248533ce043b2e61920ebf9e
@@ -0,0 +1,29 @@
+commit 1c9357d08e35f2bb248533ce043b2e61920ebf9e
+Author: Bryan Drewery <bryan@shatow.net>
+Date: Tue Mar 23 16:06:36 2021 -0700
+
+ Partially revert #844 for createfs; still use -p.
+
+ This restores the -p and atime/mountpoint/compression setting
+ for /jails and /ports.
+
+ It changes compression=lz4 to compression=on as well.
+
+ Fixes #844
+
+diff --git src/share/poudriere/include/fs.sh src/share/poudriere/include/fs.sh
+index fed4a5b08..cad0aa69d 100644
+--- src/share/poudriere/include/fs.sh
++++ src/share/poudriere/include/fs.sh
+@@ -34,7 +34,10 @@ createfs() {
+
+ if [ -n "${fs}" -a "${fs}" != "none" ]; then
+ msg_n "Creating ${name} fs at ${mnt}..."
+- if ! zfs create ${fs}; then
++ if ! zfs create -p \
++ -o compression=on \
++ -o atime=off \
++ -o mountpoint=${mnt} ${fs}; then
+ echo " fail"
+ err 1 "Failed to create FS ${fs}"
+ fi