aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2021-06-14 17:56:52 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2021-06-14 17:56:52 +0000
commitc81071045556832e93b90a70708fbca06a1bd418 (patch)
treef14f44723f6825a0266952a10fcfecd3ee2e41c5 /ports-mgmt
parentba2ba48eddaa3497048adf481253f1bce466bcab (diff)
downloadports-c81071045556832e93b90a70708fbca06a1bd418.tar.gz
ports-c81071045556832e93b90a70708fbca06a1bd418.zip
ports-mgmt/portlint: Update to 2.19.7
* Account for LEGAL_TEXT and per-ARCH DISTFILES in the Makefile sections [1] * Relax USE_LDCONFIG checks now that we don't need a specific lib pattern [2] PR: 255764 [1] 255651 [2]
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/portlint/Makefile3
-rw-r--r--ports-mgmt/portlint/src/portlint.pl25
2 files changed, 9 insertions, 19 deletions
diff --git a/ports-mgmt/portlint/Makefile b/ports-mgmt/portlint/Makefile
index a4d37b63d107..d21f0898cb4f 100644
--- a/ports-mgmt/portlint/Makefile
+++ b/ports-mgmt/portlint/Makefile
@@ -1,8 +1,7 @@
# Created by: Jun-ichiro itojun Hagino <itojun@itojun.org>
PORTNAME= portlint
-PORTVERSION= 2.19.6
-PORTREVISION= 1
+PORTVERSION= 2.19.7
CATEGORIES= ports-mgmt
MASTER_SITES= # none
DISTFILES= # none
diff --git a/ports-mgmt/portlint/src/portlint.pl b/ports-mgmt/portlint/src/portlint.pl
index 57c61cea5c01..e5d64f1a573d 100644
--- a/ports-mgmt/portlint/src/portlint.pl
+++ b/ports-mgmt/portlint/src/portlint.pl
@@ -14,7 +14,7 @@
# bsd.port.mk. There are significant differences in those so non-FreeBSD code
# was removed.
#
-# $MCom: portlint/portlint.pl,v 1.528 2021/05/14 16:53:31 jclarke Exp $
+# $MCom$
#
use strict;
@@ -49,7 +49,7 @@ $portdir = '.';
# version variables
my $major = 2;
my $minor = 19;
-my $micro = 6;
+my $micro = 7;
# default setting - for FreeBSD
my $portsdir = '/usr/ports';
@@ -593,7 +593,6 @@ sub checkplist {
my $owner_seen = 0;
my $group_seen = 0;
my $found_so = 0;
- my $found_naked_so = 0;
# Variables that are allowed to be out-of-sync in the XXXDIR check.
# E.g., %%PORTDOCS%%%%RUBY_MODDOCDIR%% will be OK because there is
@@ -809,10 +808,8 @@ sub checkplist {
$makevar{USE_LDCONFIG} eq '') {
&perror("WARN", $file, $., "installing shared libraries, ".
"please define USE_LDCONFIG as appropriate");
- } elsif ($_ =~ m|lib[^\/]+\.so\.\d+$|) {
+ } elsif ($_ =~ m|lib[^\/]+\.so[.\d]*$|) {
$found_so++;
- } elsif ($_ =~ m|lib[^\/]+\.so$|) {
- $found_naked_so++;
}
if ($_ =~ m|^share/icons/.*/| &&
@@ -947,14 +944,8 @@ sub checkplist {
}
if ($makevar{USE_LDCONFIG} ne '' && !$found_so) {
- if ($found_naked_so) {
- &perror("WARN", $file, -1, "You have defined USE_LDCONFIG, but this ".
- "port does not install shared objects in the format lib*.so.[0-9] ".
- "which ldconfig(8) needs to register them in the hints file.");
- } else {
- &perror("WARN", $file, -1, "You have defined USE_LDCONFIG, but this ".
- "port does not install any shared objects.");
- }
+ &perror("WARN", $file, -1, "You have defined USE_LDCONFIG, but this ".
+ "port does not install any shared objects.");
}
close(IN);
@@ -2709,7 +2700,7 @@ EOF
&checkorder('PORTNAME', $tmp, $file, qw(
PORTNAME PORTVERSION DISTVERSIONPREFIX DISTVERSION DISTVERSIONSUFFIX
PORTREVISION PORTEPOCH CATEGORIES MASTER_SITES MASTER_SITE_SUBDIR
-PROJECTHOST PKGNAMEPREFIX PKGNAMESUFFIX DISTNAME EXTRACT_SUFX DISTFILES
+PROJECTHOST PKGNAMEPREFIX PKGNAMESUFFIX DISTNAME EXTRACT_SUFX DISTFILES(_\w+)?
DIST_SUBDIR EXTRACT_ONLY
));
@@ -3080,7 +3071,7 @@ DIST_SUBDIR EXTRACT_ONLY
push(@varnames, qw(
PORTNAME PORTVERSION DISTVERSIONPREFIX DISTVERSION DISTVERSIONSUFFIX
PORTREVISION PORTEPOCH CATEGORIES MASTER_SITES MASTER_SITE_SUBDIR
-PROJECTHOST PKGNAMEPREFIX PKGNAMESUFFIX DISTNAME EXTRACT_SUFX DISTFILES
+PROJECTHOST PKGNAMEPREFIX PKGNAMESUFFIX DISTNAME EXTRACT_SUFX DISTFILES(_\w+)?
DIST_SUBDIR EXTRACT_ONLY
));
@@ -3255,7 +3246,7 @@ MAINTAINER COMMENT
@linestocheck = qw(
DEPRECATED EXPIRATION_DATE FORBIDDEN BROKEN(_\w+)? IGNORE(_\w+)?
ONLY_FOR_ARCHS ONLY_FOR_ARCHS_REASON(_\w+)?
-NOT_FOR_ARCHS NOT_FOR_ARCHS_REASON(_\w+)?
+NOT_FOR_ARCHS NOT_FOR_ARCHS_REASON(_\w+)? LEGAL_TEXT
);
my $brokenpattern = "^(" . join("|", @linestocheck) . ")[?+:]?=";