aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-06-20 16:03:00 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-06-20 16:15:53 +0000
commit1baaf40941f8079094f6c09c03fd6e715f149292 (patch)
tree5864fa0847853781a6494da3bfb204f1b797a8cf /www
parentaabe3498837afc3742dbf3c8f2ee558501a4d1eb (diff)
downloadports-1baaf40941f8079094f6c09c03fd6e715f149292.tar.gz
ports-1baaf40941f8079094f6c09c03fd6e715f149292.zip
www/py-google-cloud-audit-log: Add py-google-cloud-audit-log 0.1.0
The python classes generated from the google/cloud/audit protos in the googleapis/googleapis repository. WWW: https://github.com/googleapis/python-audit-log
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/py-google-cloud-audit-log/Makefile22
-rw-r--r--www/py-google-cloud-audit-log/distinfo3
-rw-r--r--www/py-google-cloud-audit-log/pkg-descr4
4 files changed, 30 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 71f9eee44517..89a48b3a73df 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1626,6 +1626,7 @@
SUBDIR += py-google-api-core
SUBDIR += py-google-api-python-client
SUBDIR += py-google-cloud-appengine-logging
+ SUBDIR += py-google-cloud-audit-log
SUBDIR += py-google-cloud-bigtable
SUBDIR += py-google-cloud-core
SUBDIR += py-google-cloud-datastore
diff --git a/www/py-google-cloud-audit-log/Makefile b/www/py-google-cloud-audit-log/Makefile
new file mode 100644
index 000000000000..67078e850741
--- /dev/null
+++ b/www/py-google-cloud-audit-log/Makefile
@@ -0,0 +1,22 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= google-cloud-audit-log
+PORTVERSION= 0.1.0
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Google Cloud Audit Protos
+
+LICENSE= APACHE20
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}googleapis-common-protos>=1.52.0:devel/py-googleapis-common-protos@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}protobuf>=3.6.0:devel/py-protobuf@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/www/py-google-cloud-audit-log/distinfo b/www/py-google-cloud-audit-log/distinfo
new file mode 100644
index 000000000000..f38fa8728d75
--- /dev/null
+++ b/www/py-google-cloud-audit-log/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1624189677
+SHA256 (google-cloud-audit-log-0.1.0.tar.gz) = 5bf5a53c641b13828154ab21fb209669be69d71cd462f5d6456bf87722fc0eeb
+SIZE (google-cloud-audit-log-0.1.0.tar.gz) = 6605
diff --git a/www/py-google-cloud-audit-log/pkg-descr b/www/py-google-cloud-audit-log/pkg-descr
new file mode 100644
index 000000000000..318834ba0fb5
--- /dev/null
+++ b/www/py-google-cloud-audit-log/pkg-descr
@@ -0,0 +1,4 @@
+The python classes generated from the google/cloud/audit protos in the
+googleapis/googleapis repository.
+
+WWW: https://github.com/googleapis/python-audit-log