aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/monitord/Makefile2
-rw-r--r--sysutils/monitord/files/patch-monitord.c11
2 files changed, 1 insertions, 12 deletions
diff --git a/sysutils/monitord/Makefile b/sysutils/monitord/Makefile
index 7f4a45d21ebc..c3e1d8a579b2 100644
--- a/sysutils/monitord/Makefile
+++ b/sysutils/monitord/Makefile
@@ -2,7 +2,7 @@
PORTNAME= monitord
PORTVERSION= 0.4.1
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= sysutils
MASTER_SITES= http://lissyara.su/distfiles/
diff --git a/sysutils/monitord/files/patch-monitord.c b/sysutils/monitord/files/patch-monitord.c
index e89f516c7ad9..0aa43953a66e 100644
--- a/sysutils/monitord/files/patch-monitord.c
+++ b/sysutils/monitord/files/patch-monitord.c
@@ -73,17 +73,6 @@
// Main loop
while(1) {
-@@ -290,8 +294,8 @@ int loop ( char **file, char *filename, int max_proc,
-
- bzero (param, sizeof(param));
- while ((token = strtok(NULL, " \t"))) {
-- strncat (param, " ", sizeof(param));
-- strncat (param, token, sizeof(param));
-+ strncat (param, " ", sizeof(*param));
-+ strncat (param, token, sizeof(*param));
- }
-
- /* Each line has a \n at the end which must be removed
@@ -355,18 +359,18 @@ int loop ( char **file, char *filename, int max_proc,
// printf("Couldn't open %s\n", buf);
}