aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--multimedia/mythtv/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/multimedia/mythtv/Makefile b/multimedia/mythtv/Makefile
index 085be8e39c3d..5e388319da82 100644
--- a/multimedia/mythtv/Makefile
+++ b/multimedia/mythtv/Makefile
@@ -1,7 +1,7 @@
PORTNAME= mythtv
DISTVERSIONPREFIX= v
DISTVERSION= 33.1
-PORTREVISION= 4
+PORTREVISION= 5
PORTEPOCH= 1
CATEGORIES= multimedia
@@ -15,8 +15,6 @@ ONLY_FOR_ARCHS= aarch64 amd64 i386 powerpc powerpc64 powerpc64le
.if ${/usr/bin/ld:L:tA} == /usr/bin/ld.lld
BROKEN_i386= ld: error: can't create dynamic relocation R_386_32 against local symbol in readonly segment
.endif
-DEPRECATED=Depends on deprecated www/qt5-webkit
-EXPIRATION_DATE=2023-12-31
LIB_DEPENDS= liblzo2.so:archivers/lzo2 \
libmp3lame.so:audio/lame \
@@ -54,7 +52,7 @@ USE_GL= gl
USE_LDCONFIG= yes
USE_QT= buildtools:build core dbus gui imageformats:run \
linguist:build multimedia network opengl qmake:build script \
- sql sql-mysql:run webkit widgets xml
+ sql sql-mysql:run widgets xml
USE_PERL5= run build
USE_XORG= x11 xv xrandr xxf86vm xinerama xext xcb
SHEBANG_FILES= programs/scripts/database/*.pl \
@@ -63,7 +61,8 @@ SHEBANG_FILES= programs/scripts/database/*.pl \
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix="${PREFIX}" --cc="${CC}" --cxx="${CXX}" \
--libxml2-path="${LOCALBASE}/include/libxml2" \
- --disable-audio-alsa
+ --disable-audio-alsa \
+ --disable-qtwebkit
CONFIGURE_ENV= QMAKESPEC="${QMAKESPEC}" MOC="${MOC}" \
QTDIR="${PREFIX}" PKG_CONFIG_PATH="${LOCALBASE}/libdata/pkgconfig"
MAKE_ENV= QTDIR="${PREFIX}" \