aboutsummaryrefslogtreecommitdiff
path: root/Mk/Uses/php.mk
diff options
context:
space:
mode:
Diffstat (limited to 'Mk/Uses/php.mk')
-rw-r--r--Mk/Uses/php.mk7
1 files changed, 4 insertions, 3 deletions
diff --git a/Mk/Uses/php.mk b/Mk/Uses/php.mk
index b4cc5a376b6c..2b7972fa7e05 100644
--- a/Mk/Uses/php.mk
+++ b/Mk/Uses/php.mk
@@ -391,9 +391,9 @@ _USE_PHP_ALL= bcmath bitset bz2 calendar ctype curl dba dom \
soap sockets sodium spl sqlite3 sysvmsg sysvsem sysvshm \
tidy tokenizer xml xmlreader xmlrpc xmlwriter xsl zip zlib
# version specific components
-_USE_PHP_VER74= ${_USE_PHP_ALL} pdf
-_USE_PHP_VER80= ${_USE_PHP_ALL}
-_USE_PHP_VER81= ${_USE_PHP_ALL}
+_USE_PHP_VER74= ${_USE_PHP_ALL} pdf zephir_parser
+_USE_PHP_VER80= ${_USE_PHP_ALL} zephir_parser
+_USE_PHP_VER81= ${_USE_PHP_ALL} zephir_parser
_USE_PHP_VER82= ${_USE_PHP_ALL}
bcmath_DEPENDS= math/php${PHP_VER}-bcmath
@@ -469,6 +469,7 @@ xmlrpc_DEPENDS= net/php${PHP_VER}-xmlrpc
. endif
xmlwriter_DEPENDS= textproc/php${PHP_VER}-xmlwriter
xsl_DEPENDS= textproc/php${PHP_VER}-xsl
+zephir_parser_DEPENDS= textproc/pecl-zephir_parser@${PHP_FLAVOR}
zip_DEPENDS= archivers/php${PHP_VER}-zip
zlib_DEPENDS= archivers/php${PHP_VER}-zlib