aboutsummaryrefslogtreecommitdiff
path: root/audio/mumble/files/patch-overlay__gl_CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'audio/mumble/files/patch-overlay__gl_CMakeLists.txt')
-rw-r--r--audio/mumble/files/patch-overlay__gl_CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/audio/mumble/files/patch-overlay__gl_CMakeLists.txt b/audio/mumble/files/patch-overlay__gl_CMakeLists.txt
new file mode 100644
index 000000000000..a6fa6fafdf06
--- /dev/null
+++ b/audio/mumble/files/patch-overlay__gl_CMakeLists.txt
@@ -0,0 +1,16 @@
+Install the 32-bit overlay library on FreeBSD-amd64
+
+--- overlay_gl/CMakeLists.txt.orig
++++ overlay_gl/CMakeLists.txt
+@@ -96,6 +96,11 @@ if(NOT APPLE)
+ "-ldl"
+ "-lrt"
+ )
++ endif()
++ endif()
++
++ if(${CMAKE_SYSTEM_NAME} STREQUAL "Linux" OR ${CMAKE_SYSTEM_NAME} STREQUAL "FreeBSD")
++ if(TARGET overlay_gl_x86)
+ # install 32bit overlay library
+ install(TARGETS overlay_gl_x86 LIBRARY DESTINATION "${MUMBLE_INSTALL_LIBDIR}")
+ endif()