aboutsummaryrefslogtreecommitdiff
path: root/deskutils/sigi/Makefile.crates
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/sigi/Makefile.crates')
-rw-r--r--deskutils/sigi/Makefile.crates159
1 files changed, 84 insertions, 75 deletions
diff --git a/deskutils/sigi/Makefile.crates b/deskutils/sigi/Makefile.crates
index 8c93ecc98e58..0823e566bae7 100644
--- a/deskutils/sigi/Makefile.crates
+++ b/deskutils/sigi/Makefile.crates
@@ -1,98 +1,107 @@
-CARGO_CRATES= atty-0.2.14 \
- autocfg-1.0.1 \
+CARGO_CRATES= android-tzdata-0.1.1 \
+ android_system_properties-0.1.5 \
+ anstream-0.3.2 \
+ anstyle-1.0.1 \
+ anstyle-parse-0.2.1 \
+ anstyle-query-1.0.0 \
+ anstyle-wincon-1.0.1 \
+ autocfg-1.1.0 \
bitflags-1.3.2 \
- cc-1.0.73 \
- cfg-if-0.1.10 \
+ bitflags-2.3.3 \
+ bumpalo-3.13.0 \
+ cc-1.0.79 \
cfg-if-1.0.0 \
- chrono-0.4.19 \
- clap-4.0.22 \
- clap_derive-4.0.21 \
- clap_lex-0.3.0 \
- clearscreen-2.0.0 \
- clipboard-win-4.4.1 \
+ chrono-0.4.26 \
+ clap-4.3.11 \
+ clap_builder-4.3.11 \
+ clap_derive-4.3.2 \
+ clap_lex-0.5.0 \
+ clearscreen-2.0.1 \
+ clipboard-win-4.5.0 \
+ colorchoice-1.0.0 \
+ core-foundation-sys-0.8.4 \
directories-4.0.1 \
- dirs-2.0.2 \
+ dirs-4.0.0 \
dirs-next-2.0.0 \
dirs-sys-0.3.7 \
dirs-sys-next-0.1.2 \
- either-1.6.1 \
+ either-1.8.1 \
endian-type-0.1.2 \
- errno-0.2.8 \
+ errno-0.3.1 \
errno-dragonfly-0.1.2 \
error-code-2.3.1 \
- fd-lock-3.0.6 \
+ fd-lock-3.0.13 \
fnv-1.0.7 \
- getrandom-0.1.16 \
- getrandom-0.2.6 \
- heck-0.4.0 \
- hermit-abi-0.1.18 \
- io-lifetimes-0.7.2 \
- itoa-0.4.7 \
+ getrandom-0.2.10 \
+ heck-0.4.1 \
+ hermit-abi-0.3.2 \
+ iana-time-zone-0.1.57 \
+ iana-time-zone-haiku-0.1.2 \
+ is-terminal-0.4.9 \
+ itoa-1.0.8 \
+ js-sys-0.3.64 \
json-0.12.4 \
- libc-0.2.139 \
- linux-raw-sys-0.0.46 \
- log-0.4.16 \
- memchr-2.4.1 \
+ libc-0.2.147 \
+ linux-raw-sys-0.4.3 \
+ log-0.4.19 \
+ memchr-2.5.0 \
+ minimal-lexical-0.2.1 \
nibble_vec-0.1.0 \
- nix-0.24.2 \
- nix-0.26.1 \
- nom-5.1.2 \
- num-integer-0.1.44 \
- num-traits-0.2.14 \
- once_cell-1.12.0 \
- os_str_bytes-6.0.0 \
- phf-0.8.0 \
- phf_codegen-0.8.0 \
- phf_generator-0.8.0 \
- phf_shared-0.8.0 \
- ppv-lite86-0.2.16 \
- proc-macro-error-1.0.4 \
- proc-macro-error-attr-1.0.4 \
- proc-macro2-1.0.47 \
+ nix-0.26.2 \
+ nom-7.1.3 \
+ num-traits-0.2.15 \
+ once_cell-1.18.0 \
+ phf-0.11.2 \
+ phf_codegen-0.11.2 \
+ phf_generator-0.11.2 \
+ phf_shared-0.11.2 \
+ proc-macro2-1.0.63 \
pure-rust-locales-0.5.6 \
- quote-1.0.9 \
+ quote-1.0.29 \
radix_trie-0.2.1 \
- rand-0.7.3 \
- rand_chacha-0.2.2 \
- rand_core-0.5.1 \
- rand_hc-0.2.0 \
- rand_pcg-0.2.1 \
- redox_syscall-0.2.13 \
+ rand-0.8.5 \
+ rand_core-0.6.4 \
+ redox_syscall-0.2.16 \
redox_users-0.4.3 \
- rustix-0.35.6 \
- rustyline-10.0.0 \
- ryu-1.0.5 \
+ rustix-0.38.3 \
+ rustyline-11.0.0 \
+ ryu-1.0.14 \
scopeguard-1.1.0 \
- serde-1.0.123 \
- serde_derive-1.0.123 \
- serde_json-1.0.64 \
+ serde-1.0.167 \
+ serde_derive-1.0.167 \
+ serde_json-1.0.100 \
siphasher-0.3.10 \
- smallvec-1.8.0 \
+ smallvec-1.11.0 \
static_assertions-1.1.0 \
- str-buf-1.0.5 \
+ str-buf-1.0.6 \
strsim-0.10.0 \
- syn-1.0.86 \
- termcolor-1.1.2 \
- terminfo-0.7.3 \
- thiserror-1.0.38 \
- thiserror-impl-1.0.38 \
- time-0.1.44 \
- unicode-ident-1.0.5 \
- unicode-segmentation-1.9.0 \
- unicode-width-0.1.9 \
- unicode-xid-0.2.1 \
- utf8parse-0.2.0 \
- version_check-0.9.4 \
- wasi-0.9.0+wasi-snapshot-preview1 \
+ syn-2.0.23 \
+ terminfo-0.8.0 \
+ thiserror-1.0.43 \
+ thiserror-impl-1.0.43 \
+ time-0.1.45 \
+ unicode-ident-1.0.10 \
+ unicode-segmentation-1.10.1 \
+ unicode-width-0.1.10 \
+ utf8parse-0.2.1 \
wasi-0.10.0+wasi-snapshot-preview1 \
- which-4.3.0 \
+ wasi-0.11.0+wasi-snapshot-preview1 \
+ wasm-bindgen-0.2.87 \
+ wasm-bindgen-backend-0.2.87 \
+ wasm-bindgen-macro-0.2.87 \
+ wasm-bindgen-macro-support-0.2.87 \
+ wasm-bindgen-shared-0.2.87 \
+ which-4.4.0 \
winapi-0.3.9 \
winapi-i686-pc-windows-gnu-0.4.0 \
- winapi-util-0.1.5 \
winapi-x86_64-pc-windows-gnu-0.4.0 \
- windows-sys-0.36.1 \
- windows_aarch64_msvc-0.36.1 \
- windows_i686_gnu-0.36.1 \
- windows_i686_msvc-0.36.1 \
- windows_x86_64_gnu-0.36.1 \
- windows_x86_64_msvc-0.36.1
+ windows-0.48.0 \
+ windows-sys-0.48.0 \
+ windows-targets-0.48.1 \
+ windows_aarch64_gnullvm-0.48.0 \
+ windows_aarch64_msvc-0.48.0 \
+ windows_i686_gnu-0.48.0 \
+ windows_i686_msvc-0.48.0 \
+ windows_x86_64_gnu-0.48.0 \
+ windows_x86_64_gnullvm-0.48.0 \
+ windows_x86_64_msvc-0.48.0