aboutsummaryrefslogtreecommitdiff
path: root/devel/rubygem-aws-sdk-mgn/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/rubygem-aws-sdk-mgn/Makefile')
-rw-r--r--devel/rubygem-aws-sdk-mgn/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/devel/rubygem-aws-sdk-mgn/Makefile b/devel/rubygem-aws-sdk-mgn/Makefile
new file mode 100644
index 000000000000..224b04a4a989
--- /dev/null
+++ b/devel/rubygem-aws-sdk-mgn/Makefile
@@ -0,0 +1,22 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= aws-sdk-mgn
+PORTVERSION= 1.0.0
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Official AWS Ruby gem for Application Migration Service (mgn)
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= rubygem-aws-sdk-core>=3.112.0<4:devel/rubygem-aws-sdk-core \
+ rubygem-aws-sigv4>=1.1<2:devel/rubygem-aws-sigv4
+
+USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>