aboutsummaryrefslogtreecommitdiff
path: root/games/openra/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/openra/Makefile')
-rw-r--r--games/openra/Makefile22
1 files changed, 9 insertions, 13 deletions
diff --git a/games/openra/Makefile b/games/openra/Makefile
index 48308ab3ba16..aa1d4540e05e 100644
--- a/games/openra/Makefile
+++ b/games/openra/Makefile
@@ -1,14 +1,12 @@
PORTNAME= openra
DISTVERSIONPREFIX= release-
-DISTVERSION= 20200503
-PORTREVISION= 7
+DISTVERSION= 20210321
CATEGORIES= games
MASTER_SITES= https://download.ip2location.com/lite/:ip2location
DISTFILES= IP2LOCATION-LITE-DB1.IPV6.BIN.ZIP:ip2location
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
-PATCHFILES+= e13fd693c386.patch:-p1 # https://github.com/OpenRA/OpenRA/pull/17744
-PATCHFILES+= 85096c4ba2fb.patch:-p1 # https://github.com/OpenRA/OpenRA/pull/17744
+PATCHFILES+= ee0d37f2b1c4.patch:-p1 # https://github.com/OpenRA/OpenRA/pull/20041
MAINTAINER= jbeich@FreeBSD.org
COMMENT= Multiplayer re-envisioning of early RTS games by Westwood Studios
@@ -19,7 +17,8 @@ LICENSE= GPLv3
BUILD_DEPENDS= msbuild:devel/msbuild
LIB_DEPENDS= libfreetype.so:print/freetype2 \
libgdiplus.so:x11-toolkits/libgdiplus
-NUGET_DEPENDS= Microsoft.NETFramework.ReferenceAssemblies=1.0.0 \
+NUGET_DEPENDS= DiscordRichPresence=1.0.150 \
+ Microsoft.NETFramework.ReferenceAssemblies=1.0.0 \
Microsoft.NETFramework.ReferenceAssemblies.net472=1.0.0 \
NUnit=3.12.0 \
NUnit.Console=3.11.1 \
@@ -30,13 +29,14 @@ NUGET_DEPENDS= Microsoft.NETFramework.ReferenceAssemblies=1.0.0 \
NUnit.Extension.TeamCityEventListener=1.0.7 \
NUnit.Extension.VSProjectLoader=3.8.0 \
NUnit3TestAdapter=3.16.1 \
+ Newtonsoft.Json=12.0.2 \
NuGet.CommandLine=4.4.1 \
OpenRA-Eluant=1.0.17 \
OpenRA-Freetype6=1.0.4 \
OpenRA-FuzzyLogicLibrary=1.0.1 \
OpenRA-Open.NAT=1.0.0 \
OpenRA-OpenAL-CS=1.0.16 \
- OpenRA-SDL2-CS=1.0.26 \
+ OpenRA-SDL2-CS=1.0.28 \
SharpZipLib=1.2.0 \
StyleCop.Analyzers=1.1.118 \
rix0rrr.BeaconLib=1.0.2
@@ -51,8 +51,7 @@ USE_SDL= sdl2
MAKE_ENV= prefix="${PREFIX}" \
gameinstalldir="${DATADIR}"
ALL_TARGET= all
-INSTALL_TARGET= install install-man-page \
- install-linux-appdata install-linux-mime install-linux-shortcuts
+INSTALL_TARGET= install install-man install-linux-appdata install-linux-shortcuts
PORTDATA= *
.include <bsd.port.pre.mk>
@@ -69,11 +68,8 @@ post-patch:
-e 's/ -verbosity:m//' \
-e '/echo/!s/ @/ /' \
-e '/^VERSION/s/=.*/= ${GH_TAGNAME}/' \
- -e '/^core:/s/$$/ version/' \
+ -e '/^all:/s/$$/ version/' \
${WRKSRC}/Makefile
-.if defined(PATCHFILES)
- ${CHMOD} +x ${WRKSRC}/configure-system-libraries.sh
-.endif
${REINPLACE_CMD} -e 's,/usr/local,${LOCALBASE},' \
-e '/target/s,$${DIR}/,,' \
${WRKSRC}/configure-system-libraries.sh
@@ -81,6 +77,6 @@ post-patch:
do-test:
@(cd ${TEST_WRKSRC} && mono \
${NUGET_PACKAGEDIR}/NUnit.ConsoleRunner/tools/nunit3-console.exe \
- --noresult OpenRA.Test.dll)
+ --noresult bin/OpenRA.Test.dll)
.include <bsd.port.post.mk>