aboutsummaryrefslogtreecommitdiff
path: root/lang/dhall/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/dhall/Makefile')
-rw-r--r--lang/dhall/Makefile120
1 files changed, 120 insertions, 0 deletions
diff --git a/lang/dhall/Makefile b/lang/dhall/Makefile
new file mode 100644
index 000000000000..7762538359a1
--- /dev/null
+++ b/lang/dhall/Makefile
@@ -0,0 +1,120 @@
+PORTNAME= dhall
+PORTVERSION= 1.41.1
+CATEGORIES= lang haskell
+
+MAINTAINER= malcolm.matalka@acsl.se
+COMMENT= Explicitly typed configuration language
+
+LICENSE= BSD3CLAUSE
+
+USES= cabal
+
+USE_CABAL= Diff-0.4.1 \
+ OneTuple-0.3.1_2 \
+ QuickCheck-2.14.2 \
+ StateVar-1.2.2 \
+ aeson-2.0.3.0 \
+ aeson-pretty-0.8.9_1 \
+ ansi-terminal-0.11.3 \
+ ansi-wl-pprint-0.6.9_3 \
+ appar-0.1.8 \
+ asn1-encoding-0.9.6_2 \
+ asn1-parse-0.9.5 \
+ asn1-types-0.3.4 \
+ assoc-1.0.2_2 \
+ async-2.2.4_1 \
+ atomic-write-0.2.0.7 \
+ attoparsec-0.14.4_1 \
+ base-compat-0.12.1 \
+ base-compat-batteries-0.12.1_2 \
+ base-orphans-0.8.6 \
+ base16-bytestring-1.0.2.0 \
+ base64-bytestring-1.2.1.0 \
+ basement-0.0.14 \
+ bifunctors-5.5.12 \
+ blaze-builder-0.4.2.2_1 \
+ byteorder-1.0.4 \
+ cabal-doctest-1.0.9_1 \
+ case-insensitive-1.2.1.0 \
+ cborg-0.2.7.0_1 \
+ cborg-json-0.2.4.0 \
+ cereal-0.5.8.2_1 \
+ charset-0.3.9 \
+ colour-2.3.6 \
+ comonad-5.0.8_1 \
+ connection-0.3.1_1 \
+ contravariant-1.5.5 \
+ cookie-0.4.5 \
+ cryptohash-sha256-0.11.102.1 \
+ cryptonite-0.30 \
+ data-default-class-0.1.2.0 \
+ data-fix-0.3.2_2 \
+ distributive-0.6.2.1_1 \
+ dlist-1.0 \
+ dotgen-0.4.3 \
+ either-5.0.2 \
+ half-0.3.1 \
+ hashable-1.4.0.2 \
+ hourglass-0.2.12 \
+ hsc2hs-0.68.8 \
+ http-client-0.7.11_1 \
+ http-client-tls-0.3.6.1 \
+ http-types-0.12.3 \
+ indexed-traversable-0.1.2_1 \
+ indexed-traversable-instances-0.1.1 \
+ integer-logarithms-1.0.3.1_2 \
+ iproute-1.7.12 \
+ lens-family-core-2.1.0 \
+ megaparsec-9.2.1 \
+ memory-0.17.0 \
+ mime-types-0.1.0.9 \
+ mmorph-1.2.0_2 \
+ network-3.1.2.7 \
+ network-uri-2.6.4.1 \
+ optparse-applicative-0.17.0.0 \
+ parser-combinators-1.3.0 \
+ parsers-0.12.11 \
+ pem-0.2.4 \
+ pretty-simple-4.1.1.0 \
+ prettyprinter-1.7.1 \
+ prettyprinter-ansi-terminal-1.1.3 \
+ primitive-0.7.3.0_2 \
+ profunctors-5.6.2_2 \
+ random-1.2.1.1 \
+ repline-0.4.2.0 \
+ scientific-0.3.7.0_2 \
+ semialign-1.2.0.1_1 \
+ semigroupoids-5.3.7 \
+ serialise-0.2.5.0 \
+ socks-0.6.1 \
+ splitmix-0.1.0.4 \
+ streaming-commons-0.2.2.4 \
+ strict-0.4.0.1_4 \
+ tagged-0.8.6.1_2 \
+ temporary-1.3 \
+ text-manipulate-0.3.1.0 \
+ text-short-0.1.5 \
+ th-abstraction-0.4.3.0 \
+ th-compat-0.1.3_1 \
+ th-lift-0.8.2_1 \
+ th-lift-instances-0.1.19 \
+ these-1.1.1.1_5 \
+ time-compat-1.9.6.1_3 \
+ tls-1.6.0 \
+ transformers-compat-0.7.1_1 \
+ unix-compat-0.6 \
+ unordered-containers-0.2.19.1 \
+ uri-encode-1.5.0.7_2 \
+ utf8-string-1.0.2 \
+ uuid-types-1.0.5_2 \
+ vector-0.12.3.1_2 \
+ witherable-0.4.2_2 \
+ x509-1.7.7 \
+ x509-store-1.6.9 \
+ x509-system-1.6.7 \
+ x509-validation-1.6.12 \
+ zlib-0.6.3.0
+
+CABAL_PROJECT= remove
+
+.include <bsd.port.mk>