aboutsummaryrefslogtreecommitdiff
path: root/mail/openarc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/openarc/Makefile')
-rw-r--r--mail/openarc/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/mail/openarc/Makefile b/mail/openarc/Makefile
new file mode 100644
index 000000000000..81c7427a14bb
--- /dev/null
+++ b/mail/openarc/Makefile
@@ -0,0 +1,33 @@
+PORTNAME= openarc
+PORTVERSION= 1.0.0.b3.20201016
+PORTREVISION= 1
+CATEGORIES= mail
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Library to validate use of certain identifiers in messages
+
+LICENSE= AGPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= autoconf-archive>0:devel/autoconf-archive
+LIB_DEPENDS= libjansson.so:devel/jansson
+
+USES= autoreconf gmake libtool pkgconfig ssl
+USE_LDCONFIG= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= trusteddomainproject
+GH_PROJECT= OpenARC
+GH_TAGNAME= eb430db
+
+GNU_CONFIGURE= yes
+
+USE_RC_SUBR= ${PORTNAME}
+
+INSTALL_TARGET= install-strip
+
+OPTIONS_DEFINE= DOCS
+
+PORTDOCS= *
+
+.include <bsd.port.mk>