aboutsummaryrefslogtreecommitdiff
path: root/mail/postsrsd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/postsrsd/Makefile')
-rw-r--r--mail/postsrsd/Makefile33
1 files changed, 12 insertions, 21 deletions
diff --git a/mail/postsrsd/Makefile b/mail/postsrsd/Makefile
index 85d67c883672..18b7bee90abb 100644
--- a/mail/postsrsd/Makefile
+++ b/mail/postsrsd/Makefile
@@ -1,44 +1,35 @@
PORTNAME= postsrsd
-DISTVERSION= 2.0.6
+DISTVERSION= 1.10
+PORTEPOCH= 1
CATEGORIES= mail
MAINTAINER= ports@bsdserwis.com
COMMENT= Postfix Sender Rewriting Scheme daemon
WWW= https://github.com/roehling/postsrsd
-LICENSE= BSD3CLAUSE GPLv3+
-LICENSE_COMB= dual
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/LICENSE
-LIB_DEPENDS= libconfuse.so:devel/libconfuse
+BUILD_DEPENDS= help2man:misc/help2man
USES= cmake cpe pkgconfig
-USE_LDCONFIG= yes
-
CPE_VENDOR= ${PORTNAME}_project
USE_GITHUB= yes
GH_ACCOUNT= roehling
USE_RC_SUBR= ${PORTNAME}
-OPTIONS_DEFINE= DOCS REDIS
-
-DOCS_CMAKE_BOOL= ENABLE_DOCS
-
-REDIS_DESC= Store envelope senders in redis
-REDIS_LIB_DEPENDS= libhiredis.so:databases/hiredis
-REDIS_CMAKE_BOOL= WITH_REDIS
-
CMAKE_ARGS= --no-warn-unused-cli \
- -DBUILD_TESTING=OFF \
- -DCMAKE_BUILD_TYPE=Release \
- -DFETCHCONTENT_TRY_FIND_PACKAGE_MODE=ALWAYS \
-DCMAKE_INCLUDE_PATH="${LOCALBASE}/include" \
-DCMAKE_LIBRARY_PATH="${LOCALBASE}/lib"
-PLIST_FILES= \
- sbin/postsrsd \
- ${LOCALBASE}/etc/${PORTNAME}.secret
+PLIST_FILES= man/man8/postsrsd.8.gz \
+ sbin/postsrsd
+
+PORTDOCS= README.md README_UPGRADE.md main.cf.ex
-PORTDOCS= README.rst CHANGELOG.rst postsrsd.conf
+OPTIONS_DEFINE= DOCS
+
+DOCS_CMAKE_BOOL= ENABLE_DOCS
.include <bsd.port.mk>