aboutsummaryrefslogtreecommitdiff
path: root/math/chuffed/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/chuffed/Makefile')
-rw-r--r--math/chuffed/Makefile18
1 files changed, 6 insertions, 12 deletions
diff --git a/math/chuffed/Makefile b/math/chuffed/Makefile
index 218e4b15bc49..22009192b674 100644
--- a/math/chuffed/Makefile
+++ b/math/chuffed/Makefile
@@ -1,5 +1,5 @@
PORTNAME= chuffed
-DISTVERSION= 0.10.4
+DISTVERSION= 0.10.4.20210104
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
@@ -10,21 +10,15 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USES= bison cmake compiler:c++11-lang
USE_GITHUB= yes
+GH_TAGNAME= e04bedd # devel branch: only devel branch is compatible with the current MiniZinc
-GH_TUPLE= cp-profiler:cpp-integration:d695d93:cpi/submodules/cp-profiler-integration
+GH_TUPLE= cp-profiler:cpp-integration:f16b313:cpi/submodules/cp-profiler-integration
-CXXFLAGS+= -I${BUILD_WRKSRC}/chuffed/flatzinc # workaround for: fatal error: 'parser.tab.h' file not found, see https://github.com/chuffed/chuffed/issues/75
-
-post-patch: # workaround for: unknown symbol YYEMPTY: wrong parser.tab.h is used by the build, see https://github.com/chuffed/chuffed/issues/75
- @${RM} ${WRKSRC}/chuffed/flatzinc/parser.tab.h
+DATADIR= ${PREFIX}/share/minizinc/chuffed
post-install:
- # move the msc file where MiniZinc looks for it, see https://github.com/chuffed/chuffed/issues/74
- cd ${STAGEDIR}${PREFIX} && \
- ${MKDIR} share/minizinc/solvers && \
- ${MV} chuffed.msc share/minizinc/solvers
- # adjust mzn executable and lib paths for MiniZinc to find them
- ${REINPLACE_CMD} -i '' -e 's|bin/|${PREFIX}/&| ; s|share/chuffed/|${PREFIX}/&|' \
+ # correct version in the config file
+ ${REINPLACE_CMD} -i '' -e 's|"version": ".*",|"version": "${PORTVERSION}",|' \
${STAGEDIR}${PREFIX}/share/minizinc/solvers/chuffed.msc
.include <bsd.port.mk>