aboutsummaryrefslogtreecommitdiff
path: root/misc/hs-hascard/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/hs-hascard/Makefile')
-rw-r--r--misc/hs-hascard/Makefile108
1 files changed, 52 insertions, 56 deletions
diff --git a/misc/hs-hascard/Makefile b/misc/hs-hascard/Makefile
index c3406f5f04dc..ba9a0ac74170 100644
--- a/misc/hs-hascard/Makefile
+++ b/misc/hs-hascard/Makefile
@@ -1,81 +1,77 @@
PORTNAME= hascard
-DISTVERSION= 0.5.0.3.1
-PORTREVISION= 1
+DISTVERSION= 0.6.0.1
CATEGORIES= misc haskell
MAINTAINER= yuri@FreeBSD.org
-COMMENT= Minimal command line utility for reviewing notes
-WWW= https://github.com/Yvee1/hascard
+COMMENT= Minimal command-line utility for reviewing notes
+WWW= https://github.com/Yvee1/hascard/
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ghc-9.2.8:lang/ghc92
-
USES= cabal
+
USE_CABAL= MonadPrompt-1.0.0.5 \
- MonadRandom-0.6 \
- QuickCheck-2.14.2 \
- StateVar-1.2.2 \
- ansi-terminal-0.11.3 \
- ansi-wl-pprint-0.6.9_3 \
- assoc-1.0.2_3 \
- base-orphans-0.8.7 \
- bifunctors-5.5.13 \
- blaze-builder-0.4.2.2_1 \
- brick-0.70 \
+ MonadRandom-0.6_4 \
+ QuickCheck-2.14.3 \
+ ansi-terminal-1.1 \
+ ansi-terminal-types-1.1 \
+ assoc-1.1_1 \
+ bimap-0.5.0 \
+ blaze-builder-0.4.2.3 \
+ brick-2.3.1 \
call-stack-0.4.0 \
case-insensitive-1.2.1.0 \
- clock-0.8.3 \
+ clock-0.8.4 \
colour-2.3.6 \
- comonad-5.0.8_1 \
- config-ini-0.2.5.0 \
- contravariant-1.5.5 \
- data-clist-0.2 \
+ config-ini-0.2.7.0_1 \
+ data-clist-0.2_1 \
data-default-class-0.1.2.0 \
- distributive-0.6.2.1_1 \
- dlist-1.0 \
erf-2.0.0.0 \
- hashable-1.4.1.0 \
- indexed-traversable-0.1.2_2 \
- integer-logarithms-1.0.3.1_3 \
- math-functions-0.3.4.2 \
- megaparsec-9.2.2 \
- microlens-0.4.12.0 \
- microlens-ghc-0.4.13.2 \
- microlens-mtl-0.2.0.2 \
- microlens-platform-0.4.2.1 \
- microlens-th-0.4.3.10_1 \
+ extra-1.7.14 \
+ hashable-1.4.4.0_1 \
+ integer-logarithms-1.0.3.1_6 \
+ math-functions-0.3.4.4 \
+ megaparsec-9.6.1 \
+ microlens-0.4.13.1_1 \
+ microlens-ghc-0.4.14.2 \
+ microlens-mtl-0.2.0.3_1 \
+ microlens-platform-0.4.3.5 \
+ microlens-th-0.4.3.14 \
monad-loops-0.4.3 \
mwc-random-0.15.0.2_1 \
- optparse-applicative-0.17.0.0 \
+ optparse-applicative-0.18.1.0 \
ordered-containers-0.2.3 \
- parallel-3.2.2.0_5 \
- parser-combinators-1.3.0 \
- primitive-0.7.4.0 \
- random-1.2.1.1 \
- random-fu-0.3.0.0 \
+ os-string-2.0.2 \
+ parser-combinators-1.3.0_1 \
+ prettyprinter-1.7.1 \
+ prettyprinter-ansi-terminal-1.1.3 \
+ primitive-0.9.0.0_1 \
+ random-1.2.1.2 \
+ random-fu-0.3.0.1 \
random-shuffle-0.0.4 \
- rvar-0.3.0.1 \
- scientific-0.3.7.0_3 \
- split-0.2.3.5 \
- splitmix-0.1.0.4_1 \
- strict-0.4.0.1_4 \
- syb-0.7.2.2 \
- tagged-0.8.6.1_3 \
- tasty-1.4.2.3 \
- tasty-hunit-0.10.0.3 \
+ rvar-0.3.0.2 \
+ scientific-0.3.7.0_7 \
+ split-0.2.5 \
+ splitmix-0.1.0.5_1 \
+ strict-0.5_1 \
+ syb-0.7.2.4 \
+ tagged-0.8.8_1 \
+ tasty-1.4.3 \
+ tasty-hunit-0.10.1 \
tasty-quickcheck-0.10.2 \
- text-zipper-0.12 \
- th-abstraction-0.4.5.0 \
- these-1.1.1.1_6 \
+ text-zipper-0.13 \
+ th-abstraction-0.6.0.0_2 \
+ these-1.2_1 \
transformers-compat-0.7.2 \
- unbounded-delays-0.1.1.1 \
- unordered-containers-0.2.19.1_1 \
+ unix-compat-0.7.1 \
+ unordered-containers-0.2.20_1 \
utf8-string-1.0.2 \
- vector-0.12.3.1_2 \
- vty-5.35.1 \
- wcwidth-0.0.2 \
+ vector-0.13.1.0_1 \
+ vector-stream-0.1.0.1_1 \
+ vty-6.2 \
+ vty-crossplatform-0.4.0.0 \
+ vty-unix-0.2.0.0 \
word-wrap-0.5
.include <bsd.port.mk>