aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/virt-viewer/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/virt-viewer/Makefile')
-rw-r--r--net-mgmt/virt-viewer/Makefile51
1 files changed, 31 insertions, 20 deletions
diff --git a/net-mgmt/virt-viewer/Makefile b/net-mgmt/virt-viewer/Makefile
index 06e45ad2a108..19b76f5100b0 100644
--- a/net-mgmt/virt-viewer/Makefile
+++ b/net-mgmt/virt-viewer/Makefile
@@ -1,7 +1,7 @@
# Created by: Jason Helfman <jgh@FreeBSD.org>
PORTNAME= virt-viewer
-PORTVERSION= 9.0
+PORTVERSION= 10.0
CATEGORIES= net-mgmt
MASTER_SITES= https://virt-manager.org/download/sources/${PORTNAME}/
@@ -10,28 +10,39 @@ COMMENT= Provides a graphical viewer for a guest OS display
LICENSE= GPLv2
-BUILD_DEPENDS= xml2-config:textproc/libxml2 \
- intltoolize:textproc/intltool \
- spice-protocol>=0.12.7:devel/spice-protocol
-LIB_DEPENDS= libvirt.so:devel/libvirt \
- libvirt-glib-1.0.so:devel/libvirt-glib \
- libgtk-vnc-2.0.so:net/gtk-vnc \
- libspice-client-glib-2.0.so:deskutils/spice-gtk
+USES= cpe desktop-file-utils gettext gettext-tools gmake gnome \
+ libtool meson pkgconfig python:3.6+,build shared-mime-info xorg tar:xz
+CPE_VENDOR= redhat
+USE_GNOME= gtk30 libxml2
+INSTALLS_ICONS= yes
+USE_XORG= xorgproto
+BINARY_ALIAS= python3=${PYTHON_CMD}
-OPTIONS_DEFINE= NLS
+OPTIONS_DEFINE= SPICE VNC LIBVIRT VTE
+OPTIONS_DEFAULT= SPICE VNC LIBVIRT VTE
OPTIONS_SUB= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ENV+= DATADIRNAME=share
-CONFIGURE_ARGS= --with-spice-gtk
-USES= autoreconf cpe desktop-file-utils gettext-tools gmake gnome \
- libtool pkgconfig shared-mime-info xorg
-USE_GNOME= gtk30
-USE_XORG= xorgproto
-INSTALLS_ICONS= yes
-CPE_VENDOR= redhat
+SPICE_DESC= SPICE support
+VNC_DESC= VNC support
+VTE_DESC= VTE support
+
+LIBVIRT_LIB_DEPENDS= libvirt.so:devel/libvirt \
+ libvirt-glib-1.0.so:devel/libvirt-glib
+LIBVIRT_MESON_ENABLED= libvirt
+
+SPICE_BUILD_DEPENDS= spice-protocol>=0.12.7:devel/spice-protocol
+SPICE_LIB_DEPENDS= libspice-client-glib-2.0.so:deskutils/spice-gtk
+SPICE_MESON_ENABLED= spice
+
+VNC_LIB_DEPENDS= libgtk-vnc-2.0.so:net/gtk-vnc
+VNC_MESON_ENABLED= vnc
+
+VTE_MESON_ENABLED= vte
+
+.include <bsd.port.options.mk>
-NLS_USES= gettext
-NLS_CONFIGURE_ENABLE= nls
+.if ${PORT_OPTIONS:MVTE}
+USE_GNOME+= vte3
+.endif
.include <bsd.port.mk>