aboutsummaryrefslogtreecommitdiff
path: root/net/rsplib/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/rsplib/Makefile')
-rw-r--r--net/rsplib/Makefile17
1 files changed, 8 insertions, 9 deletions
diff --git a/net/rsplib/Makefile b/net/rsplib/Makefile
index 8b2fe1ddd2c9..eb8228a6bacf 100644
--- a/net/rsplib/Makefile
+++ b/net/rsplib/Makefile
@@ -1,24 +1,23 @@
PORTNAME= rsplib
-PORTVERSION= 3.3.1
+DISTVERSION= 3.4.7
CATEGORIES= net
-MASTER_SITES= https://www.uni-due.de/~be0001/rserpool/download/
+MASTER_SITES= https://www.nntb.no/~dreibh/rserpool/download/
-MAINTAINER= dreibh@iem.uni-due.de
+MAINTAINER= thomas.dreibholz@gmail.com
COMMENT= RSerPool Framework and Example Applications
-WWW= https://www.uni-due.de/~be0001/rserpool/
+WWW= https://www.nntb.no/~dreibh/rserpool/
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
USES= cmake compiler:c++11-lang qt:5 shebangfix tar:xz
+SHEBANG_FILES= src/scriptingserviceexample
USE_LDCONFIG= yes
USE_QT= buildtools:build core gui qmake widgets xml
-CMAKE_ARGS+= -DCMAKE_INSTALL_MANDIR=${PREFIX}/man \
- -DDOCSDIR="${DOCSDIR}" \
- -DUSE_KERNEL_SCTP=1 -DENABLE_CSP=1 -DENABLE_QT=1
-SHEBANG_FILES= src/scriptingserviceexample
+PLIST_SUB= DISTVERSION=${DISTVERSION}
-PLIST_SUB= VERSION=${PORTVERSION}
+CMAKE_ARGS= -DCMAKE_INSTALL_DOCDIR=${DOCSDIR} \
+ -DUSE_KERNEL_SCTP=1 -DENABLE_CSP=1 -DENABLE_QT=1
.include <bsd.port.mk>