aboutsummaryrefslogtreecommitdiff
path: root/science/helfem/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'science/helfem/Makefile')
-rw-r--r--science/helfem/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/science/helfem/Makefile b/science/helfem/Makefile
new file mode 100644
index 000000000000..211a0022a6cd
--- /dev/null
+++ b/science/helfem/Makefile
@@ -0,0 +1,26 @@
+PORTNAME= helfem
+DISTVERSION= g20210807
+CATEGORIES= science # chemistry
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Finite element methods for electronic structure calculations
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libarmadillo.so:math/armadillo \
+ libgsl.so:math/gsl \
+ libhdf5_cpp.so:science/hdf5 \
+ libsz.so:science/szip \
+ libxc.so:science/libxc
+
+USES= cmake fortran
+
+USE_GITHUB= yes
+GH_ACCOUNT= susilehtola
+GH_PROJECT= HelFEM
+GH_TAGNAME= b6d8c11
+
+CMAKE_ON= HELFEM_FIND_DEPS # BUILD_SHARED_LIBS is broken, see https://github.com/susilehtola/HelFEM/issues/5
+
+.include <bsd.port.mk>