aboutsummaryrefslogtreecommitdiff
path: root/science/massxpert/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'science/massxpert/Makefile')
-rw-r--r--science/massxpert/Makefile26
1 files changed, 12 insertions, 14 deletions
diff --git a/science/massxpert/Makefile b/science/massxpert/Makefile
index 9042cc28d20c..892bbb753a16 100644
--- a/science/massxpert/Makefile
+++ b/science/massxpert/Makefile
@@ -1,32 +1,30 @@
# Created by: Veniamin Gvozdikov <vg@FreeBSD.org>
PORTNAME= massxpert
-DISTVERSION= 3.6.1
-PORTREVISION= 1
+DISTVERSION= 6.0.3
CATEGORIES= science
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= salvadore@FreeBSD.org
COMMENT= Software suite for (bio)chemists
LICENSE= GPLv3
-LICENSE_FILE= ${WRKSRC}/COPYING
+LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/pthread-stubs.pc:devel/libpthread-stubs
-LIB_DEPENDS= libpcre.so:devel/pcre \
- libpng.so:graphics/png \
+LIB_DEPENDS= libexpat.so:textproc/expat2 \
+ libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
- libexpat.so:textproc/expat2 \
- libfontconfig.so:x11-fonts/fontconfig
+ libpcre.so:devel/pcre \
+ libpng.so:graphics/png
-USES= cmake gettext gnome qt:5 tar:bzip2 xorg
+USES= cmake gnome qt:5 tar:bzip2 xorg
USE_GITLAB= yes
GL_SITE= https://salsa.debian.org/
GL_ACCOUNT= debichem-team
-GL_COMMIT= c229f4a1abde3c20b83a90e50f9c5d79104dfa5f
-USE_GCC= yes # build breaks in clang
-USE_XORG= ice sm x11 xau xcb xdmcp xext xrender
+GL_COMMIT= a21ad33eee0314df202146392023dfb3868b7d84
USE_GNOME= glib20
-USE_QT= core gui svg xml widgets buildtools_build qmake_build
-USE_LDCONFIG= yes
+USE_QT= core gui printsupport svg widgets xml buildtools_build \
+ qmake_build
+USE_XORG= ice sm x11 xau xcb xdmcp xext xrender
.include <bsd.port.mk>