aboutsummaryrefslogtreecommitdiff
path: root/security/nitrokey-app/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/nitrokey-app/Makefile')
-rw-r--r--security/nitrokey-app/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/security/nitrokey-app/Makefile b/security/nitrokey-app/Makefile
index 4d7709393efa..c49647d13774 100644
--- a/security/nitrokey-app/Makefile
+++ b/security/nitrokey-app/Makefile
@@ -1,6 +1,7 @@
PORTNAME= nitrokey-app
DISTVERSIONPREFIX= v
DISTVERSION= 1.4.2
+PORTREVISION= 1
CATEGORIES= security
MAINTAINER= monwarez@mailoo.org
@@ -12,17 +13,20 @@ LICENSE_FILE= ${WRKSRC}/LICENSES/GPLv3
LIB_DEPENDS= libnitrokey.so:security/libnitrokey
-USES= cmake compiler:c++11-lang pkgconfig qt:5
+USES= cmake compiler:c++11-lang pkgconfig qt:5 desktop-file-utils
USE_GITHUB= yes
GH_ACCOUNT= Nitrokey
GH_TUPLE= Nitrokey:nitrokey-app:${DISTVERSIONPREFIX}${DISTVERSION}\
tplgy:cppcodec:61d9b04:cppcodec
-USE_QT= buildtools:build concurrent gui linguisttools:build qmake:build svg widgets
+USE_QT= buildtools:build core concurrent gui linguisttools:build qmake:build svg widgets
+
+CMAKE_ARGS= -DBASH_COMPLETION_PATH="share/bash-completion/completions/"
post-extract:
@${RMDIR} ${WRKSRC}/3rdparty/cppcodec
@${LN} -sf ${WRKDIR}/cppcodec-61d9b04 ${WRKSRC}/3rdparty/cppcodec
+
.include <bsd.port.mk>