aboutsummaryrefslogtreecommitdiff
path: root/sysutils/py-borgmatic/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/py-borgmatic/Makefile')
-rw-r--r--sysutils/py-borgmatic/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/sysutils/py-borgmatic/Makefile b/sysutils/py-borgmatic/Makefile
index bae2019923a9..d331117d3374 100644
--- a/sysutils/py-borgmatic/Makefile
+++ b/sysutils/py-borgmatic/Makefile
@@ -1,5 +1,5 @@
PORTNAME= borgmatic
-PORTVERSION= 1.8.2
+PORTVERSION= 1.8.8
CATEGORIES= sysutils python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -10,13 +10,16 @@ WWW= https://torsion.org/borgmatic/
LICENSE= GPLv3
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}borgbackup>=0:archivers/py-borgbackup@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}colorama>=0:devel/py-colorama@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}jsonschema>=0:devel/py-jsonschema@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}packaging>=0:devel/py-packaging@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}ruamel.yaml>=0:devel/py-ruamel.yaml@${PY_FLAVOR}
USES= python
-USE_PYTHON= autoplist distutils
+USE_PYTHON= autoplist pep517
NO_ARCH= yes