aboutsummaryrefslogtreecommitdiff
path: root/www/libdatachannel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/libdatachannel/Makefile')
-rw-r--r--www/libdatachannel/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/www/libdatachannel/Makefile b/www/libdatachannel/Makefile
index 8f9615fc8d47..f13949d5baab 100644
--- a/www/libdatachannel/Makefile
+++ b/www/libdatachannel/Makefile
@@ -1,6 +1,7 @@
PORTNAME= libdatachannel
DISTVERSIONPREFIX= v
-DISTVERSION= 0.13.0
+DISTVERSION= 0.13.0-8
+DISTVERSIONSUFFIX= -g5c8d63a
CATEGORIES= www
MAINTAINER= yuri@FreeBSD.org
@@ -11,16 +12,22 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libsrtp2.so:net/libsrtp2
-USES= cmake:testing
+USES= cmake compiler:c++17-lang ssl
USE_GITHUB= yes
GH_ACCOUNT= paullouisageneau
GH_TUPLE= \
SergiusTheBest:plog:d8461e9:plog/deps/plog \
sctplab:usrsctp:07f871b:usrsctp/deps/usrsctp \
- paullouisageneau:libjuice:4393345:libjuice/deps/libjuice \
+ paullouisageneau:libjuice:7a6efb7:libjuice/deps/libjuice \
nlohmann:json:973c52d:json/deps/json
CMAKE_ON= USE_SYSTEM_SRTP NO_EXAMPLES NO_TESTS
+do-test:
+ @cd ${BUILD_WRKSRC} && \
+ ${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} -DNO_TESTS:BOOL=OFF ${CMAKE_SOURCE_PATH} && \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} ${ALL_TARGET} && \
+ ./tests-${DISTVERSION:C/-.*//}
+
.include <bsd.port.mk>