aboutsummaryrefslogtreecommitdiff
path: root/www/node18/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/node18/Makefile')
-rw-r--r--www/node18/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/www/node18/Makefile b/www/node18/Makefile
index 16b594e24d31..443bbd8c9ec4 100644
--- a/www/node18/Makefile
+++ b/www/node18/Makefile
@@ -98,4 +98,10 @@ post-configure:
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/node
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} >= 160 && ${ARCH} == aarch64
+CXXFLAGS+= -Wno-error=enum-constexpr-conversion
+.endif
+
+.include <bsd.port.post.mk>