aboutsummaryrefslogtreecommitdiff
path: root/x11/p5-X11-XCB/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/p5-X11-XCB/Makefile')
-rw-r--r--x11/p5-X11-XCB/Makefile19
1 files changed, 10 insertions, 9 deletions
diff --git a/x11/p5-X11-XCB/Makefile b/x11/p5-X11-XCB/Makefile
index b456addc311b..3b08b711bdd9 100644
--- a/x11/p5-X11-XCB/Makefile
+++ b/x11/p5-X11-XCB/Makefile
@@ -1,6 +1,5 @@
PORTNAME= X11-XCB
-PORTVERSION= 0.16
-PORTREVISION= 2
+PORTVERSION= 0.22
CATEGORIES= x11 perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -15,20 +14,22 @@ LICENSE_COMB= dual
LIB_DEPENDS= libxcb.so:x11/libxcb \
libxcb-util.so:x11/xcb-util \
libxcb-icccm.so:x11/xcb-util-wm
-BUILD_DEPENDS= ${RUN_DEPENDS}
-RUN_DEPENDS= \
+BUILD_DEPENDS= \
${LOCALBASE}/share/xcb/xcb.xsd:x11/xcb-proto \
p5-Data-Dump>=0:devel/p5-Data-Dump \
- p5-Mouse>=0:devel/p5-Mouse \
- p5-MouseX-NativeTraits>=0:devel/p5-MouseX-NativeTraits \
p5-ExtUtils-Depends>=0:devel/p5-ExtUtils-Depends \
p5-ExtUtils-PkgConfig>=0:devel/p5-ExtUtils-PkgConfig \
- p5-Test-Deep>=0:devel/p5-Test-Deep \
- p5-Test-Exception>=0:devel/p5-Test-Exception \
- p5-Try-Tiny>=0:lang/p5-Try-Tiny \
p5-XML-Descent>=0:textproc/p5-XML-Descent \
p5-XML-Simple>=0:textproc/p5-XML-Simple \
p5-XS-Object-Magic>=0:devel/p5-XS-Object-Magic
+RUN_DEPENDS= \
+ p5-Mouse>=0:devel/p5-Mouse \
+ p5-MouseX-NativeTraits>=0:devel/p5-MouseX-NativeTraits \
+ p5-Try-Tiny>=0:lang/p5-Try-Tiny \
+ p5-XS-Object-Magic>=0:devel/p5-XS-Object-Magic
+TEST_DEPENDS= \
+ p5-Test-Deep>=0:devel/p5-Test-Deep \
+ p5-Test-Exception>=0:devel/p5-Test-Exception
USES= localbase perl5 xorg
USE_PERL5= configure