aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-10-31 23:05:37 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-10-31 23:05:37 +0000
commit2d3197b9926048f887e68aec23c2e19438c3a90d (patch)
treeb477993e12baa2096750d2d2afaa51ddf4a5e07f
parenta1e4f0b53ebbad976ee8da8814dba3282d7cb748 (diff)
downloadports-2d3197b9926048f887e68aec23c2e19438c3a90d.tar.gz
ports-2d3197b9926048f887e68aec23c2e19438c3a90d.zip
New port: science/latte: Quantum chemistry: Density functional tight binding molecular dynamics
Notes
Notes: svn path=/head/; revision=483624
-rw-r--r--science/Makefile1
-rw-r--r--science/latte/Makefile44
-rw-r--r--science/latte/distinfo3
-rw-r--r--science/latte/pkg-descr12
4 files changed, 60 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index 1b3c8bcbeeec..787cce80549f 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -108,6 +108,7 @@
SUBDIR += kst2
SUBDIR += lammps
SUBDIR += lamprop
+ SUBDIR += latte
SUBDIR += libaec
SUBDIR += libccp4
SUBDIR += libcint
diff --git a/science/latte/Makefile b/science/latte/Makefile
new file mode 100644
index 000000000000..d218af9617d8
--- /dev/null
+++ b/science/latte/Makefile
@@ -0,0 +1,44 @@
+# $FreeBSD$
+
+PORTNAME= latte
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.2.1
+CATEGORIES= science
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Quantum chemistry: Density functional tight binding molecular dynamics
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE_GPL-2.0
+
+USES= blaslapack:openblas cmake:outsource,noninja fortran shebangfix
+SHEBANG_FILES= tests/run_test.sh
+USE_GITHUB= yes
+GH_ACCOUNT= lanl
+GH_PROJECT= ${PORTNAME:tu}
+USE_LDCONFIG= yes
+
+CMAKE_SOURCE_PATH= ${WRKSRC}/cmake
+CMAKE_ON= BUILD_SHARED_LIBS
+CMAKE_ARGS= -DBLA_VENDOR:STRING="OpenBLAS"
+
+OPTIONS_DEFINE= DBCSR OPENMP MPI # TODO PROGRESS needs to be ported
+OPTIONS_DEFAULT= OPENMP MPI
+
+DBCSR_DESC= Use distributed block compressed sparse row matrix library
+DBCSR_CMAKE_BOOL= DBCSR_OPT
+DBCSR_LIB_DEPENDS= libdbcsr.so:math/dbcsr
+DBCSR_BROKEN= see https://github.com/lanl/LATTE/issues/92
+
+OPENMP_CMAKE_BOOL= OPENMP
+OPENMP_LIB_DEPENDS= libomp.so:devel/openmp
+
+MPI_CMAKE_BOOL= DO_MPI
+MPI_LIB_DEPENDS= libmpi.so:net/openmpi
+MPI_LDFLAGS= ${LOCALBASE}/mpi/openmpi/lib/libmpi_mpifh.so
+MPI_PLIST_FILES= bin/LATTE_MPI_DOUBLE
+MPI_PLIST_FILES_OFF= bin/LATTE_DOUBLE
+
+PLIST_FILES= lib/liblatte.so
+
+.include <bsd.port.mk>
diff --git a/science/latte/distinfo b/science/latte/distinfo
new file mode 100644
index 000000000000..bf4e2adc38d3
--- /dev/null
+++ b/science/latte/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1540963082
+SHA256 (lanl-LATTE-v1.2.1_GH0.tar.gz) = 343f28174365bd2185ff957038ac727d33659ef1bdf82f11af5603af3d943f2c
+SIZE (lanl-LATTE-v1.2.1_GH0.tar.gz) = 6673701
diff --git a/science/latte/pkg-descr b/science/latte/pkg-descr
new file mode 100644
index 000000000000..9508cb84585a
--- /dev/null
+++ b/science/latte/pkg-descr
@@ -0,0 +1,12 @@
+A molecular dynamics package based around self-consistent-charge density
+functional tight binding theory.
+
+Features:
+* Forces computed at the SCC-DFTB level.
+* Provides forces and the potential component of the total energy.
+* Integrates the electronic degrees of freedom (XL) (provides charges).
+* Solves the electronic structure of the system.
+* Several solvers such as SP2, Truncated SP2, Chebyshev polynomial
+ expansion, etc.
+
+WWW: https://github.com/lanl/LATTE