aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2007-10-04 00:50:28 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2007-10-04 00:50:28 +0000
commit3e2fd4b788942461b3fbd53d7edac9a1abc3488e (patch)
tree50f793f00a7cb711970c62063687af6cd8625387
parentec7c5b0142aeb3539337db2d501d7b5ecf5e7284 (diff)
downloadports-3e2fd4b788942461b3fbd53d7edac9a1abc3488e.tar.gz
ports-3e2fd4b788942461b3fbd53d7edac9a1abc3488e.zip
Remove always-false/true conditions based on OSVERSION 500000
Notes
Notes: svn path=/head/; revision=200771
-rw-r--r--editors/2bsd-vi/Makefile11
-rw-r--r--editors/textedit.app/Makefile8
-rw-r--r--editors/wily/Makefile8
-rw-r--r--emulators/gcube/Makefile8
-rw-r--r--emulators/gngeo/Makefile4
-rw-r--r--emulators/hercules/Makefile4
-rw-r--r--emulators/linux-vmware-toolbox4/Makefile8
-rw-r--r--emulators/linux-vmware-toolbox5/Makefile4
-rw-r--r--emulators/linux-vmware-toolbox6/Makefile4
-rw-r--r--emulators/mupen64-base/Makefile4
-rw-r--r--emulators/pearpc/Makefile4
-rw-r--r--emulators/snes9express/Makefile8
-rw-r--r--emulators/uae/Makefile8
-rw-r--r--emulators/vice/Makefile5
-rw-r--r--emulators/vmware-tools3/Makefile8
-rw-r--r--finance/kmymoney-kde4/Makefile8
-rw-r--r--finance/kmymoney2/Makefile8
-rw-r--r--finance/qtstalker/Makefile8
-rw-r--r--ftp/bbftp/Makefile8
-rw-r--r--ftp/bsdftpd-ssl/Makefile4
-rw-r--r--ftp/curlpp/Makefile8
-rw-r--r--ftp/kftpgrabber/Makefile8
-rw-r--r--ftp/pftpx/Makefile4
-rw-r--r--ftp/yafc/Makefile2
24 files changed, 15 insertions, 139 deletions
diff --git a/editors/2bsd-vi/Makefile b/editors/2bsd-vi/Makefile
index 3dcdd635101d..58bcc6d9605f 100644
--- a/editors/2bsd-vi/Makefile
+++ b/editors/2bsd-vi/Makefile
@@ -24,18 +24,9 @@ PLIST_SUB= PRESERVEDIR="${PRESERVEDIR}"
MAN1= ex.1 vi.1
MLINKS= ex.1 edit.1 vi.1 vedit.1 vi.1 view.1
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-EXTRA_PATCHES+= ${FILESDIR}/stable-Makefile.patch
-.endif
-
post-patch:
-.if ${OSVERSION} < 500000
- @${REINPLACE_CMD} -e 's|-DMB||g' ${WRKSRC}/Makefile
-.endif
.for f in Makefile ex.1 expreserve.c exrecover.c vi.1
@${REINPLACE_CMD} -e 's|/var/preserve|${PRESERVEDIR}|' ${WRKSRC}/${f}
.endfor
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/editors/textedit.app/Makefile b/editors/textedit.app/Makefile
index 5ca948162694..037f2aaf47cb 100644
--- a/editors/textedit.app/Makefile
+++ b/editors/textedit.app/Makefile
@@ -24,10 +24,4 @@ USE_GNUSTEP_INSTALL= yes
WRKSRC= ${WRKDIR}/textedit-${PORTVERSION}
MAKE_ENV+= GNUSTEP_INSTALLATION_DOMAIN=SYSTEM
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= does not compile on 4.x
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/editors/wily/Makefile b/editors/wily/Makefile
index 15d61c34f128..105ae0a9bca8 100644
--- a/editors/wily/Makefile
+++ b/editors/wily/Makefile
@@ -33,12 +33,6 @@ PORTDOCS= index.html intro.html download.html credits.html FAQ.html \
TUTEDOCS= hello.c start typescript
TUTESHS= findword script send_to_gary
-.include <bsd.port.pre.mk>
-
-.if (${OSVERSION} < 500000)
-BROKEN= Requires more recent libc
-.endif
-
post-patch:
cd ${WRKSRC}/tools/win; ${REINPLACE_CMD} -e 's," in " __FUNCTION__ "()",,' \
win.c wgoto.c wreplace.c; \
@@ -68,4 +62,4 @@ post-install:
.endif
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/emulators/gcube/Makefile b/emulators/gcube/Makefile
index b325e448b677..f154583b5d69 100644
--- a/emulators/gcube/Makefile
+++ b/emulators/gcube/Makefile
@@ -54,10 +54,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/README
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-EXTRA_PATCHES= ${FILESDIR}/cpu.c-patch
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/emulators/gngeo/Makefile b/emulators/gngeo/Makefile
index b4ceb9309a34..2852e9819a0c 100644
--- a/emulators/gngeo/Makefile
+++ b/emulators/gngeo/Makefile
@@ -39,10 +39,6 @@ MAN1= gngeo.1
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-src__emu.h
-.endif
-
.if !defined(WITHOUT_I386ASM) || !defined(WITHOUT_RAZE) || \
!defined(WITHOUT_STAR)
BUILD_DEPENDS+= nasm:${PORTSDIR}/devel/nasm
diff --git a/emulators/hercules/Makefile b/emulators/hercules/Makefile
index 099ce064e3b7..6e28203dfa37 100644
--- a/emulators/hercules/Makefile
+++ b/emulators/hercules/Makefile
@@ -42,10 +42,6 @@ post-install:
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-IGNORE= does not compile on FreeBSD 4.x
-.endif
-
.if defined(WITH_DEBUG)
CFLAGS+= -g
.endif
diff --git a/emulators/linux-vmware-toolbox4/Makefile b/emulators/linux-vmware-toolbox4/Makefile
index 51d74980c208..9f26764b6339 100644
--- a/emulators/linux-vmware-toolbox4/Makefile
+++ b/emulators/linux-vmware-toolbox4/Makefile
@@ -36,13 +36,7 @@ NO_LATEST_LINK= yes
VMWARE_VER= 4.5.2
BUILD_VER= 8848
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-MOUNT_DEV?= /dev/acd0c
-.else
MOUNT_DEV?= /dev/acd0
-.endif
MOUNT_PT?= /mnt
MOUNT= /sbin/mount
UMOUNT= /sbin/umount
@@ -91,4 +85,4 @@ do-install:
${BRANDELF} -t Linux ${WRKSRC}/bin/vmware-toolbox
${INSTALL_PROGRAM} ${WRKSRC}/bin/vmware-toolbox ${PREFIX}/bin/linux-vmware-toolbox
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/emulators/linux-vmware-toolbox5/Makefile b/emulators/linux-vmware-toolbox5/Makefile
index 77d0cb092888..47b46ce3cc07 100644
--- a/emulators/linux-vmware-toolbox5/Makefile
+++ b/emulators/linux-vmware-toolbox5/Makefile
@@ -39,11 +39,7 @@ BUILD_VER= 19175
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-MOUNT_DEV?= /dev/acd0c
-.else
MOUNT_DEV?= /dev/acd0
-.endif
MOUNT_PT?= /mnt
MOUNT= /sbin/mount
UMOUNT= /sbin/umount
diff --git a/emulators/linux-vmware-toolbox6/Makefile b/emulators/linux-vmware-toolbox6/Makefile
index 2b98726c0204..bc6df4f84ae4 100644
--- a/emulators/linux-vmware-toolbox6/Makefile
+++ b/emulators/linux-vmware-toolbox6/Makefile
@@ -39,11 +39,7 @@ BUILD_VER= 55017
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-MOUNT_DEV?= /dev/acd0c
-.else
MOUNT_DEV?= /dev/acd0
-.endif
MOUNT_PT?= /mnt
MOUNT= /sbin/mount
UMOUNT= /sbin/umount
diff --git a/emulators/mupen64-base/Makefile b/emulators/mupen64-base/Makefile
index ac990ef2b331..f7cff58cde04 100644
--- a/emulators/mupen64-base/Makefile
+++ b/emulators/mupen64-base/Makefile
@@ -67,8 +67,4 @@ CFLAGS+= -DX86 -mcpu=athlon
MAKE_ARGS+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
-.if ${OSVERSION} < 500000
-LDFLAGS+= -L/usr/lib -lcipher
-.endif
-
.include <bsd.port.post.mk>
diff --git a/emulators/pearpc/Makefile b/emulators/pearpc/Makefile
index 11d5954e8652..d27deb36e44c 100644
--- a/emulators/pearpc/Makefile
+++ b/emulators/pearpc/Makefile
@@ -97,10 +97,6 @@ pre-configure:
post-configure:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/src/Makefile
-.if ${OSVERSION} < 500000
- @${CP} ${FILESDIR}/wcrtomb.c ${FILESDIR}/mbrtowc.c \
- ${WRKSRC}/
-.endif
post-install:
@${MKDIR} ${DATADIR}
diff --git a/emulators/snes9express/Makefile b/emulators/snes9express/Makefile
index 0f91d824db9d..a877b5f22546 100644
--- a/emulators/snes9express/Makefile
+++ b/emulators/snes9express/Makefile
@@ -23,12 +23,6 @@ USE_XLIB= yes
GNU_CONFIGURE= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= "Does not compile on FreeBSD 4.x"
-.endif
-
post-configure:
@${REINPLACE_CMD} -e 's|lstat$$U.o||' ${WRKSRC}/Makefile
@@ -44,4 +38,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/emulators/uae/Makefile b/emulators/uae/Makefile
index 948736d4cd72..fbc5af67c964 100644
--- a/emulators/uae/Makefile
+++ b/emulators/uae/Makefile
@@ -59,10 +59,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/amiga/devs/AHI/uae.audio ${DATADIR}/amiga/devs/AHI/
${INSTALL_DATA} ${WRKSRC}/amiga/devs/AudioModes/UAE ${DATADIR}/amiga/devs/AudioModes/
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= "Doesn't build on FreeBSD < 5.x"
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/emulators/vice/Makefile b/emulators/vice/Makefile
index 997d2c5c3307..c498989956de 100644
--- a/emulators/vice/Makefile
+++ b/emulators/vice/Makefile
@@ -88,11 +88,6 @@ CONFIGURE_ARGS+= --with-esd
CONFIGURE_ARGS+= --without-esd
.endif
-.if ${ARCH} == "alpha" && ${OSVERSION} < 500000
-# ../src/resid/libresid.a(wave.o)(.rodata+0x0): relocation truncated to fit: GPREL32 *UND*
-BROKEN= "GPREL relocation truncated"
-.endif
-
post-extract:
@${RM} -f ${WRKSRC}/doc/vice.info*
diff --git a/emulators/vmware-tools3/Makefile b/emulators/vmware-tools3/Makefile
index 4061e3b1a02a..dc0ddf592142 100644
--- a/emulators/vmware-tools3/Makefile
+++ b/emulators/vmware-tools3/Makefile
@@ -36,13 +36,7 @@ NO_PACKAGE= ${RESTRICTED}
VMWARE_VER= 3.2.1
BUILD_VER= 2237
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-MOUNT_DEV?= /dev/acd0c
-.else
MOUNT_DEV?= /dev/acd0
-.endif
MOUNT_PT?= /mnt
MOUNT= /sbin/mount
UMOUNT= /sbin/umount
@@ -83,4 +77,4 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/vmware-toolbox ${PREFIX}/bin
-${LOCALBASE}/sbin/vmware-guestd --cmd toolinstall.end
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/finance/kmymoney-kde4/Makefile b/finance/kmymoney-kde4/Makefile
index 62621a6054e2..abdd3e1f28ed 100644
--- a/finance/kmymoney-kde4/Makefile
+++ b/finance/kmymoney-kde4/Makefile
@@ -50,13 +50,7 @@ MANCOMPRESSED= yes
DATADIR= ${PREFIX}/share/apps/${PORTNAME}
DOCSDIR= ${PREFIX}/share/doc/HTML/en/${PORTNAME}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= Does not build on 4.x
-.endif
-
post-patch:
${REINPLACE_CMD} -E -e "s|%%LOCALBASE%%|${LOCALBASE}|g" ${WRKSRC}/configure
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/finance/kmymoney2/Makefile b/finance/kmymoney2/Makefile
index 62621a6054e2..abdd3e1f28ed 100644
--- a/finance/kmymoney2/Makefile
+++ b/finance/kmymoney2/Makefile
@@ -50,13 +50,7 @@ MANCOMPRESSED= yes
DATADIR= ${PREFIX}/share/apps/${PORTNAME}
DOCSDIR= ${PREFIX}/share/doc/HTML/en/${PORTNAME}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= Does not build on 4.x
-.endif
-
post-patch:
${REINPLACE_CMD} -E -e "s|%%LOCALBASE%%|${LOCALBASE}|g" ${WRKSRC}/configure
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/finance/qtstalker/Makefile b/finance/qtstalker/Makefile
index 16d35a8b9f87..c17ebb51cb4e 100644
--- a/finance/qtstalker/Makefile
+++ b/finance/qtstalker/Makefile
@@ -49,12 +49,6 @@ PORTDOCS+= \
PLIST_SUB+= \
VERSION_PLUGIN="${VERSION_PLUGIN}"
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= "Does not compile on FreeBSD 4.x"
-.endif
-
post-patch:
# tell qtstalker where to install plugins
@${FIND} ${WRKSRC} -type f -name "*pro" | \
@@ -114,4 +108,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/ftp/bbftp/Makefile b/ftp/bbftp/Makefile
index 76f6aba52b81..7650d9ecb1dd 100644
--- a/ftp/bbftp/Makefile
+++ b/ftp/bbftp/Makefile
@@ -23,12 +23,6 @@ USE_RC_SUBR= bbftpd
MAN1= bbftp.1 bbftpd.1
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= does not compile
-.endif
-
do-configure:
${CP} -f ${TEMPLATES}/config.guess ${WRKSRC}
${CP} -f ${TEMPLATES}/config.sub ${WRKSRC}
@@ -45,4 +39,4 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/doc/bbftp.1 ${PREFIX}/man/man1
${INSTALL_MAN} ${WRKSRC}/doc/bbftpd.1 ${PREFIX}/man/man1
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/ftp/bsdftpd-ssl/Makefile b/ftp/bsdftpd-ssl/Makefile
index ec798f9167c5..b0b9fa0f5c76 100644
--- a/ftp/bsdftpd-ssl/Makefile
+++ b/ftp/bsdftpd-ssl/Makefile
@@ -59,10 +59,6 @@ MANDIR= ${PREFIX}/man/man
DOCDIR= ${DOCSDIR}${PKGNAMESUFFIX}
pre-build:
-.if ${OSVERSION} < 500000
-# Compatibility with FreeBSD 4.x
- (cd ${WRKSRC} && ./config.sh _conv_gcc29x) || exit
-.endif
(cd ${WRKSRC} && ./config.sh FreeBSD) || exit
do-build:
diff --git a/ftp/curlpp/Makefile b/ftp/curlpp/Makefile
index 9135974902ce..aa24bdcc5db9 100644
--- a/ftp/curlpp/Makefile
+++ b/ftp/curlpp/Makefile
@@ -24,12 +24,6 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
CONFIGURE_ARGS= --disable-ewarning
USE_LDCONFIG= yes
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "alpha" && ${OSVERSION} < 500000
-BROKEN= Does not compile on alpha 4.x
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g' ${WRKSRC}/Makefile.in
@@ -42,4 +36,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/doc/guide.pdf ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/ftp/kftpgrabber/Makefile b/ftp/kftpgrabber/Makefile
index 52eff75de767..01b1058e010d 100644
--- a/ftp/kftpgrabber/Makefile
+++ b/ftp/kftpgrabber/Makefile
@@ -22,10 +22,4 @@ USE_AUTOTOOLS= libtool:15
post-patch:
@${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/${CONFIGURE_SCRIPT}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= Does not compile on 4.x
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/ftp/pftpx/Makefile b/ftp/pftpx/Makefile
index b112f1aa349b..cb935dd9f75e 100644
--- a/ftp/pftpx/Makefile
+++ b/ftp/pftpx/Makefile
@@ -23,10 +23,6 @@ USE_RC_SUBR= pftpx
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-IGNORE= only for 5.0 and above
-.endif
-
.if ${OSVERSION} < 502116
MAKE_ARGS= LOCALBASE="${PREFIX}" OSLEVEL=34
.if defined(WITH_ALTQ) && (${WITH_ALTQ} == "yes")
diff --git a/ftp/yafc/Makefile b/ftp/yafc/Makefile
index 721b88212c87..e2664b6f04bb 100644
--- a/ftp/yafc/Makefile
+++ b/ftp/yafc/Makefile
@@ -30,7 +30,7 @@ PLIST_DIRS= %%EXAMPLESDIR%%
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000 || exists(${LOCALBASE}/lib/libreadline.so.5)
+.if exists(${LOCALBASE}/lib/libreadline.so.5)
LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
.endif