aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2017-05-13 23:21:37 +0000
committerMark Linimon <linimon@FreeBSD.org>2017-05-13 23:21:37 +0000
commit7e4f41c6908ce98d98c9a87bb0998ff78c715166 (patch)
tree4ae3b8a2f12ec648a3f08b6e08e43bdddbde045b
parentaaf8b327e5095da79cd603bcd11cc3bb1af0e5b5 (diff)
downloadports-7e4f41c6908ce98d98c9a87bb0998ff78c715166.tar.gz
ports-7e4f41c6908ce98d98c9a87bb0998ff78c715166.zip
Mark some ports failing on power64. In cases where the error message
was a stub, provide a real one. While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=440858
-rw-r--r--emulators/gem5/Makefile2
-rw-r--r--emulators/simh/Makefile2
-rw-r--r--emulators/unicorn/Makefile2
-rw-r--r--ftp/curlpp/Makefile2
-rw-r--r--ftp/libfilezilla/Makefile2
-rw-r--r--games/bunnysay/Makefile2
-rw-r--r--games/crafty-tablebase-no-pawn/Makefile1
-rw-r--r--games/crafty-tablebase-pawn/Makefile1
-rw-r--r--games/flightgear-mb339-pan/Makefile2
-rw-r--r--games/redorblack/Makefile2
-rw-r--r--games/rubix/Makefile4
-rw-r--r--graphics/code-eli/Makefile3
-rw-r--r--graphics/cptutils/Makefile2
-rw-r--r--java/bootstrap-openjdk/Makefile2
-rw-r--r--lang/phantomjs/Makefile1
-rw-r--r--lang/qore/Makefile11
-rw-r--r--lang/racket-minimal/Makefile9
-rw-r--r--lang/squirrel/Makefile2
-rw-r--r--math/clrng/Makefile1
-rw-r--r--math/gringo/Makefile2
-rw-r--r--math/openlibm/Makefile4
-rw-r--r--multimedia/libtuner/Makefile2
-rw-r--r--multimedia/mkvalidator/Makefile2
-rw-r--r--multimedia/oscam/Makefile2
24 files changed, 43 insertions, 22 deletions
diff --git a/emulators/gem5/Makefile b/emulators/gem5/Makefile
index fb510f987452..51e51800f49e 100644
--- a/emulators/gem5/Makefile
+++ b/emulators/gem5/Makefile
@@ -14,7 +14,7 @@ BUILD_DEPENDS= swig2.0:devel/swig20 \
BROKEN_armv6= fails to link: undefined reference to HDLcd::BUS_OPTIONS_RESETV
BROKEN_i386= does not build
BROKEN_mips64= fails to build: claims that gcc version 4.6 or newer required
-BROKEN_powerpc64= does not build
+BROKEN_powerpc64= fails to build: claims that gcc version 4.6 or newer required
DATE= 20140422
USE_GITHUB= yes
diff --git a/emulators/simh/Makefile b/emulators/simh/Makefile
index b6e3c18d67f9..175ee9faf0b7 100644
--- a/emulators/simh/Makefile
+++ b/emulators/simh/Makefile
@@ -17,6 +17,8 @@ COMMENT= Emulates classic DEC, HP, GRI, IBM, Altair, SDS, Honeywell, and others
LICENSE= BSD3CLAUSE
+BROKEN_powerpc64= fails to compile: cc1: error: unrecognized command line option "-Wno-logical-op-parentheses"
+
NO_WRKSUBDIR= yes
USES= gmake dos2unix zip
diff --git a/emulators/unicorn/Makefile b/emulators/unicorn/Makefile
index 305df7629efe..479bacd61209 100644
--- a/emulators/unicorn/Makefile
+++ b/emulators/unicorn/Makefile
@@ -12,6 +12,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
TEST_DEPENDS= cmocka>0:sysutils/cmocka
+BROKEN_powerpc64= fails to compile: cc1: error: unrecognized command line option "-Wno-logical-op-parentheses"
+
USE_GITHUB= yes
GH_ACCOUNT= unicorn-engine
diff --git a/ftp/curlpp/Makefile b/ftp/curlpp/Makefile
index 591ef90b1904..a97b29693a7f 100644
--- a/ftp/curlpp/Makefile
+++ b/ftp/curlpp/Makefile
@@ -14,6 +14,8 @@ LICENSE_FILE= ${WRKSRC}/doc/LICENSE
LIB_DEPENDS= libcurl.so:ftp/curl
+BROKEN_powerpc64= fails to configure: error: A compiler with support for C++11 language features is required
+
OPTIONS_DEFINE= DOCS EXAMPLES
USE_LDCONFIG= yes
diff --git a/ftp/libfilezilla/Makefile b/ftp/libfilezilla/Makefile
index 0f947178d874..d4b14191cdff 100644
--- a/ftp/libfilezilla/Makefile
+++ b/ftp/libfilezilla/Makefile
@@ -12,7 +12,7 @@ COMMENT= C++ library for building platform-independent programs
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_powerpc64= Does not build
+BROKEN_powerpc64= does not compile: libfilezilla/string.hpp: error: to_wstring is not a member of std
USES= compiler:c++14-lang gmake iconv:wchar_t libtool localbase pathfix pkgconfig tar:bzip2
USE_LDCONFIG= yes
diff --git a/games/bunnysay/Makefile b/games/bunnysay/Makefile
index 0fdd96426f7b..2c583bc9cca8 100644
--- a/games/bunnysay/Makefile
+++ b/games/bunnysay/Makefile
@@ -12,6 +12,8 @@ COMMENT= Bunny Sign for terminals with UTF-8 support
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/LICENSE
+BROKEN_powerpc64= fails to compile: cc1plus: error: unrecognized command line option -std=c++11
+
USES= gmake
ALL_TARGET= bunnysay
diff --git a/games/crafty-tablebase-no-pawn/Makefile b/games/crafty-tablebase-no-pawn/Makefile
index 125c22ad7353..aae4034c9132 100644
--- a/games/crafty-tablebase-no-pawn/Makefile
+++ b/games/crafty-tablebase-no-pawn/Makefile
@@ -52,6 +52,7 @@ NO_BUILD= yes
BROKEN_aarch64= Fails to install: runaway process
BROKEN_armv6= Fails to install: runaway process
BROKEN_mips64= Fails to install: runaway process
+BROKEN_powerpc64= Fails to install: runaway process
.if !defined(WITH_TBDIR)
WITH_TBDIR= ${PREFIX}/lib/crafty/TB
diff --git a/games/crafty-tablebase-pawn/Makefile b/games/crafty-tablebase-pawn/Makefile
index 842536533730..49c2c27b46d3 100644
--- a/games/crafty-tablebase-pawn/Makefile
+++ b/games/crafty-tablebase-pawn/Makefile
@@ -44,6 +44,7 @@ NO_ARCH= yes
BROKEN_aarch64= Fails to install: runaway process
BROKEN_armv6= Fails to install: runaway process
BROKEN_mips64= Fails to install: runaway process
+BROKEN_powerpc64= Fails to install: runaway process
.if !defined(WITH_TBDIR)
WITH_TBDIR= ${PREFIX}/lib/crafty/TB
diff --git a/games/flightgear-mb339-pan/Makefile b/games/flightgear-mb339-pan/Makefile
index e698097918f8..9aa76563fd4c 100644
--- a/games/flightgear-mb339-pan/Makefile
+++ b/games/flightgear-mb339-pan/Makefile
@@ -15,6 +15,8 @@ RUN_DEPENDS= ${LOCALBASE}/share/flightgear/version:games/flightgear-data
RESTRICTED= Redistribution prohibited
+BROKEN_powerpc64= fails to build: runaway process
+
NO_BUILD= yes
USES= zip
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/games/redorblack/Makefile b/games/redorblack/Makefile
index bb58a5b4769d..4e5804f22dc9 100644
--- a/games/redorblack/Makefile
+++ b/games/redorblack/Makefile
@@ -11,6 +11,8 @@ COMMENT= Simple card game to test fortune and probability theory
LICENSE= BSD2CLAUSE
+BROKEN_powerpc64= fails to compile: deckClass.h: error: random: No such file or directory
+
PLIST_FILES= bin/redorblack
do-build:
diff --git a/games/rubix/Makefile b/games/rubix/Makefile
index 5eb7ec481339..10f120011f50 100644
--- a/games/rubix/Makefile
+++ b/games/rubix/Makefile
@@ -11,8 +11,6 @@ MASTER_SITES= http://sed.free.fr/rubix/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= Another Rubik's cube game with a rather interesting interface
-BROKEN_powerpc64= Does not build
-
USES= compiler:nestedfct gmake tar:bzip2
USE_XORG= x11
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS} -DENGLISH" \
@@ -26,7 +24,7 @@ OPTIONS_DEFINE= DOCS
.include <bsd.port.pre.mk>
-.if (${ARCH} == mips || ${ARCH} == mips64) && ${COMPILER_TYPE} == gcc
+.if (${ARCH} == mips || ${ARCH} == mips64 || ${ARCH} == powerpc || ${ARCH} == powerpc64) && ${COMPILER_TYPE} == gcc
CFLAGS+= -fnested-functions
.endif
diff --git a/graphics/code-eli/Makefile b/graphics/code-eli/Makefile
index e14d1a714688..20bc3820fc02 100644
--- a/graphics/code-eli/Makefile
+++ b/graphics/code-eli/Makefile
@@ -33,7 +33,8 @@ DOXYGEN_BUILD_DEPENDS= ${LOCALBASE}/bin/doxygen:devel/doxygen
DOXYGEN_ALL_TARGET= doc
DOXYGEN_PORTDOCS= html latex
-BROKEN_armv6= Fails to compile: undefined reference to cbrtl
+BROKEN_armv6= fails to compile: undefined reference to cbrtl
+BROKEN_powerpc64= fails to compile: there are no arguments to 'printf' that depend on a template parameter
post-patch-EXAMPLES-off:
${REINPLACE_CMD} \
diff --git a/graphics/cptutils/Makefile b/graphics/cptutils/Makefile
index 31054e269b90..84f6621472ce 100644
--- a/graphics/cptutils/Makefile
+++ b/graphics/cptutils/Makefile
@@ -19,6 +19,8 @@ BUILD_DEPENDS= gengetopt:devel/gengetopt \
LIB_DEPENDS= libjansson.so:devel/jansson \
libpng.so:graphics/png
+BROKEN_powerpc64= fails to build: grd5read.c: \#pragma GCC diagnostic not allowed inside functions
+
USE_GITHUB= yes
GH_ACCOUNT= jjgreen
diff --git a/java/bootstrap-openjdk/Makefile b/java/bootstrap-openjdk/Makefile
index e1b2602b05b6..82ab5d53b1d4 100644
--- a/java/bootstrap-openjdk/Makefile
+++ b/java/bootstrap-openjdk/Makefile
@@ -14,9 +14,11 @@ COMMENT= Oracle\'s Java 6 virtual machine release under the GPL v2
LICENSE= GPLv2
RUN_DEPENDS= java-zoneinfo>0:java/java-zoneinfo
+
BUNDLE_LIBS= yes
ONLY_FOR_ARCHS= amd64 armv6 armv6hf i386 powerpc64
+BROKEN_powerpc64= fails to build: pkg-static: Unable to access file jre/lib/powerpc64/jvm.cfg
DISTINFO_FILE= ${.CURDIR}/distinfo.${JDK_ARCH}
DISTVERSION_amd64= r351880
diff --git a/lang/phantomjs/Makefile b/lang/phantomjs/Makefile
index 790bb9257fd6..3b410aedb717 100644
--- a/lang/phantomjs/Makefile
+++ b/lang/phantomjs/Makefile
@@ -17,6 +17,7 @@ LIB_DEPENDS= libfreetype.so:print/freetype2 \
libicui18n.so:devel/icu \
libpng.so:graphics/png
+BROKEN_powerpc64= fails to build: g++48: not found
BROKEN_sparc64= does not link on sparc64
USES= bison:build compiler:c++11-lang gmake gperf jpeg perl5 pkgconfig python:build ssl sqlite
diff --git a/lang/qore/Makefile b/lang/qore/Makefile
index ec4d4aeaec56..7492708901bf 100644
--- a/lang/qore/Makefile
+++ b/lang/qore/Makefile
@@ -15,7 +15,8 @@ BUILD_DEPENDS= ${LOCALBASE}/bin/flex:textproc/flex \
${LOCALBASE}/bin/bison:devel/bison \
${LOCALBASE}/bin/bash:shells/bash
-BROKEN_powerpc64= Does not build
+BROKEN_powerpc= fails to build
+BROKEN_powerpc64= fails to build: Error: unsupported relocation against r1
USES= gmake iconv libtool:build pathfix autoreconf ssl
USE_LDCONFIG= yes
@@ -30,16 +31,10 @@ LDFLAGS+= -L${LOCALBASE}/lib
PLIST_SUB= PORTVERSION=${PORTVERSION}
INSTALL_TARGET= install-strip
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "powerpc"
-BROKEN= Does not compile on powerpc
-.endif
-
pre-configure:
cd ${WRKSRC}; ./reconf.sh
post-configure:
${REINPLACE_CMD} -e 's|; make|; $${MAKE}|g' ${WRKSRC}/Makefile.in
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/lang/racket-minimal/Makefile b/lang/racket-minimal/Makefile
index 5f2d7e3602ec..be6026f47212 100644
--- a/lang/racket-minimal/Makefile
+++ b/lang/racket-minimal/Makefile
@@ -21,10 +21,11 @@ LICENSE= LGPL3
LIB_DEPENDS= libffi.so:devel/libffi
-BROKEN_armv6= does not build: error: GNU lightning does not support the current target
-BROKEN_aarch64= does not build: error: Unported platform
-BROKEN_sparc64= does not build
-BROKEN_i386= does not build on i386 (Seg fault (internal error) at 0x606060a)
+BROKEN_armv6= does not build: error: GNU lightning does not support the current target
+BROKEN_aarch64= does not build: error: Unported platform
+BROKEN_powerpc64= does not build: jit.c: error: JIT_LOCAL4 undeclared
+BROKEN_sparc64= does not build
+BROKEN_i386= does not build on i386 (Seg fault (internal error) at 0x606060a)
MAKE_JOBS_UNSAFE=yes
diff --git a/lang/squirrel/Makefile b/lang/squirrel/Makefile
index 1225de0af38d..406ff6887e10 100644
--- a/lang/squirrel/Makefile
+++ b/lang/squirrel/Makefile
@@ -12,6 +12,8 @@ COMMENT= High level imperative/OO programming language
CONFLICTS= squsq-[0-9]*
+BROKEN_powerpc64= fails to compile: cc1plus: error: unrecognized command line option -std=c++0x
+
USES= cmake dos2unix
CMAKE_ARGS= -DINSTALL_INC_DIR:STRING=include
USE_LDCONFIG= yes
diff --git a/math/clrng/Makefile b/math/clrng/Makefile
index b1cc46431c26..fcfddc0d909b 100644
--- a/math/clrng/Makefile
+++ b/math/clrng/Makefile
@@ -18,6 +18,7 @@ RUN_DEPENDS= opencl>=0:devel/opencl
ONLY_FOR_ARCHS= amd64 i386 powerpc powerpc64
ONLY_FOR_ARCHS_REASON= this code has only been tested on x86 and powerpc platforms
+BROKEN_powerpc64= fails to compile: cc1: error: unrecognized command line option -std=c11
USE_GITHUB= yes
GH_ACCOUNT= clMathLibraries
diff --git a/math/gringo/Makefile b/math/gringo/Makefile
index 4336a1d0895d..8ff3f9ab64a8 100644
--- a/math/gringo/Makefile
+++ b/math/gringo/Makefile
@@ -15,6 +15,8 @@ LICENSE= GPLv3
BUILD_DEPENDS= re2c:devel/re2c
+BROKEN_powerpc64= fails to compile: term.cc: error: pow is not a member of std
+
USES= bison compiler:c++11-lib scons
MAKE_ARGS+= ${MAKE_ENV}
diff --git a/math/openlibm/Makefile b/math/openlibm/Makefile
index a3f84c17f4e2..40bee825e437 100644
--- a/math/openlibm/Makefile
+++ b/math/openlibm/Makefile
@@ -21,8 +21,8 @@ GH_PROJECT= openlibm
USES= gmake
USE_LDCONFIG= yes
-BROKEN_aarch64= Does not compile: the clang compiler does not support -march=aarch64
-BROKEN_powerpc64= Does not build
+BROKEN_aarch64= does not compile: the clang compiler does not support -march=aarch64
+BROKEN_powerpc64= does not build: gmake: clang: Command not found
.include <bsd.port.pre.mk>
diff --git a/multimedia/libtuner/Makefile b/multimedia/libtuner/Makefile
index 44fc7aee8e16..c26bc4cc805d 100644
--- a/multimedia/libtuner/Makefile
+++ b/multimedia/libtuner/Makefile
@@ -12,6 +12,8 @@ COMMENT= Userspace drivers for various TV/radio tuner ICs
LICENSE= BSD2CLAUSE MIT
LICENSE_COMB= multi
+BROKEN_powerpc64= fails to compile: tuner_iic_device.cpp: EINVAL was not declared in this scope
+
MAKE_ARGS+= INSTALLDIR=${STAGEDIR}${PREFIX}
MAKE_ARGS+= -D LIBTUNER_ENABLE_IIC
USE_LDCONFIG= ${PREFIX}/lib/libtuner
diff --git a/multimedia/mkvalidator/Makefile b/multimedia/mkvalidator/Makefile
index b3d053d3251f..609fe217d8a4 100644
--- a/multimedia/mkvalidator/Makefile
+++ b/multimedia/mkvalidator/Makefile
@@ -11,7 +11,7 @@ COMMENT= Command line tool to verify Matroska and WebM files
LICENSE= BSD3CLAUSE BSD4CLAUSE GPLv2
LICENSE_COMB= multi
-BROKEN_powerpc64= Does not build
+BROKEN_powerpc64= does not compile: mkvtree.c: error: dereferencing pointer to incomplete type
BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}
diff --git a/multimedia/oscam/Makefile b/multimedia/oscam/Makefile
index e0530409d3a5..d031b3df63d1 100644
--- a/multimedia/oscam/Makefile
+++ b/multimedia/oscam/Makefile
@@ -12,7 +12,7 @@ COMMENT= Softcam software to decrypt digital tv channels
LICENSE= GPLv3
-BROKEN_powerpc64= Does not build
+BROKEN_powerpc64= does not build: gmake: clang: Command not found
USES= gmake ssl tar:bzip2
USE_RC_SUBR= oscam