aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2013-07-05 15:17:15 +0000
committerRene Ladan <rene@FreeBSD.org>2013-07-05 15:17:15 +0000
commitd46264516da3888718d020f2ad9cf48abce52e4d (patch)
tree941cb729514d699934eabc1c82ef031ebd016584
parentcc5f50ea5d44bfc4369b06d780d7dbde032a9345 (diff)
downloadports-d46264516da3888718d020f2ad9cf48abce52e4d.tar.gz
ports-d46264516da3888718d020f2ad9cf48abce52e4d.zip
Convert to USES=gmake
Remove an empty OPTIONS_DEFAULT in lang/nbc
Notes
Notes: svn path=/head/; revision=322337
-rw-r--r--astro/boinc-astropulse/Makefile3
-rw-r--r--emulators/libspectrum/Makefile3
-rw-r--r--games/torcs/Makefile3
-rw-r--r--lang/nbc/Makefile4
4 files changed, 4 insertions, 9 deletions
diff --git a/astro/boinc-astropulse/Makefile b/astro/boinc-astropulse/Makefile
index 79864545155d..794977626f5c 100644
--- a/astro/boinc-astropulse/Makefile
+++ b/astro/boinc-astropulse/Makefile
@@ -19,11 +19,10 @@ BUILD_DEPENDS= ${LOCALBASE}/include/fftw3.h:${PORTSDIR}/math/fftw3 \
RUN_DEPENDS= boinc_client:${PORTSDIR}/net/boinc-client
LIB_DEPENDS= fftw3f:${PORTSDIR}/math/fftw3-float
-USES= pkgconfig
+USES= gmake pkgconfig
USE_XZ= yes
USE_AUTOTOOLS= autoconf:env automake:env libtool
GNU_CONFIGURE= yes
-USE_GMAKE= yes
WRKSRC= ${WRKDIR}/${DISTNAME}/client
CFLAGS+= -O2 -I${LOCALBASE}/include/boinc -I${LOCALBASE}/include \
diff --git a/emulators/libspectrum/Makefile b/emulators/libspectrum/Makefile
index 182bedacb3c6..4b785ae3861b 100644
--- a/emulators/libspectrum/Makefile
+++ b/emulators/libspectrum/Makefile
@@ -14,10 +14,9 @@ LICENSE= GPLv2
LIB_DEPENDS= gcrypt:${PORTSDIR}/security/libgcrypt
GNU_CONFIGURE= yes
-USE_GMAKE= yes
USE_GNOME= glib20
USE_LDCONFIG= yes
-USES= pkgconfig
+USES= gmake pkgconfig
MAN3= libspectrum.3
diff --git a/games/torcs/Makefile b/games/torcs/Makefile
index 427ad4190447..cbd855ca719d 100644
--- a/games/torcs/Makefile
+++ b/games/torcs/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
vorbis:${PORTSDIR}/audio/libvorbis
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
-USES= shebangfix
+USES= gmake shebangfix
SHEBANG_FILES= src/linux/torcs.in src/tools/accc/accc.in \
src/tools/nfsperf/nfsperf.in \
src/tools/texmapper/texmapper.in src/tools/nfs2ac/nfs2ac.in \
@@ -30,7 +30,6 @@ USE_GL= glut
USE_OPENAL= al alut
USE_BZIP2= yes
GNU_CONFIGURE= yes
-USE_GMAKE= yes
USE_LDCONFIG= yes
CONFIGURE_ARGS= --x-includes=${LOCALBASE}/include --x-libraries=${LOCALBASE}/lib
CONFIGURE_ENV= LIBS="${PTHREAD_LIBS}"
diff --git a/lang/nbc/Makefile b/lang/nbc/Makefile
index 1f0412e59273..8b43c1c12f35 100644
--- a/lang/nbc/Makefile
+++ b/lang/nbc/Makefile
@@ -22,15 +22,13 @@ OPTIONS_DEFINE= DOCS ROBOCTL
ROBOCTL_DESC= Include roboctl to communicate with the NXT
-OPTIONS_DEFAULT=
-
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MROBOCTL}
RUN_DEPENDS= legoctl:${PORTSDIR}/devel/roboctl
.endif
-USE_GMAKE= yes
+USES= gmake
USE_DOS2UNIX= yes
USE_FPC= fcl-base fcl-image