aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-07-15 06:36:31 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-07-15 06:36:31 +0000
commit3eccd9c35128f912daea188a3da4ce5ea2508945 (patch)
tree029b77e58295660f6b096a0c28452a6d07195040
parente8e5eb56b4f73301f8b64dc896984b939f6b0f54 (diff)
downloadports-3eccd9c35128f912daea188a3da4ce5ea2508945.tar.gz
ports-3eccd9c35128f912daea188a3da4ce5ea2508945.zip
Add enscribe 0.0.3,
Enscribe creates digital audio watermark images from photographic images. These images can only be seen using a third party frequency vs time display, such as Baudline (audio/baudline). Images are still visible even after such audio mangling techniques as MP3/Ogg compression, reverb, chorus, etc. Heavy EQ and flange can stripe out vertical sections, but they can also ruin an otherwise good song as well. PR: ports/69076 Submitted by: Jean-Yves Lefort <jylefort@brutele.be>
Notes
Notes: svn path=/head/; revision=113687
-rw-r--r--audio/Makefile1
-rw-r--r--audio/enscribe/Makefile38
-rw-r--r--audio/enscribe/distinfo2
-rw-r--r--audio/enscribe/pkg-descr13
-rw-r--r--audio/enscribe/pkg-plist3
5 files changed, 57 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 2adc674d829f..2b3208617e06 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -70,6 +70,7 @@
SUBDIR += eawpats
SUBDIR += ecasound
SUBDIR += ecawave
+ SUBDIR += enscribe
SUBDIR += ermixer
SUBDIR += esound
SUBDIR += etktab
diff --git a/audio/enscribe/Makefile b/audio/enscribe/Makefile
new file mode 100644
index 000000000000..18b427b219b5
--- /dev/null
+++ b/audio/enscribe/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: enscribe
+# Date created: 15 Jul 2004
+# Whom: Jean-Yves Lefort <jylefort@brutele.be>
+#
+# $FreeBSD$
+#
+
+PORTNAME= enscribe
+PORTVERSION= 0.0.3
+CATEGORIES= audio graphics
+MASTER_SITES= http://jbd.zayda.net/enscribe/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= jylefort@brutele.be
+COMMENT= Create digital audio watermark images from photographic images
+
+LIB_DEPENDS= gd:${PORTSDIR}/graphics/gd \
+ png:${PORTSDIR}/graphics/png \
+ jpeg:${PORTSDIR}/graphics/jpeg \
+ freetype:${PORTSDIR}/print/freetype2 \
+ sndfile:${PORTSDIR}/audio/libsndfile
+
+do-build:
+ cd ${BUILD_WRKSRC}; ${CC} ${CFLAGS} \
+ `pkg-config --cflags --libs sndfile freetype2` \
+ -I${LOCALBASE}/include -L${LOCALBASE}/lib \
+ -lgd -lpng -ljpeg -lm -lz \
+ -o enscribe enscribe.c
+
+do-install:
+ ${MKDIR} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/enscribe ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/audio/enscribe/distinfo b/audio/enscribe/distinfo
new file mode 100644
index 000000000000..b15597286f69
--- /dev/null
+++ b/audio/enscribe/distinfo
@@ -0,0 +1,2 @@
+MD5 (enscribe-0.0.3.tgz) = 7e0107fead2edce0aa7d85d5f86c5482
+SIZE (enscribe-0.0.3.tgz) = 30062
diff --git a/audio/enscribe/pkg-descr b/audio/enscribe/pkg-descr
new file mode 100644
index 000000000000..cd914201939d
--- /dev/null
+++ b/audio/enscribe/pkg-descr
@@ -0,0 +1,13 @@
+Enscribe creates digital audio watermark images from photographic
+images. These images can only be seen using a third party frequency vs
+time display, such as Baudline (audio/baudline).
+
+Images are still visible even after such audio mangling techniques as
+MP3/Ogg compression, reverb, chorus, etc. Heavy EQ and flange can
+stripe out vertical sections, but they can also ruin an otherwise good
+song as well.
+
+WWW: http://jbd.zayda.net/enscribe/
+
+- Jean-Yves Lefort
+jylefort@brutele.be
diff --git a/audio/enscribe/pkg-plist b/audio/enscribe/pkg-plist
new file mode 100644
index 000000000000..941577fa8c4e
--- /dev/null
+++ b/audio/enscribe/pkg-plist
@@ -0,0 +1,3 @@
+bin/enscribe
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%