aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-05-29 11:20:14 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-05-29 11:20:14 +0000
commit7a21dec23d525b7d538c8b786a36466c6f42a3fe (patch)
tree0997236aa1cf8c358a3a31d2a2e5911fc3339176
parent21a21949929f981bbd3926ed60498d387612d331 (diff)
downloadports-7a21dec23d525b7d538c8b786a36466c6f42a3fe.tar.gz
ports-7a21dec23d525b7d538c8b786a36466c6f42a3fe.zip
- Convert gmake,bzip2,xz to USES
Approved by: portmgr
Notes
Notes: svn path=/head/; revision=355686
-rw-r--r--sysutils/aimage/Makefile2
-rw-r--r--sysutils/anacron/Makefile2
-rw-r--r--sysutils/and/Makefile2
-rw-r--r--sysutils/apcupsd/Makefile2
-rw-r--r--sysutils/apt/Makefile3
-rw-r--r--sysutils/bubblemon-dockapp/Makefile2
-rw-r--r--sysutils/cfengine34/Makefile3
-rw-r--r--sysutils/chgrep/Makefile2
-rw-r--r--sysutils/createrepo/Makefile2
-rw-r--r--sysutils/debootstrap/Makefile2
-rw-r--r--sysutils/dvdimagecmp/Makefile2
-rw-r--r--sysutils/fcron/Makefile3
-rw-r--r--sysutils/fstyp/Makefile2
-rw-r--r--sysutils/gapcmon/Makefile4
-rw-r--r--sysutils/gkleds2/Makefile3
-rw-r--r--sysutils/gnomebaker/Makefile3
-rw-r--r--sysutils/grub2-efi/Makefile4
-rw-r--r--sysutils/ispman/Makefile3
-rw-r--r--sysutils/ledit/Makefile2
-rw-r--r--sysutils/lineak-defaultplugin/Makefile2
-rw-r--r--sysutils/lineakd/Makefile2
-rw-r--r--sysutils/logtool/Makefile2
-rw-r--r--sysutils/mdcp/Makefile2
-rw-r--r--sysutils/msktutil/Makefile3
-rw-r--r--sysutils/msyslog/Makefile2
-rw-r--r--sysutils/pax-utils/Makefile3
-rw-r--r--sysutils/pmt/Makefile3
-rw-r--r--sysutils/prelink/Makefile3
-rw-r--r--sysutils/rename/Makefile2
-rw-r--r--sysutils/serpentine/Makefile4
-rw-r--r--sysutils/sformat/Makefile2
-rw-r--r--sysutils/slack/Makefile3
-rw-r--r--sysutils/u-boot-beaglebone-eabi/Makefile3
-rw-r--r--sysutils/wmflame/Makefile2
-rw-r--r--sysutils/xlogmaster/Makefile2
-rw-r--r--sysutils/zisofs-tools/Makefile3
36 files changed, 36 insertions, 55 deletions
diff --git a/sysutils/aimage/Makefile b/sysutils/aimage/Makefile
index 1197be240797..c41209f4f1e0 100644
--- a/sysutils/aimage/Makefile
+++ b/sysutils/aimage/Makefile
@@ -12,7 +12,7 @@ COMMENT= Advanced Disk Imager
LIB_DEPENDS= afflib:${PORTSDIR}/sysutils/afflib
USE_OPENSSL= yes
-USE_GMAKE= yes
+USES= gmake
GNU_CONFIGURE= yes
PLIST_FILES= bin/aimage
diff --git a/sysutils/anacron/Makefile b/sysutils/anacron/Makefile
index 1cca549c774a..86381b7149fa 100644
--- a/sysutils/anacron/Makefile
+++ b/sysutils/anacron/Makefile
@@ -12,7 +12,7 @@ COMMENT= Schedules periodic jobs on systems that are not permanently up
MAN8= anacron.8
MAN5= anacrontab.5
-USE_GMAKE= yes
+USES= gmake
USE_RC_SUBR= anacron
SUB_FILES= pkg-message
diff --git a/sysutils/and/Makefile b/sysutils/and/Makefile
index 820faae602dc..166f992d38c1 100644
--- a/sysutils/and/Makefile
+++ b/sysutils/and/Makefile
@@ -9,7 +9,7 @@ MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Auto Nice Daemon
-USE_GMAKE= yes
+USES= gmake
ALL_TARGET= default
NOPRECIOUSMAKEVARS= yes
diff --git a/sysutils/apcupsd/Makefile b/sysutils/apcupsd/Makefile
index 8b659a8463bb..8b42fdf99bd7 100644
--- a/sysutils/apcupsd/Makefile
+++ b/sysutils/apcupsd/Makefile
@@ -22,7 +22,7 @@ USE_RC_SUBR= apcupsd
SUB_FILES= pkg-message
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake
CONFIGURE_ARGS= --sbindir=${PREFIX}/sbin \
--with-nologin=/var/run \
--disable-install-distdir \
diff --git a/sysutils/apt/Makefile b/sysutils/apt/Makefile
index 815077129231..bc5e540d23f9 100644
--- a/sysutils/apt/Makefile
+++ b/sysutils/apt/Makefile
@@ -19,8 +19,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS} \
LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl
GNU_CONFIGURE= yes
-USE_GMAKE= yes
-USES= gettext iconv
+USES= gettext iconv gmake
USE_BDB= 44+
USE_LDCONFIG= yes
NO_FILTER_SHLIBS= yes
diff --git a/sysutils/bubblemon-dockapp/Makefile b/sysutils/bubblemon-dockapp/Makefile
index 96392f482100..2832f369f709 100644
--- a/sysutils/bubblemon-dockapp/Makefile
+++ b/sysutils/bubblemon-dockapp/Makefile
@@ -12,7 +12,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:S/0$//}
MAINTAINER= ports@FreeBSD.org
COMMENT= X eye candy for displaying CPU and memory load in a dock
-USE_GMAKE= yes
+USES= gmake
USE_GNOME= gtk12
MAKE_ARGS+= PREFIX="${PREFIX}"
diff --git a/sysutils/cfengine34/Makefile b/sysutils/cfengine34/Makefile
index d62667db3160..b617b0b27d03 100644
--- a/sysutils/cfengine34/Makefile
+++ b/sysutils/cfengine34/Makefile
@@ -23,11 +23,10 @@ CONFLICTS= cfengine-2* cfengine-3.[235]* cfengine-devel-*
USE_RC_SUBR= cf-execd cf-serverd
-USES= libtool
+USES= libtool gmake
USE_LDCONFIG= yes
USE_OPENSSL= yes
GNU_CONFIGURE= yes
-USE_GMAKE= yes
# EXAMPLESDIR= ${PREFIX}/share/examples/cfengine3
DOCSDIR= ${PREFIX}/share/doc/cfengine
CONFIGURE_ARGS= --docdir=${DOCSDIR} \
diff --git a/sysutils/chgrep/Makefile b/sysutils/chgrep/Makefile
index 40db91e3cf0c..375d73c95336 100644
--- a/sysutils/chgrep/Makefile
+++ b/sysutils/chgrep/Makefile
@@ -11,7 +11,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Fast string substitution across multiple files
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake
PLIST_FILES= bin/chgrep man/man1/${PORTNAME}.1.gz
diff --git a/sysutils/createrepo/Makefile b/sysutils/createrepo/Makefile
index ae842ce5f08a..a01ee9651b00 100644
--- a/sysutils/createrepo/Makefile
+++ b/sysutils/createrepo/Makefile
@@ -16,7 +16,7 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/sqlitecachec.py:${PORTSDIR}/devel/py-yum-metad
${PYTHON_SITELIBDIR}/yum/__init__.py:${PORTSDIR}/sysutils/yum
USE_PYTHON= yes
-USE_GMAKE= yes
+USES= gmake
BUILD_DEPENDS+= ginstall:${PORTSDIR}/sysutils/coreutils
GINSTALL= ginstall
diff --git a/sysutils/debootstrap/Makefile b/sysutils/debootstrap/Makefile
index 449f9baa1ee0..5268f00771db 100644
--- a/sysutils/debootstrap/Makefile
+++ b/sysutils/debootstrap/Makefile
@@ -15,7 +15,7 @@ RUN_DEPENDS= wget:${PORTSDIR}/ftp/wget
WRKSRC= ${WRKDIR}/${DISTNAME:S/_/-/}
NO_BUILD= yes
-USE_GMAKE= yes
+USES= gmake
MAKE_ARGS= DESTDIR="${PREFIX}"
MAN8= debootstrap.8
diff --git a/sysutils/dvdimagecmp/Makefile b/sysutils/dvdimagecmp/Makefile
index f1c1ad6edc13..67fd85551379 100644
--- a/sysutils/dvdimagecmp/Makefile
+++ b/sysutils/dvdimagecmp/Makefile
@@ -11,7 +11,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@thepentagon.org
COMMENT= A simple tool for comparing an image to a burned disc
-USE_GMAKE= yes
+USES= gmake
CFLAGS+= -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
diff --git a/sysutils/fcron/Makefile b/sysutils/fcron/Makefile
index 113a4cc9c4a4..5f392f16f0c2 100644
--- a/sysutils/fcron/Makefile
+++ b/sysutils/fcron/Makefile
@@ -15,8 +15,7 @@ MAINTAINER= rde@tavi.co.uk
COMMENT= A periodic command scheduler
GNU_CONFIGURE= yes
-USE_GMAKE= yes
-USES= perl5
+USES= perl5 gmake
USE_PERL5= build
CONFIGURE_ARGS= --with-etcdir=${PREFIX}/etc --localstatedir=/var \
--with-cflags="${CFLAGS}" \
diff --git a/sysutils/fstyp/Makefile b/sysutils/fstyp/Makefile
index bec689aea736..d83b75ead409 100644
--- a/sysutils/fstyp/Makefile
+++ b/sysutils/fstyp/Makefile
@@ -10,7 +10,7 @@ MAINTAINER= sacchi@gmail.com
COMMENT= Detect which filesystem type a device/partition contains
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake
PLIST_FILES= bin/fstyp
diff --git a/sysutils/gapcmon/Makefile b/sysutils/gapcmon/Makefile
index 41d7b96e1165..0eac0816cc5e 100644
--- a/sysutils/gapcmon/Makefile
+++ b/sysutils/gapcmon/Makefile
@@ -12,10 +12,8 @@ COMMENT= Monitor apcupsd with GTK+2 GUI
LICENSE= GPLv2
SUB_FILES= pkg-message
-USE_BZIP2= yes
-USE_GMAKE= yes
USE_GNOME= gconf2
-USES= pkgconfig
+USES= pkgconfig gmake tar:bzip2
GNU_CONFIGURE= yes
PORTDOCS= AUTHORS ChangeLog INSTALL README
diff --git a/sysutils/gkleds2/Makefile b/sysutils/gkleds2/Makefile
index 77e91ddde3dd..902aeeee4cd6 100644
--- a/sysutils/gkleds2/Makefile
+++ b/sysutils/gkleds2/Makefile
@@ -14,10 +14,9 @@ COMMENT= GKrellM Leds for CapsLock, NumLock, and ScrollLock
BUILD_DEPENDS= ${LOCALBASE}/include/gkrellm2/gkrellm.h:${PORTSDIR}/sysutils/gkrellm2
RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm2
-USES= pkgconfig
+USES= pkgconfig gmake
USE_XORG= x11 xtst
USE_GNOME= gtk20
-USE_GMAKE= yes
USE_AUTOTOOLS= libtool
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/sysutils/gnomebaker/Makefile b/sysutils/gnomebaker/Makefile
index 0d36d4fc6711..461a61b1dc74 100644
--- a/sysutils/gnomebaker/Makefile
+++ b/sysutils/gnomebaker/Makefile
@@ -19,9 +19,8 @@ RUN_DEPENDS+= cdrdao:${PORTSDIR}/sysutils/cdrdao \
USE_GNOME= gnomeprefix gnomehack libgnomeui desktopfileutils
GNU_CONFIGURE= yes
-USE_GMAKE= yes
INSTALLS_OMF= yes
-USES= gettext
+USES= gettext gmake
USE_GSTREAMER= vorbis mp3 flac
INSTALLS_ICONS= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/sysutils/grub2-efi/Makefile b/sysutils/grub2-efi/Makefile
index a878c2c3801e..f17db9423327 100644
--- a/sysutils/grub2-efi/Makefile
+++ b/sysutils/grub2-efi/Makefile
@@ -19,13 +19,11 @@ BUILD_DEPENDS= ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex \
help2man:${PORTSDIR}/misc/help2man
SSP_UNSAFE= yes
-USE_XZ= yes
USE_GCC= yes
USE_AUTOTOOLS= automake aclocal autoconf
ACLOCAL_ARGS= -Im4
GNU_CONFIGURE= yes
-USE_GMAKE= yes
-USES= bison gettext
+USES= bison gettext gmake tar:xz
ONLY_FOR_ARCHS= amd64
MAKE_JOBS_UNSAFE= yes
diff --git a/sysutils/ispman/Makefile b/sysutils/ispman/Makefile
index aea6cbc6e74a..ce2604719ea3 100644
--- a/sysutils/ispman/Makefile
+++ b/sysutils/ispman/Makefile
@@ -32,8 +32,7 @@ RUN_DEPENDS= p5-Text-Balanced>=0:${PORTSDIR}/textproc/p5-Text-Balanced\
p5-I18N-LangTags>=0:${PORTSDIR}/misc/p5-I18N-LangTags \
p5-SOAP-Lite>=0:${PORTSDIR}/net/p5-SOAP-Lite
-USE_GMAKE= yes
-USES= perl5
+USES= perl5 gmake
ALL_TARGET= ispman
HAS_CONFIGURE= yes
diff --git a/sysutils/ledit/Makefile b/sysutils/ledit/Makefile
index 1f574cc8c8cf..49fda91e183e 100644
--- a/sysutils/ledit/Makefile
+++ b/sysutils/ledit/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= camlp5r:${PORTSDIR}/devel/ocaml-camlp5
-USE_GMAKE= yes
+USES= gmake
USE_OCAML= yes
ALL_TARGET= all ledit.opt
diff --git a/sysutils/lineak-defaultplugin/Makefile b/sysutils/lineak-defaultplugin/Makefile
index f9babc1ed9a2..6010440deef8 100644
--- a/sysutils/lineak-defaultplugin/Makefile
+++ b/sysutils/lineak-defaultplugin/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= lineak:${PORTSDIR}/sysutils/lineakd
USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
USE_XORG= x11 xext xt xtst xfixes
-USE_GMAKE= yes
+USES= gmake
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS+= --program-prefix=''
diff --git a/sysutils/lineakd/Makefile b/sysutils/lineakd/Makefile
index 159c0dafe745..d20ee886c75b 100644
--- a/sysutils/lineakd/Makefile
+++ b/sysutils/lineakd/Makefile
@@ -11,7 +11,7 @@ DIST_SUBDIR= lineak
MAINTAINER= ports@FreeBSD.org
COMMENT= Lineakd is a daemon which enables special keys on internet keyboards
-USE_GMAKE= yes
+USES= gmake
USE_XORG= x11 xext xt
USE_AUTOTOOLS= libtool
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/sysutils/logtool/Makefile b/sysutils/logtool/Makefile
index 53c898ce7963..ee9510c3839a 100644
--- a/sysutils/logtool/Makefile
+++ b/sysutils/logtool/Makefile
@@ -9,7 +9,7 @@ MASTER_SITES= http://xjack.org/logtool/download/
MAINTAINER= dhn@FreeBSD.org
COMMENT= Parse ASCII logfiles into ANSI, CSV, HTML formats
-USE_GMAKE= yes
+USES= gmake
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc/${PORTNAME}
diff --git a/sysutils/mdcp/Makefile b/sysutils/mdcp/Makefile
index 955284f9053c..ca975f856774 100644
--- a/sysutils/mdcp/Makefile
+++ b/sysutils/mdcp/Makefile
@@ -10,7 +10,7 @@ MAINTAINER= wamonzyne@hotmail.com
COMMENT= A fastest utility for copy from a disk device for many
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake
PLIST_FILES= sbin/mdcp
diff --git a/sysutils/msktutil/Makefile b/sysutils/msktutil/Makefile
index c3675b59a6f4..4b11acdd6433 100644
--- a/sysutils/msktutil/Makefile
+++ b/sysutils/msktutil/Makefile
@@ -11,8 +11,7 @@ MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE} \
MAINTAINER= zi@FreeBSD.org
COMMENT= Utility to manage Active Directory interoperability
-USE_BZIP2= yes
-USE_GMAKE= yes
+USES= gmake tar:bzip2
USE_OPENLDAP= yes
GNU_CONFIGURE= yes
WANT_OPENLDAP_SASL= yes
diff --git a/sysutils/msyslog/Makefile b/sysutils/msyslog/Makefile
index 6071960df844..8e229f5296d5 100644
--- a/sysutils/msyslog/Makefile
+++ b/sysutils/msyslog/Makefile
@@ -17,7 +17,7 @@ OPTIONS_DEFINE= MYSQL PGSQL
WRKSRC= ${WRKDIR}/${DISTNAME:S/-src//}
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake
USE_RC_SUBR= msyslogd
PKGMESSAGE= ${WRKDIR}/pkg-message
USE_LDCONFIG= yes
diff --git a/sysutils/pax-utils/Makefile b/sysutils/pax-utils/Makefile
index ada1eec7b2cb..4bfab255c8dc 100644
--- a/sysutils/pax-utils/Makefile
+++ b/sysutils/pax-utils/Makefile
@@ -14,8 +14,7 @@ COMMENT= Various ELF related utils for ELF32, ELF64 binaries
LICENSE= GPLv2
-USE_XZ= true
-USE_GMAKE= true
+USES= gmake tar:xz
PLIST_FILES= bin/dumpelf bin/pspax bin/scanelf bin/scanmacho
diff --git a/sysutils/pmt/Makefile b/sysutils/pmt/Makefile
index bb84bb6cbcf8..1f9f6a61a4df 100644
--- a/sysutils/pmt/Makefile
+++ b/sysutils/pmt/Makefile
@@ -10,8 +10,7 @@ MASTER_SITES= http://hansmi.ch/download/pmt/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= Small collection of filters which can be added to UNIX pipes
-USE_BZIP2= yes
-USE_GMAKE= yes
+USES= gmake tar:bzip2
PLIST_FILES= bin/pmt
diff --git a/sysutils/prelink/Makefile b/sysutils/prelink/Makefile
index 92111a3fe6f5..b1524a5f3050 100644
--- a/sysutils/prelink/Makefile
+++ b/sysutils/prelink/Makefile
@@ -12,9 +12,8 @@ COMMENT= ELF prelinking utility to speed up dynamic linking
LIB_DEPENDS= argp:${PORTSDIR}/devel/argp-standalone
BUILD_DEPENDS= fig2dev:${PORTSDIR}/print/transfig
-USE_BZIP2= yes
+USES= gmake tar:bzip2
GNU_CONFIGURE= yes
-USE_GMAKE= yes
USE_AUTOTOOLS= aclocal autoheader automake autoconf libtoolize libtool
ACLOCAL_ARGS= -I . -I ${LOCALBASE}/share/aclocal
AUTOMAKE_ARGS= -c -a
diff --git a/sysutils/rename/Makefile b/sysutils/rename/Makefile
index d4cb4cc6a3dd..0ec43af2daf4 100644
--- a/sysutils/rename/Makefile
+++ b/sysutils/rename/Makefile
@@ -12,7 +12,7 @@ MAINTAINER= jsa@FreeBSD.org
COMMENT= Rename multiple files using regular expressions
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake
PLIST_FILES= bin/${PORTNAME}
MAN1= rename.1
diff --git a/sysutils/serpentine/Makefile b/sysutils/serpentine/Makefile
index aeb77219097f..360732df0ed2 100644
--- a/sysutils/serpentine/Makefile
+++ b/sysutils/serpentine/Makefile
@@ -14,11 +14,9 @@ COMMENT= Gnome Audio Cd Burner
BUILD_DEPENDS= xmlproc_parse:${PORTSDIR}/textproc/py-xml
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USES= pkgconfig
-USE_BZIP2= yes
+USES= pkgconfig gmake tar:bzip2
GNU_CONFIGURE= yes
USE_GNOME= pygnomedesktop intlhack
-USE_GMAKE= yes
USE_GSTREAMER= core gnomevfs python
USE_PYTHON= yes
diff --git a/sysutils/sformat/Makefile b/sysutils/sformat/Makefile
index 4822c9b6c43e..7118326a1c6b 100644
--- a/sysutils/sformat/Makefile
+++ b/sysutils/sformat/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= marius@FreeBSD.org
COMMENT= Allows formatting/partitioning/analysis/repairing of SCSI disks
LIBSCHILY= libschily-2.01.01a07.tar.gz
-USE_GMAKE= yes
+USES= gmake
.include <bsd.port.pre.mk>
diff --git a/sysutils/slack/Makefile b/sysutils/slack/Makefile
index 67f412195e7c..672947b746d5 100644
--- a/sysutils/slack/Makefile
+++ b/sysutils/slack/Makefile
@@ -12,8 +12,7 @@ COMMENT= Configuration management system designed to appeal to lazy admins
RUN_DEPENDS= rsync:${PORTSDIR}/net/rsync
-USES= perl5
-USE_GMAKE= yes
+USES= perl5 gmake
MAN1= slack-diff.1
MAN5= slack.conf.5
diff --git a/sysutils/u-boot-beaglebone-eabi/Makefile b/sysutils/u-boot-beaglebone-eabi/Makefile
index d012ca0f2660..f797b091986a 100644
--- a/sysutils/u-boot-beaglebone-eabi/Makefile
+++ b/sysutils/u-boot-beaglebone-eabi/Makefile
@@ -16,8 +16,7 @@ COMMENT= U-Boot loader for BeagleBone and BeagleBone Black
BUILD_DEPENDS= arm-eabi-gcc:${PORTSDIR}/devel/arm-eabi-gcc
WRKSRC= ${WRKDIR}/u-boot-${PORTVERSION}
-USE_BZIP2= yes
-USE_GMAKE= yes
+USES= gmake tar:bzip2
U_BOOT_DIR= share/u-boot/${PORTNAME}${PKGNAMESUFFIX}
PLIST_FILES= ${U_BOOT_DIR}/bb-uboot.img \
${U_BOOT_DIR}/bb-uenv.txt \
diff --git a/sysutils/wmflame/Makefile b/sysutils/wmflame/Makefile
index 09bda6e84789..a4dfe3816f83 100644
--- a/sysutils/wmflame/Makefile
+++ b/sysutils/wmflame/Makefile
@@ -13,7 +13,7 @@ COMMENT= Dockapp that shows the load average as a flame
LICENSE= GPLv2
-USE_GMAKE= yes
+USES= gmake
USE_XORG= x11 xpm
PLIST_FILES= bin/wmflame
diff --git a/sysutils/xlogmaster/Makefile b/sysutils/xlogmaster/Makefile
index 4e5b9710ed11..35f49bf7de97 100644
--- a/sysutils/xlogmaster/Makefile
+++ b/sysutils/xlogmaster/Makefile
@@ -11,7 +11,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Quick & easy monitoring of logfiles and devices
USE_GNOME= gtk12
-USE_GMAKE= yes
+USES= gmake
GNU_CONFIGURE= yes
MAN1= xlogmaster.1
diff --git a/sysutils/zisofs-tools/Makefile b/sysutils/zisofs-tools/Makefile
index 73926783d4ec..72e8f00e7bf5 100644
--- a/sysutils/zisofs-tools/Makefile
+++ b/sysutils/zisofs-tools/Makefile
@@ -14,8 +14,7 @@ COMMENT= User utilities for zisofs
PORTDOCS= CHANGES COPYING INSTALL MRULES README
USE_AUTOTOOLS= autoconf
-USE_BZIP2= yes
-USE_GMAKE= yes
+USES= gmake tar:bzip2
GNU_CONFIGURE= yes
MAKE_ARGS+= CFLAGS="${CFLAGS} -I${LOCALBASE}/include"