aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2012-07-05 07:46:16 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2012-07-05 07:46:16 +0000
commit9d3051d0d089292c7eb677b4bfd066747db502d7 (patch)
tree24e586b9b4c19debdd2d76a815b10daaba6c7663
parentef1300ddc3494336889dbbac9d15d2b7ae4b84d0 (diff)
downloadports-9d3051d0d089292c7eb677b4bfd066747db502d7.tar.gz
ports-9d3051d0d089292c7eb677b4bfd066747db502d7.zip
- Update to the latest stable version, 1.2.1 [1]
- Drop hardcoded library ABI versions from LIB_DEPENDS [1] - Allow to install unstripped binaries for debugging [2] - Add missing quotes when passing extra CONFIGURE_ARGS Submitted by: Ilya Arkhipov [1] PR: ports/167814 [2]
Notes
Notes: svn path=/head/; revision=300505
-rw-r--r--games/openttd/Makefile31
-rw-r--r--games/openttd/distinfo4
-rw-r--r--games/openttd/pkg-plist25
3 files changed, 30 insertions, 30 deletions
diff --git a/games/openttd/Makefile b/games/openttd/Makefile
index e1c8cdb03629..8c05e72fe447 100644
--- a/games/openttd/Makefile
+++ b/games/openttd/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= openttd
-PORTVERSION= 1.1.5
-PORTREVISION= 2
+PORTVERSION= 1.2.1
CATEGORIES= games
MASTER_SITES= http://gb.binaries.openttd.org/binaries/releases/${PORTVERSION}/ \
http://ftp.snt.utwente.nl/pub/games/openttd/binaries/releases/${PORTVERSION}/ \
@@ -21,10 +20,11 @@ COMMENT= An open source clone of Microprose Transport Tycoon Deluxe
LICENSE= GPLv2
LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
- lzo2.2:${PORTSDIR}/archivers/lzo2
+ lzo2:${PORTSDIR}/archivers/lzo2
USE_XZ= yes
HAS_CONFIGURE= yes
+CONFIGURE_ENV= STRIP="${STRIP_CMD} ${STRIP}"
CONFIGURE_ARGS= --prefix-dir="${PREFIX}" --data-dir="${DATADIR_REL}"
USE_GMAKE= yes
MAKE_ARGS= VERBOSE=1 # We want to see what's going on
@@ -36,7 +36,7 @@ CXXFLAGS= # Set to empty as OpenTTD treats it as an addition to CFLAGS
SUB_FILES= pkg-message
MAN6= ${PORTNAME}.6
-PORTDOCS= 32bpp.txt HOWTO_compile_lang_files.txt admin_network.txt \
+PORTDOCS= HOWTO_compile_lang_files.txt admin_network.txt \
elrail.svg elrail_tile.png elrail_track.png landscape.html \
landscape_externals.html landscape_grid.html multiplayer.txt \
obg_format.txt obm_format.txt obs_format.txt \
@@ -46,11 +46,11 @@ DESKTOP_ENTRIES="OpenTTD" "${COMMENT}" "${PORTNAME}" "${PORTNAME}" \
"Game;Simulation;StrategyGame;" false
.if defined(WITH_MIDI_PLAYER)
-CONFIGURE_ARGS+= --with-midi=${WITH_MIDI_PLAYER}
+CONFIGURE_ARGS+= --with-midi="${WITH_MIDI_PLAYER}"
.endif
.if defined(WITH_MIDI_PLAYER_ARGS)
-CONFIGURE_ARGS+= --with-midi-arg=${WITH_MIDI_PLAYER_ARGS}
+CONFIGURE_ARGS+= --with-midi-arg="${WITH_MIDI_PLAYER_ARGS}"
.endif
.if defined(WITH_DEDICATED_SERVER_ONLY)
@@ -60,16 +60,16 @@ CONFIGURE_ARGS+= --enable-dedicated
CFLAGS+= -I${LOCALBASE}/include
USE_RC_SUBR= ${PORTNAME}
.else
-LIB_DEPENDS+= freetype.9:${PORTSDIR}/print/freetype2 \
- fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig
+LIB_DEPENDS+= freetype:${PORTSDIR}/print/freetype2 \
+ fontconfig:${PORTSDIR}/x11-fonts/fontconfig
USE_SDL= sdl
INSTALLS_ICONS= yes
.endif
.if defined(WITH_OPEN_GAME_FILES)
-RUN_DEPENDS= ${LOCALBASE}/share/${PORTNAME}/data/opengfx/opengfx.obg:${PORTSDIR}/games/opengfx \
- ${LOCALBASE}/share/${PORTNAME}/gm/openmsx/openmsx.obm:${PORTSDIR}/games/openmsx \
- ${LOCALBASE}/share/${PORTNAME}/data/opensfx/opensfx.obs:${PORTSDIR}/games/opensfx
+RUN_DEPENDS+= ${LOCALBASE}/share/${PORTNAME}/baseset/opengfx/opengfx.obg:${PORTSDIR}/games/opengfx \
+ ${LOCALBASE}/share/${PORTNAME}/baseset/openmsx/openmsx.obm:${PORTSDIR}/games/openmsx \
+ ${LOCALBASE}/share/${PORTNAME}/baseset/opensfx/opensfx.obs:${PORTSDIR}/games/opensfx
.endif
.include <bsd.port.pre.mk>
@@ -99,16 +99,15 @@ post-patch:
's,pkg-config liblzma,pkg-config ${FILESDIR}/liblzma.pc,' \
${WRKSRC}/config.lib
.else
-LIB_DEPENDS+= lzma.5:${PORTSDIR}/archivers/xz
+LIB_DEPENDS+= lzma:${PORTSDIR}/archivers/xz
.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/${PORTNAME} ${PREFIX}/bin
- @${MKDIR} ${DATADIR}/ai ${DATADIR}/data ${DATADIR}/gm \
- ${DATADIR}/lang ${DATADIR}/scripts
+ @${MKDIR} ${DATADIR}/ai ${DATADIR}/baseset ${DATADIR}/lang \
+ ${DATADIR}/scripts
${INSTALL_DATA} ${WRKSRC}/bin/ai/*.nut ${DATADIR}/ai
- ${INSTALL_DATA} ${WRKSRC}/bin/data/* ${DATADIR}/data
- ${INSTALL_DATA} ${WRKSRC}/bin/gm/* ${DATADIR}/gm
+ ${INSTALL_DATA} ${WRKSRC}/bin/baseset/* ${DATADIR}/baseset
${INSTALL_DATA} ${WRKSRC}/bin/lang/* ${DATADIR}/lang
${INSTALL_DATA} ${WRKSRC}/bin/scripts/* ${DATADIR}/scripts
${INSTALL_MAN} ${WRKSRC}/docs/${MAN6} ${MANPREFIX}/man/man6
diff --git a/games/openttd/distinfo b/games/openttd/distinfo
index 0eec54ee3750..64e457559f07 100644
--- a/games/openttd/distinfo
+++ b/games/openttd/distinfo
@@ -1,2 +1,2 @@
-SHA256 (openttd-1.1.5-source.tar.xz) = f96b6892ee134acf210c54bc4187c0b578b2525f6e2c11b0500879405ece1f54
-SIZE (openttd-1.1.5-source.tar.xz) = 5261684
+SHA256 (openttd-1.2.1-source.tar.xz) = c8a8ae4e067bf6694f1d1447ddb14fc5e7853961cb1654629cf2c4613ee9f176
+SIZE (openttd-1.2.1-source.tar.xz) = 5712672
diff --git a/games/openttd/pkg-plist b/games/openttd/pkg-plist
index d7c02f77c64d..bece544bda11 100644
--- a/games/openttd/pkg-plist
+++ b/games/openttd/pkg-plist
@@ -3,19 +3,19 @@ share/pixmaps/openttd.32.xpm
%%DATADIR%%/ai/compat_0.7.nut
%%DATADIR%%/ai/compat_1.0.nut
%%DATADIR%%/ai/compat_1.1.nut
+%%DATADIR%%/ai/compat_1.2.nut
@dirrm %%DATADIR%%/ai
-%%DATADIR%%/gm/no_music.obm
-%%DATADIR%%/gm/orig_win.obm
-@dirrmtry %%DATADIR%%/gm
-%%DATADIR%%/data/openttd.grf
-%%DATADIR%%/data/opntitle.dat
-%%DATADIR%%/data/orig_dos.obg
-%%DATADIR%%/data/orig_dos.obs
-%%DATADIR%%/data/orig_dos_de.obg
-%%DATADIR%%/data/orig_win.obg
-%%DATADIR%%/data/orig_win.obs
-%%DATADIR%%/data/no_sound.obs
-@dirrmtry %%DATADIR%%/data
+%%DATADIR%%/baseset/no_music.obm
+%%DATADIR%%/baseset/orig_win.obm
+%%DATADIR%%/baseset/openttd.grf
+%%DATADIR%%/baseset/opntitle.dat
+%%DATADIR%%/baseset/orig_dos.obg
+%%DATADIR%%/baseset/orig_dos.obs
+%%DATADIR%%/baseset/orig_dos_de.obg
+%%DATADIR%%/baseset/orig_win.obg
+%%DATADIR%%/baseset/orig_win.obs
+%%DATADIR%%/baseset/no_sound.obs
+@dirrmtry %%DATADIR%%/baseset
%%DATADIR%%/lang/afrikaans.lng
%%DATADIR%%/lang/arabic_egypt.lng
%%DATADIR%%/lang/brazilian_portuguese.lng
@@ -27,6 +27,7 @@ share/pixmaps/openttd.32.xpm
%%DATADIR%%/lang/danish.lng
%%DATADIR%%/lang/dutch.lng
%%DATADIR%%/lang/english.lng
+%%DATADIR%%/lang/english_AU.lng
%%DATADIR%%/lang/english_US.lng
%%DATADIR%%/lang/esperanto.lng
%%DATADIR%%/lang/estonian.lng