aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2012-04-21 18:48:24 +0000
committerMartin Wilke <miwi@FreeBSD.org>2012-04-21 18:48:24 +0000
commitf3f7ffb70350e76cbd98247d9111f74f46de266d (patch)
tree67febfe5450aa9d53ba6ee22b98d2687c1367706
parentabc61d16d2ed93e08a04f9f316b236f5292a2097 (diff)
downloadports-f3f7ffb70350e76cbd98247d9111f74f46de266d.tar.gz
ports-f3f7ffb70350e76cbd98247d9111f74f46de266d.zip
- Update to version 2.0
PR: 166880 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=295215
-rw-r--r--devel/make++/Makefile33
-rw-r--r--devel/make++/distinfo4
-rw-r--r--devel/make++/pkg-plist122
3 files changed, 112 insertions, 47 deletions
diff --git a/devel/make++/Makefile b/devel/make++/Makefile
index 7b0362148651..763721295e3c 100644
--- a/devel/make++/Makefile
+++ b/devel/make++/Makefile
@@ -7,10 +7,11 @@
#
PORTNAME= make++
-DISTVERSION= 1.40.1a
+PORTVERSION= 2.0
CATEGORIES= devel perl5
-MASTER_SITES= SF/${PORTNAME:S/+/p/g}/${DISTVERSION:S/a//}
-DISTNAME= ${PORTNAME:S/+/p/g}-${DISTVERSION:S/\.a//}
+MASTER_SITES= SF/${PORTNAME:S/+/p/g}/${PORTVERSION}
+DISTNAME= ${PORTNAME:S/+/p/g}-${PORTVERSION}
+EXTRACT_SUFX= .txz
MAINTAINER= ports@FreeBSD.org
COMMENT= A drop-in replacement for GNU make
@@ -18,8 +19,7 @@ COMMENT= A drop-in replacement for GNU make
LICENSE= ART10 GPLv1 GPLv2 GPLv3
LICENSE_COMB= dual
-WRKSRC= ${WRKDIR}/${PORTNAME:S/+/p/g}-${DISTVERSION:R}
-
+USE_XZ= yes
USE_PERL5= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX} --mandir=${MANPREFIX}/man
@@ -28,14 +28,21 @@ DATADIR= ${PREFIX}/share/${PORTNAME:S/+/p/g}
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME:S/+/p/g}
MAN1= makepp.1 makepp_build_algorithm.1 \
- makepp_builtin.1 makepp_command.1 \
+ makepp_build_cache.1 makepp_build_check.1 \
+ makepp_builtin.1 makepp_builtins.1 \
+ makepp_command.1 makepp_compatibility.1 \
makepp_cookbook.1 makepp_extending.1 \
- makepp_functions.1 makepp_incompatibilities.1 \
- makepp_release_notes.1 makepp_repositories.1 \
- makepp_rules.1 makepp_scanning.1 \
- makepp_signatures.1 makepp_statements.1 \
- makepp_tutorial.1 makepp_tutorial_compilation.1 \
- makepp_variables.1 makeppclient.1
+ makepp_faq.1 makepp_functions.1 \
+ makepp_incompatibilities.1 makepp_release_notes.1 \
+ makepp_repositories.1 makepp_rules.1 \
+ makepp_sandboxes.1 makepp_scanning.1 \
+ makepp_signatures.1 makepp_speedup.1 \
+ makepp_statements.1 makepp_tutorial.1 \
+ makepp_tutorial_compilation.1 makepp_variables.1 \
+ makeppbuiltin.1 makeppclean.1 \
+ makeppgraph.1 makeppinfo.1 \
+ makepplog.1 makeppreplay.1 \
+ perl_performance.1
.include <bsd.port.pre.mk>
@@ -50,6 +57,6 @@ CONFIGURE_ARGS+=--htmldir=${DOCSDIR}/html
.endif
post-patch:
- @${REINPLACE_CMD} -e '/^all:/s|test||' ${WRKSRC}/config.pl
+ @${TOUCH} ${WRKSRC}/.test_done
.include <bsd.port.post.mk>
diff --git a/devel/make++/distinfo b/devel/make++/distinfo
index 43e0e5996530..8a2e293ac77d 100644
--- a/devel/make++/distinfo
+++ b/devel/make++/distinfo
@@ -1,2 +1,2 @@
-SHA256 (makepp-1.40.1a.tar.gz) = eb9991e9c726836e9b214377976dc15f66f4f6045f9713cd36c8c6b73c1f8e83
-SIZE (makepp-1.40.1a.tar.gz) = 278170
+SHA256 (makepp-2.0.txz) = 0c617b1c23b537070d43ace2501ac1b30503b126a729206a7853933485d2bc78
+SIZE (makepp-2.0.txz) = 534708
diff --git a/devel/make++/pkg-plist b/devel/make++/pkg-plist
index 048085869a1b..33363d6d33f0 100644
--- a/devel/make++/pkg-plist
+++ b/devel/make++/pkg-plist
@@ -1,57 +1,115 @@
bin/makepp
-bin/makeppclient
+bin/makepp_build_cache_control
+bin/makeppbuiltin
+bin/makeppclean
+bin/makeppgraph
+bin/makeppinfo
+bin/makepplog
+bin/makeppreplay
+bin/mpp
+bin/mppb
+bin/mppbcc
+bin/mppc
+bin/mppg
+bin/mppi
+bin/mppl
+bin/mppr
+%%PORTDOCS%%%%DOCSDIR%%/html/bg.png
+%%PORTDOCS%%%%DOCSDIR%%/html/google.png
%%PORTDOCS%%%%DOCSDIR%%/html/index.html
+%%PORTDOCS%%%%DOCSDIR%%/html/makepp.css
%%PORTDOCS%%%%DOCSDIR%%/html/makepp.html
+%%PORTDOCS%%%%DOCSDIR%%/html/makepp.js
+%%PORTDOCS%%%%DOCSDIR%%/html/makepp.png
%%PORTDOCS%%%%DOCSDIR%%/html/makepp_build_algorithm.html
+%%PORTDOCS%%%%DOCSDIR%%/html/makepp_build_cache.html
+%%PORTDOCS%%%%DOCSDIR%%/html/makepp_build_check.html
%%PORTDOCS%%%%DOCSDIR%%/html/makepp_builtin.html
+%%PORTDOCS%%%%DOCSDIR%%/html/makepp_builtins.html
%%PORTDOCS%%%%DOCSDIR%%/html/makepp_command.html
+%%PORTDOCS%%%%DOCSDIR%%/html/makepp_compatibility.html
%%PORTDOCS%%%%DOCSDIR%%/html/makepp_cookbook.html
%%PORTDOCS%%%%DOCSDIR%%/html/makepp_extending.html
+%%PORTDOCS%%%%DOCSDIR%%/html/makepp_faq.html
%%PORTDOCS%%%%DOCSDIR%%/html/makepp_functions.html
%%PORTDOCS%%%%DOCSDIR%%/html/makepp_incompatibilities.html
+%%PORTDOCS%%%%DOCSDIR%%/html/makepp_index.html
%%PORTDOCS%%%%DOCSDIR%%/html/makepp_release_notes.html
%%PORTDOCS%%%%DOCSDIR%%/html/makepp_repositories.html
%%PORTDOCS%%%%DOCSDIR%%/html/makepp_rules.html
+%%PORTDOCS%%%%DOCSDIR%%/html/makepp_sandboxes.html
%%PORTDOCS%%%%DOCSDIR%%/html/makepp_scanning.html
%%PORTDOCS%%%%DOCSDIR%%/html/makepp_signatures.html
+%%PORTDOCS%%%%DOCSDIR%%/html/makepp_speedup.html
%%PORTDOCS%%%%DOCSDIR%%/html/makepp_statements.html
%%PORTDOCS%%%%DOCSDIR%%/html/makepp_tutorial.html
%%PORTDOCS%%%%DOCSDIR%%/html/makepp_tutorial_compilation.html
%%PORTDOCS%%%%DOCSDIR%%/html/makepp_variables.html
-%%PORTDOCS%%%%DOCSDIR%%/html/makeppclient.html
-%%DATADIR%%/ActionParser/Legacy.pm
-%%DATADIR%%/ActionParser/Specific.pm
-%%DATADIR%%/ActionParser.pm
-%%DATADIR%%/CommandParser/Basic.pm
-%%DATADIR%%/CommandParser/Gcc.pm
-%%DATADIR%%/CommandParser/Vcs.pm
-%%DATADIR%%/CommandParser.pm
-%%DATADIR%%/FileInfo.pm
-%%DATADIR%%/FileInfo_makepp.pm
-%%DATADIR%%/Glob.pm
-%%DATADIR%%/MakeEvent.pm
-%%DATADIR%%/Makefile.pm
-%%DATADIR%%/Makesubs.pm
-%%DATADIR%%/Rule.pm
-%%DATADIR%%/Scanner/C.pm
-%%DATADIR%%/Scanner/Vera.pm
-%%DATADIR%%/Scanner/Verilog.pm
-%%DATADIR%%/Scanner.pm
-%%DATADIR%%/Signature/c_compilation_md5.pm
-%%DATADIR%%/Signature/exact_match.pm
-%%DATADIR%%/Signature/md5.pm
-%%DATADIR%%/Signature/target_newer.pm
-%%DATADIR%%/Signature/verilog_simulation_md5.pm
-%%DATADIR%%/Signature/verilog_synthesis_md5.pm
-%%DATADIR%%/Signature.pm
-%%DATADIR%%/TextSubs.pm
+%%PORTDOCS%%%%DOCSDIR%%/html/makeppbuiltin.html
+%%PORTDOCS%%%%DOCSDIR%%/html/makeppclean.html
+%%PORTDOCS%%%%DOCSDIR%%/html/makeppgraph.html
+%%PORTDOCS%%%%DOCSDIR%%/html/makeppinfo.html
+%%PORTDOCS%%%%DOCSDIR%%/html/makepplog.html
+%%PORTDOCS%%%%DOCSDIR%%/html/makeppreplay.html
+%%PORTDOCS%%%%DOCSDIR%%/html/nav.png
+%%PORTDOCS%%%%DOCSDIR%%/html/nav2.png
+%%PORTDOCS%%%%DOCSDIR%%/html/perl_performance.html
+%%PORTDOCS%%%%DOCSDIR%%/html/tabs.png
+%%PORTDOCS%%%%DOCSDIR%%/html/url.png
+%%DATADIR%%/Mpp/ActionParser/Legacy.pm
+%%DATADIR%%/Mpp/ActionParser/Specific.pm
+%%DATADIR%%/Mpp/BuildCache.pm
+%%DATADIR%%/Mpp/BuildCacheControl.pm
+%%DATADIR%%/Mpp/BuildCheck/architecture_independent.pm
+%%DATADIR%%/Mpp/BuildCheck/exact_match.pm
+%%DATADIR%%/Mpp/BuildCheck/ignore_action.pm
+%%DATADIR%%/Mpp/BuildCheck/only_action.pm
+%%DATADIR%%/Mpp/BuildCheck/target_newer.pm
+%%DATADIR%%/Mpp/BuildCheck.pm
+%%DATADIR%%/Mpp/Cmds.pm
+%%DATADIR%%/Mpp/CommandParser/Esql.pm
+%%DATADIR%%/Mpp/CommandParser/Gcc.pm
+%%DATADIR%%/Mpp/CommandParser/Swig.pm
+%%DATADIR%%/Mpp/CommandParser/Vcs.pm
+%%DATADIR%%/Mpp/CommandParser.pm
+%%DATADIR%%/Mpp/Event.pm
+%%DATADIR%%/Mpp/File.pm
+%%DATADIR%%/Mpp/FileOpt.pm
+%%DATADIR%%/Mpp/Fixer/Automake.pm
+%%DATADIR%%/Mpp/Fixer/CMake.pm
+%%DATADIR%%/Mpp/Glob.pm
+%%DATADIR%%/Mpp/Lexer.pm
+%%DATADIR%%/Mpp/Makefile.pm
+%%DATADIR%%/Mpp/Recursive.pm
+%%DATADIR%%/Mpp/Repository.pm
+%%DATADIR%%/Mpp/Rule.pm
+%%DATADIR%%/Mpp/Scanner/C.pm
+%%DATADIR%%/Mpp/Scanner/Esqlc.pm
+%%DATADIR%%/Mpp/Scanner/Swig.pm
+%%DATADIR%%/Mpp/Scanner/Vera.pm
+%%DATADIR%%/Mpp/Scanner/Verilog.pm
+%%DATADIR%%/Mpp/Scanner.pm
+%%DATADIR%%/Mpp/Signature/c_compilation_md5.pm
+%%DATADIR%%/Mpp/Signature/md5.pm
+%%DATADIR%%/Mpp/Signature/shared_object.pm
+%%DATADIR%%/Mpp/Signature/verilog_synthesis_md5.pm
+%%DATADIR%%/Mpp/Signature/xml.pm
+%%DATADIR%%/Mpp/Signature/xml_space.pm
+%%DATADIR%%/Mpp/Signature.pm
+%%DATADIR%%/Mpp/Subs.pm
+%%DATADIR%%/Mpp/Text.pm
+%%DATADIR%%/Mpp/Utils.pm
+%%DATADIR%%/Mpp.pm
%%DATADIR%%/makepp_builtin_rules.mk
%%DATADIR%%/makepp_default_makefile.mk
%%DATADIR%%/recursive_makepp
-@dirrm %%DATADIR%%/Signature
-@dirrm %%DATADIR%%/Scanner
-@dirrm %%DATADIR%%/CommandParser
-@dirrm %%DATADIR%%/ActionParser
+@dirrm %%DATADIR%%/Mpp/Signature
+@dirrm %%DATADIR%%/Mpp/Scanner
+@dirrm %%DATADIR%%/Mpp/Fixer
+@dirrm %%DATADIR%%/Mpp/CommandParser
+@dirrm %%DATADIR%%/Mpp/BuildCheck
+@dirrm %%DATADIR%%/Mpp/ActionParser
+@dirrm %%DATADIR%%/Mpp
@dirrm %%DATADIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
%%PORTDOCS%%@dirrm %%DOCSDIR%%