aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-06-16 13:24:54 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-06-16 13:24:54 +0000
commit3351f07e72f6a9e713262cea6369dc403cb30b9c (patch)
tree14dca9a2f8856fca8139550bc80fdbc014b64626
parentcd525c0664a874a72772cfa27b356675689e8846 (diff)
downloadports-3351f07e72f6a9e713262cea6369dc403cb30b9c.tar.gz
ports-3351f07e72f6a9e713262cea6369dc403cb30b9c.zip
MFH: r389839
- Fix build on pre-10.x by requiring newer OpenSSL version from ports - Fix build with NLS disabled by adding gettext-tools dependency Approved by: ports-secteam (erwin)
Notes
Notes: svn path=/branches/2015Q2/; revision=389842
-rw-r--r--irc/hexchat/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/irc/hexchat/Makefile b/irc/hexchat/Makefile
index c2ecb2e32b41..978024e98308 100644
--- a/irc/hexchat/Makefile
+++ b/irc/hexchat/Makefile
@@ -20,6 +20,7 @@ CONFIGURE_ARGS+=--enable-openssl --enable-gtkfe --disable-sysinfo \
--with-pkgconfigdir=${LOCALBASE}/libdata/pkgconfig
INSTALLS_ICONS= yes
INSTALL_TARGET= install-strip
+USE_OPENSSL= yes
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib -lX11
@@ -51,6 +52,7 @@ DOAT_CONFIGURE_ENABLE= doat
FISHLIM_CONFIGURE_ENABLE= fishlim
NLS_CONFIGURE_ENABLE= nls
NLS_USES= gettext
+NLS_USES_OFF= gettext-tools # doesn't build otherwise
NOTIFY_RUN_DEPENDS= notify-send:${PORTSDIR}/devel/libnotify
NOTIFY_CONFIGURE_ENABLE= libnotify
PERL_CONFIGURE_ENABLE= perl
@@ -61,6 +63,12 @@ TEXTFE_CONFIGURE_ENABLE= textfe
.include <bsd.port.options.mk>
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000000
+WITH_OPENSSL_PORT= yes
+.endif
+
+.include <bsd.port.pre.mk>
+
.if ${PORT_OPTIONS:MCA_BUNDLE}
CA_BUNDLE= "${LOCALBASE}/share/certs/ca-root-nss.crt"
.else
@@ -93,4 +101,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/*.md ${STAGEDIR}${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>