aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2015-12-16 09:37:45 +0000
committerJan Beich <jbeich@FreeBSD.org>2015-12-16 09:37:45 +0000
commitab9e0736d58c185d565cde65e8aaf50c38226ea9 (patch)
tree01d43647787c90ec24d8ded6c52221b97251323d
parent7304c3ca9cdb66eb0c6e852e98d8a93cf66a0a0d (diff)
downloadports-ab9e0736d58c185d565cde65e8aaf50c38226ea9.tar.gz
ports-ab9e0736d58c185d565cde65e8aaf50c38226ea9.zip
gecko: drop FreeBSD 8.x and 9.0 support
Notes
Notes: svn path=/head/; revision=403852
-rw-r--r--mail/thunderbird/Makefile3
-rw-r--r--mail/thunderbird/files/patch-media-libstagefright-foundation-AString.cpp16
-rw-r--r--mail/thunderbird/files/patch-media-webrtc-trunk-src-system_wrappers-source-spreadsortlib-spreadsort.hpp16
-rw-r--r--www/firefox-esr/Makefile3
-rw-r--r--www/firefox-esr/files/patch-media-libstagefright-foundation-AString.cpp16
-rw-r--r--www/firefox-esr/files/patch-media-webrtc-trunk-src-system_wrappers-source-spreadsortlib-spreadsort.hpp16
-rw-r--r--www/firefox/Makefile3
-rw-r--r--www/firefox/files/patch-media-libstagefright-foundation-AString.cpp16
-rw-r--r--www/firefox/files/patch-media-webrtc-trunk-src-system_wrappers-source-spreadsortlib-spreadsort.hpp16
-rw-r--r--www/libxul/Makefile3
-rw-r--r--www/libxul/files/patch-media-libstagefright-foundation-AString.cpp16
-rw-r--r--www/libxul/files/patch-media-webrtc-trunk-src-system_wrappers-source-spreadsortlib-spreadsort.hpp16
-rw-r--r--www/seamonkey/Makefile3
-rw-r--r--www/seamonkey/files/patch-media-libstagefright-foundation-AString.cpp16
-rw-r--r--www/seamonkey/files/patch-media-webrtc-trunk-src-system_wrappers-source-spreadsortlib-spreadsort.hpp16
15 files changed, 5 insertions, 170 deletions
diff --git a/mail/thunderbird/Makefile b/mail/thunderbird/Makefile
index ac35d61ebe9a..b28978a91137 100644
--- a/mail/thunderbird/Makefile
+++ b/mail/thunderbird/Makefile
@@ -40,8 +40,7 @@ USE_MOZILLA= -opus
USE_QT5= # empty
QT_NONSTANDARD= yes
USE_GL= gl
-USES= dos2unix tar:bzip2
-DOS2UNIX_FILES= mozilla/media/webrtc/trunk/webrtc/system_wrappers/source/spreadsortlib/spreadsort.hpp
+USES= tar:bzip2
MOZ_OPTIONS= --program-transform-name='s/thunderbird/${MOZILLA}/' \
--enable-single-profile --disable-profilesharing \
diff --git a/mail/thunderbird/files/patch-media-libstagefright-foundation-AString.cpp b/mail/thunderbird/files/patch-media-libstagefright-foundation-AString.cpp
deleted file mode 100644
index 063cc52226d3..000000000000
--- a/mail/thunderbird/files/patch-media-libstagefright-foundation-AString.cpp
+++ /dev/null
@@ -1,16 +0,0 @@
---- mozilla/media/libstagefright/frameworks/av/media/libstagefright/foundation/AString.cpp~
-+++ mozilla/media/libstagefright/frameworks/av/media/libstagefright/foundation/AString.cpp
-@@ -23,6 +23,13 @@
- #include "ADebug.h"
- #include "AString.h"
-
-+#ifdef __FreeBSD__
-+# include <osreldate.h>
-+# if __FreeBSD_version < 900506
-+# undef tolower
-+# endif
-+#endif
-+
- namespace stagefright {
-
- // static
diff --git a/mail/thunderbird/files/patch-media-webrtc-trunk-src-system_wrappers-source-spreadsortlib-spreadsort.hpp b/mail/thunderbird/files/patch-media-webrtc-trunk-src-system_wrappers-source-spreadsortlib-spreadsort.hpp
deleted file mode 100644
index 65a568c22ddf..000000000000
--- a/mail/thunderbird/files/patch-media-webrtc-trunk-src-system_wrappers-source-spreadsortlib-spreadsort.hpp
+++ /dev/null
@@ -1,16 +0,0 @@
---- mozilla/media/webrtc/trunk/webrtc/system_wrappers/source/spreadsortlib/spreadsort.hpp~
-+++ mozilla/media/webrtc/trunk/webrtc/system_wrappers/source/spreadsortlib/spreadsort.hpp
-@@ -21,6 +21,13 @@ Scott McMurray
- #include "constants.hpp"
- #include <cstring>
-
-+#ifdef __FreeBSD__
-+# include <osreldate.h>
-+# if __FreeBSD_version < 900506
-+# define getchar boost_getchar
-+# endif
-+#endif
-+
- namespace boost {
- namespace detail {
- //This only works on unsigned data types
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index dcf9691015a0..1fd820f2b990 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -41,8 +41,7 @@ MOZILLA_NAME= Firefox
USE_QT5= # empty
QT_NONSTANDARD= yes
USE_GL= gl
-USES= dos2unix tar:bzip2
-DOS2UNIX_FILES= media/webrtc/trunk/webrtc/system_wrappers/source/spreadsortlib/spreadsort.hpp
+USES= tar:bzip2
FIREFOX_ICON= ${MOZILLA}.png
FIREFOX_ICON_SRC= ${PREFIX}/lib/${MOZILLA}/browser/chrome/icons/default/default48.png
diff --git a/www/firefox-esr/files/patch-media-libstagefright-foundation-AString.cpp b/www/firefox-esr/files/patch-media-libstagefright-foundation-AString.cpp
deleted file mode 100644
index 530902b13393..000000000000
--- a/www/firefox-esr/files/patch-media-libstagefright-foundation-AString.cpp
+++ /dev/null
@@ -1,16 +0,0 @@
---- media/libstagefright/frameworks/av/media/libstagefright/foundation/AString.cpp~
-+++ media/libstagefright/frameworks/av/media/libstagefright/foundation/AString.cpp
-@@ -23,6 +23,13 @@
- #include "ADebug.h"
- #include "AString.h"
-
-+#ifdef __FreeBSD__
-+# include <osreldate.h>
-+# if __FreeBSD_version < 900506
-+# undef tolower
-+# endif
-+#endif
-+
- namespace stagefright {
-
- // static
diff --git a/www/firefox-esr/files/patch-media-webrtc-trunk-src-system_wrappers-source-spreadsortlib-spreadsort.hpp b/www/firefox-esr/files/patch-media-webrtc-trunk-src-system_wrappers-source-spreadsortlib-spreadsort.hpp
deleted file mode 100644
index eeb58e7baa20..000000000000
--- a/www/firefox-esr/files/patch-media-webrtc-trunk-src-system_wrappers-source-spreadsortlib-spreadsort.hpp
+++ /dev/null
@@ -1,16 +0,0 @@
---- media/webrtc/trunk/webrtc/system_wrappers/source/spreadsortlib/spreadsort.hpp~
-+++ media/webrtc/trunk/webrtc/system_wrappers/source/spreadsortlib/spreadsort.hpp
-@@ -21,6 +21,13 @@ Scott McMurray
- #include "constants.hpp"
- #include <cstring>
-
-+#ifdef __FreeBSD__
-+# include <osreldate.h>
-+# if __FreeBSD_version < 900506
-+# define getchar boost_getchar
-+# endif
-+#endif
-+
- namespace boost {
- namespace detail {
- //This only works on unsigned data types
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index a023757262f5..239caf8db980 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -40,8 +40,7 @@ MOZILLA_NAME= Firefox
USE_QT5= # empty
QT_NONSTANDARD= yes
USE_GL= gl
-USES= dos2unix tar:xz
-DOS2UNIX_FILES= media/webrtc/trunk/webrtc/system_wrappers/source/spreadsortlib/spreadsort.hpp
+USES= tar:xz
FIREFOX_ICON= ${MOZILLA}.png
FIREFOX_ICON_SRC= ${PREFIX}/lib/${MOZILLA}/browser/chrome/icons/default/default48.png
diff --git a/www/firefox/files/patch-media-libstagefright-foundation-AString.cpp b/www/firefox/files/patch-media-libstagefright-foundation-AString.cpp
deleted file mode 100644
index 530902b13393..000000000000
--- a/www/firefox/files/patch-media-libstagefright-foundation-AString.cpp
+++ /dev/null
@@ -1,16 +0,0 @@
---- media/libstagefright/frameworks/av/media/libstagefright/foundation/AString.cpp~
-+++ media/libstagefright/frameworks/av/media/libstagefright/foundation/AString.cpp
-@@ -23,6 +23,13 @@
- #include "ADebug.h"
- #include "AString.h"
-
-+#ifdef __FreeBSD__
-+# include <osreldate.h>
-+# if __FreeBSD_version < 900506
-+# undef tolower
-+# endif
-+#endif
-+
- namespace stagefright {
-
- // static
diff --git a/www/firefox/files/patch-media-webrtc-trunk-src-system_wrappers-source-spreadsortlib-spreadsort.hpp b/www/firefox/files/patch-media-webrtc-trunk-src-system_wrappers-source-spreadsortlib-spreadsort.hpp
deleted file mode 100644
index eeb58e7baa20..000000000000
--- a/www/firefox/files/patch-media-webrtc-trunk-src-system_wrappers-source-spreadsortlib-spreadsort.hpp
+++ /dev/null
@@ -1,16 +0,0 @@
---- media/webrtc/trunk/webrtc/system_wrappers/source/spreadsortlib/spreadsort.hpp~
-+++ media/webrtc/trunk/webrtc/system_wrappers/source/spreadsortlib/spreadsort.hpp
-@@ -21,6 +21,13 @@ Scott McMurray
- #include "constants.hpp"
- #include <cstring>
-
-+#ifdef __FreeBSD__
-+# include <osreldate.h>
-+# if __FreeBSD_version < 900506
-+# define getchar boost_getchar
-+# endif
-+#endif
-+
- namespace boost {
- namespace detail {
- //This only works on unsigned data types
diff --git a/www/libxul/Makefile b/www/libxul/Makefile
index b0b9e2ba96a9..d66ed451e283 100644
--- a/www/libxul/Makefile
+++ b/www/libxul/Makefile
@@ -35,8 +35,7 @@ CONFLICTS_INSTALL= libxul-1.9.*
USE_QT5= # empty
QT_NONSTANDARD= yes
USE_GL= gl
-USES= dos2unix pathfix tar:bzip2
-DOS2UNIX_FILES= media/webrtc/trunk/webrtc/system_wrappers/source/spreadsortlib/spreadsort.hpp
+USES= pathfix tar:bzip2
MAKE_ENV= SKIP_GRE_REGISTRATION=1 mozappdir=${PREFIX}/lib/${MOZILLA}
LDFLAGS+= -Wl,-rpath,${PREFIX}/lib/${MOZ_RPATH}
USE_LDCONFIG= ${PREFIX}/lib/${MOZILLA}
diff --git a/www/libxul/files/patch-media-libstagefright-foundation-AString.cpp b/www/libxul/files/patch-media-libstagefright-foundation-AString.cpp
deleted file mode 100644
index 530902b13393..000000000000
--- a/www/libxul/files/patch-media-libstagefright-foundation-AString.cpp
+++ /dev/null
@@ -1,16 +0,0 @@
---- media/libstagefright/frameworks/av/media/libstagefright/foundation/AString.cpp~
-+++ media/libstagefright/frameworks/av/media/libstagefright/foundation/AString.cpp
-@@ -23,6 +23,13 @@
- #include "ADebug.h"
- #include "AString.h"
-
-+#ifdef __FreeBSD__
-+# include <osreldate.h>
-+# if __FreeBSD_version < 900506
-+# undef tolower
-+# endif
-+#endif
-+
- namespace stagefright {
-
- // static
diff --git a/www/libxul/files/patch-media-webrtc-trunk-src-system_wrappers-source-spreadsortlib-spreadsort.hpp b/www/libxul/files/patch-media-webrtc-trunk-src-system_wrappers-source-spreadsortlib-spreadsort.hpp
deleted file mode 100644
index eeb58e7baa20..000000000000
--- a/www/libxul/files/patch-media-webrtc-trunk-src-system_wrappers-source-spreadsortlib-spreadsort.hpp
+++ /dev/null
@@ -1,16 +0,0 @@
---- media/webrtc/trunk/webrtc/system_wrappers/source/spreadsortlib/spreadsort.hpp~
-+++ media/webrtc/trunk/webrtc/system_wrappers/source/spreadsortlib/spreadsort.hpp
-@@ -21,6 +21,13 @@ Scott McMurray
- #include "constants.hpp"
- #include <cstring>
-
-+#ifdef __FreeBSD__
-+# include <osreldate.h>
-+# if __FreeBSD_version < 900506
-+# define getchar boost_getchar
-+# endif
-+#endif
-+
- namespace boost {
- namespace detail {
- //This only works on unsigned data types
diff --git a/www/seamonkey/Makefile b/www/seamonkey/Makefile
index d7be3c37761e..dafe0140361a 100644
--- a/www/seamonkey/Makefile
+++ b/www/seamonkey/Makefile
@@ -40,8 +40,7 @@ USE_GECKO= gecko
USE_QT5= # empty
QT_NONSTANDARD= yes
USE_GL= gl
-USES= dos2unix tar:xz
-DOS2UNIX_FILES= mozilla/media/webrtc/trunk/webrtc/system_wrappers/source/spreadsortlib/spreadsort.hpp
+USES= tar:xz
MOZ_PIS_SCRIPTS= moz_pis_S50cleanhome
MOZ_EXTENSIONS= default
diff --git a/www/seamonkey/files/patch-media-libstagefright-foundation-AString.cpp b/www/seamonkey/files/patch-media-libstagefright-foundation-AString.cpp
deleted file mode 100644
index 063cc52226d3..000000000000
--- a/www/seamonkey/files/patch-media-libstagefright-foundation-AString.cpp
+++ /dev/null
@@ -1,16 +0,0 @@
---- mozilla/media/libstagefright/frameworks/av/media/libstagefright/foundation/AString.cpp~
-+++ mozilla/media/libstagefright/frameworks/av/media/libstagefright/foundation/AString.cpp
-@@ -23,6 +23,13 @@
- #include "ADebug.h"
- #include "AString.h"
-
-+#ifdef __FreeBSD__
-+# include <osreldate.h>
-+# if __FreeBSD_version < 900506
-+# undef tolower
-+# endif
-+#endif
-+
- namespace stagefright {
-
- // static
diff --git a/www/seamonkey/files/patch-media-webrtc-trunk-src-system_wrappers-source-spreadsortlib-spreadsort.hpp b/www/seamonkey/files/patch-media-webrtc-trunk-src-system_wrappers-source-spreadsortlib-spreadsort.hpp
deleted file mode 100644
index 65a568c22ddf..000000000000
--- a/www/seamonkey/files/patch-media-webrtc-trunk-src-system_wrappers-source-spreadsortlib-spreadsort.hpp
+++ /dev/null
@@ -1,16 +0,0 @@
---- mozilla/media/webrtc/trunk/webrtc/system_wrappers/source/spreadsortlib/spreadsort.hpp~
-+++ mozilla/media/webrtc/trunk/webrtc/system_wrappers/source/spreadsortlib/spreadsort.hpp
-@@ -21,6 +21,13 @@ Scott McMurray
- #include "constants.hpp"
- #include <cstring>
-
-+#ifdef __FreeBSD__
-+# include <osreldate.h>
-+# if __FreeBSD_version < 900506
-+# define getchar boost_getchar
-+# endif
-+#endif
-+
- namespace boost {
- namespace detail {
- //This only works on unsigned data types