aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-06-02 15:33:46 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-06-02 15:33:46 +0000
commit04c55a23227ec2c7e08b9eb43432acba2c9df0aa (patch)
tree5bc8798b6d9ff5756bd2fde58903b7bd23693d1f
parenta2c463183a666e7ffe3f2723be3efc5cea82c412 (diff)
downloadports-04c55a23227ec2c7e08b9eb43432acba2c9df0aa.tar.gz
ports-04c55a23227ec2c7e08b9eb43432acba2c9df0aa.zip
Plzip is a massively parallel (multi-threaded), lossless data
compressor based on the LZMA algorithm, with very safe integrity checking and a user interface similar to the one of gzip or bzip2. Plzip uses the lzip file format; the files produced by plzip are fully compatible with lzip-1.4 or newer. WWW: http://www.nongnu.org/lzip/plzip.html Albert Vernon <f3cun3c02@sneakemail.com> PR: ports/146884 Submitted by: Albert Vernon <f3cun3c02 at sneakemail.com>
Notes
Notes: svn path=/head/; revision=255543
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/plzip/Makefile25
-rw-r--r--archivers/plzip/distinfo3
-rw-r--r--archivers/plzip/pkg-descr9
4 files changed, 38 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index f84e577ffc9c..85bcea6e9276 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -137,6 +137,7 @@
SUBDIR += php52-zip
SUBDIR += php52-zlib
SUBDIR += pigz
+ SUBDIR += plzip
SUBDIR += ppmd
SUBDIR += ppmd-7z
SUBDIR += ppunpack
diff --git a/archivers/plzip/Makefile b/archivers/plzip/Makefile
new file mode 100644
index 000000000000..10e2c52f3c19
--- /dev/null
+++ b/archivers/plzip/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: plzip
+# Date created: 2010-05-22
+# Whom: Albert Vernon <f3cun3c02@sneakemail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= plzip
+PORTVERSION= 0.6
+CATEGORIES= archivers
+MASTER_SITES= SAVANNAH/lzip
+
+MAINTAINER= f3cun3c02@sneakemail.com
+COMMENT= Is a parallel, lossless data compressor based on the LZMA algorithm
+
+BUILD_DEPENDS= lzlib>=1.0:${PORTSDIR}/archivers/lzlib
+
+PLIST_FILES= bin/plzip
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= CXXFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+MAN1= plzip.1
+INFO= plzip
+.include <bsd.port.mk>
diff --git a/archivers/plzip/distinfo b/archivers/plzip/distinfo
new file mode 100644
index 000000000000..b63a30a6fd5d
--- /dev/null
+++ b/archivers/plzip/distinfo
@@ -0,0 +1,3 @@
+MD5 (plzip-0.6.tar.gz) = f452029b1e8232cbe837f4437613e1ed
+SHA256 (plzip-0.6.tar.gz) = 6ce0e98027399694d93dc46816d7ddd7593ab7c96b5ecf23b497fb46a7ef5aeb
+SIZE (plzip-0.6.tar.gz) = 64535
diff --git a/archivers/plzip/pkg-descr b/archivers/plzip/pkg-descr
new file mode 100644
index 000000000000..4b6566ff2df5
--- /dev/null
+++ b/archivers/plzip/pkg-descr
@@ -0,0 +1,9 @@
+Plzip is a massively parallel (multi-threaded), lossless data
+compressor based on the LZMA algorithm, with very safe integrity
+checking and a user interface similar to the one of gzip or bzip2.
+Plzip uses the lzip file format; the files produced by plzip are
+fully compatible with lzip-1.4 or newer.
+
+WWW: http://www.nongnu.org/lzip/plzip.html
+
+Albert Vernon <f3cun3c02@sneakemail.com>