aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2014-03-10 02:48:21 +0000
committerMark Felder <feld@FreeBSD.org>2014-03-10 02:48:21 +0000
commit74b6bf2aefe447715c041d08a567e9d9328299f7 (patch)
treec6553ea9c4ba452a25539095dfe58cb2851ad79a
parent9ca5f96eb50bc9f9280c7c72608881edd7c8c463 (diff)
downloadports-74b6bf2aefe447715c041d08a567e9d9328299f7.tar.gz
ports-74b6bf2aefe447715c041d08a567e9d9328299f7.zip
Permit control of the flags passed to java through a new variable
called unifi_javaflags Users have requested an easy way to make this change. Ubiquiti recommends 1024M by default, but the actual memory requirement depends on the size of your environment. It is safe to run at much lower levels with only a few APs.
Notes
Notes: svn path=/head/; revision=347714
-rw-r--r--net-mgmt/unifi2/Makefile2
-rw-r--r--net-mgmt/unifi2/files/unifi.in3
-rw-r--r--net-mgmt/unifi3/Makefile2
-rw-r--r--net-mgmt/unifi3/files/unifi.in3
4 files changed, 6 insertions, 4 deletions
diff --git a/net-mgmt/unifi2/Makefile b/net-mgmt/unifi2/Makefile
index ecfbcad7e01b..18b51b6cc04e 100644
--- a/net-mgmt/unifi2/Makefile
+++ b/net-mgmt/unifi2/Makefile
@@ -3,7 +3,7 @@
PORTNAME= unifi2
PORTVERSION= 2.4.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-mgmt java
MASTER_SITES= http://dl.ubnt.com/unifi/${PORTVERSION}/
DISTNAME= UniFi.unix
diff --git a/net-mgmt/unifi2/files/unifi.in b/net-mgmt/unifi2/files/unifi.in
index f1dafecb738e..5e61de90008d 100644
--- a/net-mgmt/unifi2/files/unifi.in
+++ b/net-mgmt/unifi2/files/unifi.in
@@ -23,10 +23,11 @@ load_rc_config ${name}
: ${unifi_user:=%%USERS%%}
: ${unifi_group:=%%GROUPS%%}
: ${unifi_chdir=%%JAVASHAREDIR%%/unifi}
+: ${unifi_javaflags:="-Djava.awt.headless=true -Xmx1024M"}
command_interpreter=.
command="%%PREFIX%%/bin/java"
-command_args="-Djava.awt.headless=true -Xmx1024M -jar lib/ace.jar"
+command_args="${unifi_javaflags} -jar lib/ace.jar"
start_cmd=start_cmd
start_precmd=start_precmd
stop_cmd=stop_cmd
diff --git a/net-mgmt/unifi3/Makefile b/net-mgmt/unifi3/Makefile
index 4884a61db2b3..4714f87edd65 100644
--- a/net-mgmt/unifi3/Makefile
+++ b/net-mgmt/unifi3/Makefile
@@ -3,7 +3,7 @@
PORTNAME= unifi3
PORTVERSION= 3.1.10
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-mgmt java
MASTER_SITES= http://dl.ubnt.com/unifi/${PORTVERSION}/
DISTNAME= UniFi.unix
diff --git a/net-mgmt/unifi3/files/unifi.in b/net-mgmt/unifi3/files/unifi.in
index f1dafecb738e..5e61de90008d 100644
--- a/net-mgmt/unifi3/files/unifi.in
+++ b/net-mgmt/unifi3/files/unifi.in
@@ -23,10 +23,11 @@ load_rc_config ${name}
: ${unifi_user:=%%USERS%%}
: ${unifi_group:=%%GROUPS%%}
: ${unifi_chdir=%%JAVASHAREDIR%%/unifi}
+: ${unifi_javaflags:="-Djava.awt.headless=true -Xmx1024M"}
command_interpreter=.
command="%%PREFIX%%/bin/java"
-command_args="-Djava.awt.headless=true -Xmx1024M -jar lib/ace.jar"
+command_args="${unifi_javaflags} -jar lib/ace.jar"
start_cmd=start_cmd
start_precmd=start_precmd
stop_cmd=stop_cmd