aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-03-10 14:54:41 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-03-10 14:54:41 +0000
commit9ddcc1212bd360f4f2eb9118dea2db07dfa1eb6d (patch)
tree8ebac364a5814c005c93d6ffcc314775c4d2a5e5
parentd9142f168b3594d0f36739974a7b59e8270b59c3 (diff)
downloadports-9ddcc1212bd360f4f2eb9118dea2db07dfa1eb6d.tar.gz
ports-9ddcc1212bd360f4f2eb9118dea2db07dfa1eb6d.zip
Convert i* to USES=zip
Notes
Notes: svn path=/head/; revision=347763
-rw-r--r--irc/irssi-fish/Makefile2
-rw-r--r--irc/pircbot/Makefile2
-rw-r--r--irc/py-irc/Makefile2
-rw-r--r--irc/xchat-fish/Makefile3
-rw-r--r--irc/xchat-mircryption/Makefile3
5 files changed, 5 insertions, 7 deletions
diff --git a/irc/irssi-fish/Makefile b/irc/irssi-fish/Makefile
index e80194efe586..ea65689ba94c 100644
--- a/irc/irssi-fish/Makefile
+++ b/irc/irssi-fish/Makefile
@@ -16,7 +16,7 @@ BUILD_DEPENDS= ${LOCALBASE}/include/glib-2.0/glib.h:${PORTSDIR}/devel/glib20 \
${LOCALBASE}/include/irssi/src/common.h:${PORTSDIR}/irc/irssi
RUN_DEPENDS= irssi:${PORTSDIR}/irc/irssi
-USE_ZIP= yes
+USES= zip
USE_LDCONFIG= yes
PLIST_FILES= lib/irssi/modules/libfish.so
diff --git a/irc/pircbot/Makefile b/irc/pircbot/Makefile
index 01435df47014..f99147218f9a 100644
--- a/irc/pircbot/Makefile
+++ b/irc/pircbot/Makefile
@@ -12,7 +12,7 @@ MASTER_SITES= http://www.jibble.org/files/ \
MAINTAINER= tdb@FreeBSD.org
COMMENT= PircBot Java IRC Bot Framework
-USE_ZIP= yes
+USES= zip
NO_BUILD= yes
USE_JAVA= yes
diff --git a/irc/py-irc/Makefile b/irc/py-irc/Makefile
index b7e153db11d7..a6a19f67c49c 100644
--- a/irc/py-irc/Makefile
+++ b/irc/py-irc/Makefile
@@ -19,7 +19,7 @@ BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hgtools>0:${PORTSDIR}/devel/py-hgtools \
USE_PYTHON= yes
USE_PYDISTUTILS=easy_install
PYDISTUTILS_AUTOPLIST= yes
-USE_ZIP= yes
+USES= zip
PORTEXAMPLES= irccat.py irccat2.py servermap.py testbot.py \
dccreceive.py dccsend.py
diff --git a/irc/xchat-fish/Makefile b/irc/xchat-fish/Makefile
index bbc4e1b89896..fcc24acc4885 100644
--- a/irc/xchat-fish/Makefile
+++ b/irc/xchat-fish/Makefile
@@ -17,8 +17,7 @@ COMMENT= An encryption plugin for XChat
BUILD_DEPENDS= ${LOCALBASE}/lib/libmiracl.a:${PORTSDIR}/math/miracl
RUN_DEPENDS= xchat:${PORTSDIR}/irc/xchat
-USE_ZIP= yes
-USES= dos2unix
+USES= dos2unix zip
NO_WRKSUBDIR= yes
DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
CCFLAGS+= -Wall -O2 -I${LOCALBASE}/include
diff --git a/irc/xchat-mircryption/Makefile b/irc/xchat-mircryption/Makefile
index a7ad3e5145fa..d322245f86e9 100644
--- a/irc/xchat-mircryption/Makefile
+++ b/irc/xchat-mircryption/Makefile
@@ -16,8 +16,7 @@ COMMENT= A free encryption add-on for the popular XChat irc client
RUN_DEPENDS= xchat:${PORTSDIR}/irc/xchat
-USE_ZIP= yes
-USES= dos2unix
+USES= dos2unix zip
ALL_TARGET= freebsd
CFLAGS+= -fPIC
USE_LDCONFIG= yes