aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2016-05-02 12:40:09 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2016-05-02 12:40:09 +0000
commitaf372bced70fce050473e383f4768b456914639d (patch)
treeefba21b423c9177776f1c19f4df5e37e93c9cf65
parenta1c9737410b456554d74128cc87a6e50f6f370be (diff)
downloadports-af372bced70fce050473e383f4768b456914639d.tar.gz
ports-af372bced70fce050473e383f4768b456914639d.zip
Cotire compilation speedup fails with upcoming libc++ 3.8.0, so disable it.
Reported by: dim@
Notes
Notes: svn path=/head/; revision=414441
-rw-r--r--textproc/luceneplusplus/Makefile7
-rw-r--r--textproc/luceneplusplus/files/extra-patch-CMakeLists.txt11
-rw-r--r--textproc/luceneplusplus/files/patch-CMakeLists.txt14
3 files changed, 15 insertions, 17 deletions
diff --git a/textproc/luceneplusplus/Makefile b/textproc/luceneplusplus/Makefile
index 60ed4e27ac89..b8019083a12e 100644
--- a/textproc/luceneplusplus/Makefile
+++ b/textproc/luceneplusplus/Makefile
@@ -23,9 +23,10 @@ USE_LDCONFIG= yes
.include <bsd.port.pre.mk>
-.if ${COMPILER_TYPE} == gcc
-EXTRA_PATCHES= ${FILESDIR}/extra-patch-CMakeLists.txt
-.endif
+post-patch:
+ ${REINPLACE_CMD} "/cotire/d" ${WRKSRC}/src/contrib/CMakeLists.txt \
+ ${WRKSRC}/src/core/CMakeLists.txt \
+ ${WRKSRC}/src/test/CMakeLists.txt
post-install:
cd ${WRKSRC}/include &&${INSTALL_DATA} *.h \
diff --git a/textproc/luceneplusplus/files/extra-patch-CMakeLists.txt b/textproc/luceneplusplus/files/extra-patch-CMakeLists.txt
deleted file mode 100644
index c9d24dd44068..000000000000
--- a/textproc/luceneplusplus/files/extra-patch-CMakeLists.txt
+++ /dev/null
@@ -1,11 +0,0 @@
---- CMakeLists.txt.orig 2015-01-30 17:14:22.000000000 +0100
-+++ CMakeLists.txt 2015-05-26 18:05:53.000000000 +0200
-@@ -20,6 +20,8 @@
- ####################################
- include(cotire)
-
-+set_property(GLOBAL PROPERTY COTIRE_ENABLE_PRECOMPILED_HEADER FALSE)
-+
- # if setup using the Toolchain-llvm.cmake file, then use llvm...
- if(ENABLE_LLVM)
- include(Toolchain-llvm)
diff --git a/textproc/luceneplusplus/files/patch-CMakeLists.txt b/textproc/luceneplusplus/files/patch-CMakeLists.txt
index ff82cbb84f6e..fa051b25a0c9 100644
--- a/textproc/luceneplusplus/files/patch-CMakeLists.txt
+++ b/textproc/luceneplusplus/files/patch-CMakeLists.txt
@@ -1,6 +1,14 @@
---- CMakeLists.txt.orig 2015-02-25 13:04:40.000000000 +0100
-+++ CMakeLists.txt 2015-02-25 13:05:18.000000000 +0100
-@@ -168,7 +168,7 @@
+--- CMakeLists.txt.orig 2015-01-30 17:14:22.000000000 +0100
++++ CMakeLists.txt 2016-04-29 17:50:01.000000000 +0200
+@@ -18,7 +18,6 @@
+ ####################################
+ # pre-compiled headers support
+ ####################################
+-include(cotire)
+
+ # if setup using the Toolchain-llvm.cmake file, then use llvm...
+ if(ENABLE_LLVM)
+@@ -168,7 +167,7 @@
FILES
"${CMAKE_CURRENT_BINARY_DIR}/liblucene++.pc"
"${CMAKE_CURRENT_BINARY_DIR}/liblucene++-contrib.pc"