aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabor Kovesdan <gabor@FreeBSD.org>2007-04-19 21:20:48 +0000
committerGabor Kovesdan <gabor@FreeBSD.org>2007-04-19 21:20:48 +0000
commitc7611291caed7042dac74061e36e3fa5ba7ed166 (patch)
tree1d2de5d52eb1b8904d425116b2afd36170dab951
parentaf96ced369a5fd129e406f51d4135261e2b70bb3 (diff)
downloadports-c7611291caed7042dac74061e36e3fa5ba7ed166.tar.gz
ports-c7611291caed7042dac74061e36e3fa5ba7ed166.zip
- Remove FreeBSD 4.X support from unmaintained ports in categories starting
with letter n-p
Notes
Notes: svn path=/head/; revision=190385
-rw-r--r--net-mgmt/net-snmp4/Makefile4
-rw-r--r--net-mgmt/pads/Makefile8
-rw-r--r--net/gq/Makefile4
-rw-r--r--net/libnet-devel/Makefile12
-rw-r--r--net/libunp/Makefile8
-rw-r--r--net/mpich/Makefile2
-rw-r--r--net/nvnet/Makefile4
-rw-r--r--net/rdist6/Makefile7
-rw-r--r--net/tintin++-devel/Makefile11
-rw-r--r--net/vls/Makefile4
-rw-r--r--palm/makeztxt/Makefile10
-rw-r--r--palm/uppc-kmod/Makefile8
-rw-r--r--ports-mgmt/portsman/Makefile8
-rw-r--r--portuguese/staroffice52/Makefile13
-rw-r--r--print/lilypond/Makefile4
15 files changed, 13 insertions, 94 deletions
diff --git a/net-mgmt/net-snmp4/Makefile b/net-mgmt/net-snmp4/Makefile
index fe605bb872eb..9af21287416e 100644
--- a/net-mgmt/net-snmp4/Makefile
+++ b/net-mgmt/net-snmp4/Makefile
@@ -71,6 +71,8 @@ CFLAGS+= -DOPENSSL_DES_LIBDES_COMPATIBILITY
SHLIB_VERSION= 4
PLIST_SUB+= shlib=${SHLIB_VERSION}
+OPTIONS= IPV6 "Enable IPv6 support" On
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 700019
@@ -81,7 +83,7 @@ BROKEN= Does not compile on FreeBSD >= 7.0
CFLAGS+= -Dfreebsd5
.endif
-.if ${OSVERSION} >= 400014
+.if defined(WITH_IPV6)
CONFIGURE_ARGS+= --enable-ipv6
.endif
diff --git a/net-mgmt/pads/Makefile b/net-mgmt/pads/Makefile
index c9fb763d0abb..fee64deb05f4 100644
--- a/net-mgmt/pads/Makefile
+++ b/net-mgmt/pads/Makefile
@@ -20,10 +20,4 @@ GNU_CONFIGURE= yes
MAN8= pads.8 pads-report.8 pads.conf.8
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= Does not compile
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/gq/Makefile b/net/gq/Makefile
index 660cf818392c..696359bcb7ac 100644
--- a/net/gq/Makefile
+++ b/net/gq/Makefile
@@ -39,10 +39,6 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-BROKEN= does not compile
-.endif
-
.if !defined(WITHOUT_JPEG)
USE_GNOME+= gdkpixbuf
.endif
diff --git a/net/libnet-devel/Makefile b/net/libnet-devel/Makefile
index e7a4c24e60e2..76cac44ab6b8 100644
--- a/net/libnet-devel/Makefile
+++ b/net/libnet-devel/Makefile
@@ -32,16 +32,6 @@ EXAMPLES= sample/*.c
SHORT_VER= 113
-.include <bsd.port.pre.mk>
-
-post-patch:
-.if ${OSVERSION} < 500000
- ${REINPLACE_CMD} -e "s|stdint\.h|inttypes.h|g" \
- ${WRKSRC}/include/libnet/libnet-types.h
-.else
- ${DO_NADA}
-.endif
-
post-install:
${INSTALL_SCRIPT} ${WRKSRC}/libnet-config \
${PREFIX}/bin/libnet${SHORT_VER}-config
@@ -55,4 +45,4 @@ post-install:
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/libunp/Makefile b/net/libunp/Makefile
index 95428628884f..c72d88ef0ed2 100644
--- a/net/libunp/Makefile
+++ b/net/libunp/Makefile
@@ -18,12 +18,6 @@ COMMENT= The networking library used in UNIX Network Programming Volume 1 2e
GNU_CONFIGURE= yes
USE_GMAKE= yes
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "alpha" && ${OSVERSION} < 500000
-BROKEN= "Does not compile on alpha 4.x"
-.endif
-
pre-patch:
@ ${CP} ${WRKSRC}/lib/wrapsock.c ${WRKSRC}/lib/wrapsock_r.c
@@ -40,4 +34,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/lib/addrinfo.h ${PREFIX}/include/unp
${INSTALL_DATA} ${WRKSRC}/config.h ${PREFIX}/include/unp
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/mpich/Makefile b/net/mpich/Makefile
index 6d4ad43384ce..e4d81bfd558c 100644
--- a/net/mpich/Makefile
+++ b/net/mpich/Makefile
@@ -185,7 +185,7 @@ MAN4= CLOG_Init.4 CLOG_commtype.4 CLOG_cput.4 CLOG_csync.4 \
# Use ssh instead of rsh
.if !defined(WITHOUT_SSH)
-.if ${OSVERSION} >= 400016 && exists(/usr/bin/ssh)
+.if exists(/usr/bin/ssh)
CONFIGURE_ENV+= RSHCOMMAND="/usr/bin/ssh"
.elif defined(WITH_SSH) || exists(${LOCALBASE}/bin/ssh)
RUN_DEPENDS+= ${LOCALBASE}/bin/ssh:${PORTSDIR}/security/ssh
diff --git a/net/nvnet/Makefile b/net/nvnet/Makefile
index 8b8efb53b581..4295ee909524 100644
--- a/net/nvnet/Makefile
+++ b/net/nvnet/Makefile
@@ -26,10 +26,6 @@ MAKE_ENV= OSTYPE=${OPSYS}
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 480100 || ${OSVERSION} >= 500000 && ${OSVERSION} < 501000
-IGNORE= Systems prior to FreeBSD 4.9 & 5.1 are not supported
-.endif
-
.if ${OSVERSION} >= 600021
IGNORE= nve support already exists in base
.endif
diff --git a/net/rdist6/Makefile b/net/rdist6/Makefile
index a80f407134ae..1c3d6d57b4bc 100644
--- a/net/rdist6/Makefile
+++ b/net/rdist6/Makefile
@@ -15,11 +15,6 @@ MASTER_SITES= http://www.magnicomp.com/download/rdist/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= A network file distribution/synchronisation utility
-.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 400000
-BROKEN= Not supported for pre-4.0 FreeBSD
-.endif
-
# To avoid confusion with /usr/bin/rdist, you may prefer otherwise.
RDIST_NAME?= rdist6
@@ -33,4 +28,4 @@ post-install:
@${STRIP_CMD} ${PREFIX}/bin/${RDIST_NAME}
@${STRIP_CMD} ${PREFIX}/bin/rdistd
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/tintin++-devel/Makefile b/net/tintin++-devel/Makefile
index 919dc77c2b27..3f4fc91f2051 100644
--- a/net/tintin++-devel/Makefile
+++ b/net/tintin++-devel/Makefile
@@ -25,15 +25,6 @@ USE_GCC= 3.2+
PLIST_FILES= bin/tt++
PORTDOCS= BUGS CREDITS FAQ README TODO tintin19.txt chat_protocol.txt
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
-CFLAGS+= -I ${LOCALBASE}/include
-MAKE_ENV+= LIBS="-L${LOCALBASE}/lib"
-MAKE_ARGS+= LDFLAGS=${PTHREAD_LIBS}
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|' ${WRKSRC}/Makefile.in
@@ -46,4 +37,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/vls/Makefile b/net/vls/Makefile
index 7700c87fc79d..da575fcd3263 100644
--- a/net/vls/Makefile
+++ b/net/vls/Makefile
@@ -53,10 +53,6 @@ post-install:
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-BROKEN= Does not build
-.endif
-
.if ${OSVERSION} >= 502122
# allow nonconforming code to compile
CFLAGS+= -fpermissive
diff --git a/palm/makeztxt/Makefile b/palm/makeztxt/Makefile
index 838004148ecd..66bd888ead87 100644
--- a/palm/makeztxt/Makefile
+++ b/palm/makeztxt/Makefile
@@ -19,13 +19,7 @@ PLIST_FILES= bin/makeztxt
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_GMAKE= yes
-MAKE_ENV+= USEPOSIX=1
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500000
-MAKE_ENV+= LONG_OPTS=1
-.endif
+MAKE_ENV+= USEPOSIX=1 LONG_OPTS=1
post-patch:
${REINPLACE_CMD} 's/-O2//' ${WRKSRC}/libztxt/Makefile
@@ -33,4 +27,4 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/makeztxt ${LOCALBASE}/bin/
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/palm/uppc-kmod/Makefile b/palm/uppc-kmod/Makefile
index 86d796d0d6de..400d5d0ab41e 100644
--- a/palm/uppc-kmod/Makefile
+++ b/palm/uppc-kmod/Makefile
@@ -22,12 +22,6 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
IGNORE= Requires kernel source (/usr/src/sys) to build
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= "Does not build on FreeBSD 4.x"
-.endif
-
post-build:
@${REINPLACE_CMD} -e 's|%%INITIAL_INSTALLDIR%%|${PREFIX}/lib|g' ${BUILD_WRKSRC}/uppcsetup
@${REINPLACE_CMD} -e 's|%%INITIAL_MODDIR%%|${KMODDIR}|g' ${WRKSRC}/uppcsetup
@@ -46,4 +40,4 @@ post-install:
@${ECHO_CMD} " * and set up a connection. *"
@${ECHO_CMD} " ****************************************************************"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/ports-mgmt/portsman/Makefile b/ports-mgmt/portsman/Makefile
index 6cc4bff8a60e..c1c8dd284e64 100644
--- a/ports-mgmt/portsman/Makefile
+++ b/ports-mgmt/portsman/Makefile
@@ -16,12 +16,6 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-rc2
MAINTAINER= ports@FreeBSD.org
COMMENT= An ncurses based front-end to manage the FreeBSD ports collection
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 400000
-LIB_DEPENDS= ncurses.5:${PORTSDIR}/devel/ncurses
-.endif
-
MAN1= portsman.1
MAN5= portsmanrc.5
GNU_CONFIGURE= yes
@@ -30,4 +24,4 @@ post-patch:
@${REINPLACE_CMD} -e "/^pmanrcdir/s|etc$$|etc/portsman|" \
${WRKSRC}/config/Makefile.in
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/portuguese/staroffice52/Makefile b/portuguese/staroffice52/Makefile
index 3afbe8ac718c..095cd2e1ec49 100644
--- a/portuguese/staroffice52/Makefile
+++ b/portuguese/staroffice52/Makefile
@@ -68,19 +68,6 @@ pre-fetch:
@${ECHO} -----------------------------------------------------------
@${FALSE}
.endif
-.if ${OSVERSION} < 410000
- @${ECHO}
- @${ECHO} OS-VERSION ${OSVERSION}
- @${ECHO}
- @${ECHO} Staroffice depende de uma correção para
- @${ECHO} linguagem script em
- @${ECHO} /usr/src/sys/i386/linux/linux_sysvec.c
- @${ECHO} \(revisão 1.55.2.1 ou maior\)
- @${ECHO}
- @${ECHO} Por favor, atualize seu sistema para FreeBSD 4.1
- @${ECHO}
- @${FALSE}
-.endif
.if ${SIZE} < 250000
@${ECHO}
@${ECHO} Há pouco espaço livre em disco em seu diretório
diff --git a/print/lilypond/Makefile b/print/lilypond/Makefile
index 8acffc13fe2f..f0c3335842d7 100644
--- a/print/lilypond/Makefile
+++ b/print/lilypond/Makefile
@@ -59,10 +59,6 @@ CFLAGS+= ${CPPFLAGS}
.include <bsd.port.pre.mk>
ALL_TARGET= all
-.if ${OSVERSION} < 500000
-USE_GCC= 3.4
-.endif
-
SCRIPTS_ENV+= PORTVERSION=${PORTVERSION}
.if defined(NOPORTDOCS)