aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2011-03-18 19:42:35 +0000
committerSteve Wills <swills@FreeBSD.org>2011-03-18 19:42:35 +0000
commitcae009169cdf7015f5d7c0c2d8eb8e330464c613 (patch)
treebb250dd36470b367fec3e3fab70d2c3f9d2e7219
parentf748b9776a65db59909f6a26310413b76271a905 (diff)
downloadports-cae009169cdf7015f5d7c0c2d8eb8e330464c613.tar.gz
ports-cae009169cdf7015f5d7c0c2d8eb8e330464c613.zip
h5utils is a set of utilities for visualization and conversion of
scientific data in the free, portable HDF5 format. Besides providing a simple tool for batch visualization as PNG images, h5utils also includes programs to convert HDF5 datasets into the formats required by other free visualization software (e.g. plain text, Vis5d, and VTK). WWW: http://ab-initio.mit.edu/wiki/index.php/H5utils PR: ports/155482 Submitted by: Klaus Aehlig <aehlig at linta.de>
Notes
Notes: svn path=/head/; revision=271279
-rw-r--r--science/Makefile1
-rw-r--r--science/h5utils/Makefile28
-rw-r--r--science/h5utils/distinfo2
-rw-r--r--science/h5utils/pkg-descr9
-rw-r--r--science/h5utils/pkg-plist31
5 files changed, 71 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index 64bed06db558..10ab222bf259 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -63,6 +63,7 @@
SUBDIR += gsystem
SUBDIR += gtamsanalyzer
SUBDIR += gwyddion
+ SUBDIR += h5utils
SUBDIR += harminv
SUBDIR += hdf
SUBDIR += hdf-java
diff --git a/science/h5utils/Makefile b/science/h5utils/Makefile
new file mode 100644
index 000000000000..93d885c16c57
--- /dev/null
+++ b/science/h5utils/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: h5utils
+# Date created: Mar 11, 2011
+# Whom: Klaus Aehlig <aehlig@linta.de>
+# $FreeBSD$
+
+PORTNAME= h5utils
+PORTVERSION= 1.12.1
+CATEGORIES= science
+MASTER_SITES= http://ab-initio.mit.edu/${PORTNAME}/
+
+MAINTAINER= aehlig@linta.de
+COMMENT= A set of utilities for visualization and conversion of HDF5 format
+
+LICENSE= MIT GPLv2
+LICENSE_COMB= multi
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+MAN1= h5totxt.1 h5fromtxt.1 h5tovtk.1 h5topng.1 h5math.1
+
+GNU_CONFIGURE= YES
+CFLAGS += -L${LOCALBASE}/lib -I${LOCALBASE}/include ${PTHREAD_LIBS}
+
+BUILD_DEPENDS+= gawk:${PORTSDIR}/lang/gawk
+LIB_DEPENDS += hdf5:${PORTSDIR}/science/hdf5 \
+ png:${PORTSDIR}/graphics/png \
+ matheval.1:${PORTSDIR}/devel/libmatheval
+
+.include <bsd.port.mk>
diff --git a/science/h5utils/distinfo b/science/h5utils/distinfo
new file mode 100644
index 000000000000..d3ab6dc973ca
--- /dev/null
+++ b/science/h5utils/distinfo
@@ -0,0 +1,2 @@
+SHA256 (h5utils-1.12.1.tar.gz) = 7290290ca5d5d4451d757a70c86baaa70d23a28edb09c951b6b77c22b924a38d
+SIZE (h5utils-1.12.1.tar.gz) = 156785
diff --git a/science/h5utils/pkg-descr b/science/h5utils/pkg-descr
new file mode 100644
index 000000000000..cf777918e4f2
--- /dev/null
+++ b/science/h5utils/pkg-descr
@@ -0,0 +1,9 @@
+h5utils is a set of utilities for visualization and conversion of
+scientific data in the free, portable HDF5 format.
+
+Besides providing a simple tool for batch visualization as PNG images,
+h5utils also includes programs to convert HDF5 datasets into the formats
+required by other free visualization software (e.g. plain text, Vis5d,
+and VTK).
+
+WWW: http://ab-initio.mit.edu/wiki/index.php/H5utils
diff --git a/science/h5utils/pkg-plist b/science/h5utils/pkg-plist
new file mode 100644
index 000000000000..5b886d1226b6
--- /dev/null
+++ b/science/h5utils/pkg-plist
@@ -0,0 +1,31 @@
+bin/h5math
+bin/h5totxt
+bin/h5fromtxt
+bin/h5tovtk
+bin/h5topng
+%%DATADIR%%/colormaps/autumn
+%%DATADIR%%/colormaps/bluered
+%%DATADIR%%/colormaps/bone
+%%DATADIR%%/colormaps/colorcube
+%%DATADIR%%/colormaps/cool
+%%DATADIR%%/colormaps/copper
+%%DATADIR%%/colormaps/flag
+%%DATADIR%%/colormaps/gray
+%%DATADIR%%/colormaps/green
+%%DATADIR%%/colormaps/hot
+%%DATADIR%%/colormaps/hsv
+%%DATADIR%%/colormaps/jet
+%%DATADIR%%/colormaps/lines
+%%DATADIR%%/colormaps/pink
+%%DATADIR%%/colormaps/prism
+%%DATADIR%%/colormaps/spring
+%%DATADIR%%/colormaps/summer
+%%DATADIR%%/colormaps/vga
+%%DATADIR%%/colormaps/winter
+%%DATADIR%%/colormaps/yarg
+%%DATADIR%%/colormaps/yellow
+%%DATADIR%%/colormaps/dkbluered
+@dirrmtry bin
+@dirrm %%DATADIR%%/colormaps
+@dirrm %%DATADIR%%
+@dirrmtry share