aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Kozlov <ak@FreeBSD.org>2012-06-25 04:15:50 +0000
committerAlex Kozlov <ak@FreeBSD.org>2012-06-25 04:15:50 +0000
commit61ccb75449e934ce15c362e836abe764660824ab (patch)
tree58e4fc161366f0687e7bcdae86fd5ab3e027ca0c
parent092a8d14ba5861f91eb4a45e1d86172975728463 (diff)
downloadports-61ccb75449e934ce15c362e836abe764660824ab.tar.gz
ports-61ccb75449e934ce15c362e836abe764660824ab.zip
- Convert to optionsNG
- Pet portlint - Remove pkg-plist from security/dropbear Approved by: eadler (mentor)
Notes
Notes: svn path=/head/; revision=299928
-rw-r--r--devel/p5-SDL/Makefile36
-rw-r--r--emulators/cpmtools2/Makefile16
-rw-r--r--games/evilfinder/Makefile12
-rw-r--r--games/lordsawar/Makefile25
-rw-r--r--security/dropbear/Makefile18
-rw-r--r--security/dropbear/pkg-plist5
6 files changed, 56 insertions, 56 deletions
diff --git a/devel/p5-SDL/Makefile b/devel/p5-SDL/Makefile
index 9d69989ecc89..97fc3deaf99c 100644
--- a/devel/p5-SDL/Makefile
+++ b/devel/p5-SDL/Makefile
@@ -17,39 +17,43 @@ COMMENT= Perl Bindings for SDL
BUILD_DEPENDS= p5-YAML>=0.62:${PORTSDIR}/textproc/p5-YAML
LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
- jpeg.11:${PORTSDIR}/graphics/jpeg
+ jpeg:${PORTSDIR}/graphics/jpeg
USE_SDL= sdl
PERL_MODBUILD= yes
-OPTIONS= SDL_TTF "Enable TTF support" on \
- SDL_NET "Enable NET support" on \
- SDL_GFX "Enable GFX support" on \
- SDL_IMAGE "Enable IMAGE support" on \
- SDL_MIXER "Enable MIXER support" on
+OPTIONS_DEFINE= GFX IMAGE MIXER NET TTF
-.include <bsd.port.pre.mk>
+GFX_DESC= Enable GFX support
+IMAGE_DESC= Enable IMAGE support
+MIXER_DESC= Enable MIXER support
+NET_DESC= Enable NET support
+TTF_DESC= Enable TTF support
-.if !defined(WITHOUT_SDL_TTF)
-USE_SDL+= ttf
-.endif
+OPTIONS_DEFAULT= GFX IMAGE MIXER NET TTF
-.if !defined(WITHOUT_SDL_NET)
-USE_SDL+= net
-.endif
+.include <bsd.port.pre.mk>
-.if !defined(WITHOUT_SDL_GFX)
+.if ${PORT_OPTIONS:MGFX}
USE_SDL+= gfx
.endif
-.if !defined(WITHOUT_SDL_IMAGE)
+.if ${PORT_OPTIONS:MIMAGE}
USE_SDL+= image
.endif
-.if !defined(WITHOUT_SDL_MIXER)
+.if ${PORT_OPTIONS:MMIXER}
USE_SDL+= mixer
.endif
+.if ${PORT_OPTIONS:MNET}
+USE_SDL+= net
+.endif
+
+.if ${PORT_OPTIONS:MTTF}
+USE_SDL+= ttf
+.endif
+
USE_LDCONFIG= yes
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
diff --git a/emulators/cpmtools2/Makefile b/emulators/cpmtools2/Makefile
index c5501db20b87..9773f3f4ed46 100644
--- a/emulators/cpmtools2/Makefile
+++ b/emulators/cpmtools2/Makefile
@@ -13,10 +13,10 @@ MASTER_SITES= http://www.moria.de/~michael/cpmtools/
MAINTAINER= ak@FreeBSD.org
COMMENT= Tools to access CP/M disks and disk images
-LATEST_LINK= cpmtools2
-
LICENSE= GPLv3
+LATEST_LINK= cpmtools2
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--bindir=${PREFIX}/sbin \
--datarootdir=${DATADIR}
@@ -24,12 +24,14 @@ CONFIGURE_ARGS+=--bindir=${PREFIX}/sbin \
MAN1= cpmls.1 cpmcp.1 cpmrm.1 cpmchmod.1 cpmchattr.1 mkfs.cpm.1 fsck.cpm.1 fsed.cpm.1
MAN5= cpm.5
-OPTIONS= LIBDSK "With LIBDSK support" off
+OPTIONS_DEFINE= LIBDSK
+
+LIBDSK_DESC= Access to disks and disk images support
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_LIBDSK)
-LIB_DEPENDS+= dsk.5:${PORTSDIR}/emulators/libdsk
+.if ${PORT_OPTIONS:MLIBDISK}
+LIB_DEPENDS+= dsk:${PORTSDIR}/emulators/libdsk
CONFIGURE_ARGS+=--with-libdsk=${LOCALBASE}
.else
CONFIGURE_ARGS+=--with-libdsk=''
@@ -46,4 +48,4 @@ post-patch:
pre-install:
@${MKDIR} ${DATADIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/evilfinder/Makefile b/games/evilfinder/Makefile
index 096209bcf476..7cfe70a0940b 100644
--- a/games/evilfinder/Makefile
+++ b/games/evilfinder/Makefile
@@ -18,11 +18,15 @@ COMMENT= Numerologically determine the evilness of things
WRKSRC= ${WRKDIR}/${PORTNAME}
-OPTIONS= WRAPPER "Evilfinder local wrapper" on
+OPTIONS_DEFINE= WRAPPER
-.include <bsd.port.pre.mk>
+WRAPPER_DESC= Evilfinder local wrapper
-.if !defined(WITHOUT_WRAPPER)
+OPTIONS_DEFAULT= WRAPPER
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MWRAPPER}
RUN_DEPENDS+= lynx:${PORTSDIR}/www/lynx
PLIST_SUB+= WRAPPER=""
.else
@@ -55,4 +59,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/lordsawar/Makefile b/games/lordsawar/Makefile
index f16782627697..1882aac506ae 100644
--- a/games/lordsawar/Makefile
+++ b/games/lordsawar/Makefile
@@ -15,36 +15,25 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ak@FreeBSD.org
COMMENT= A Warlords II clone
-LIB_DEPENDS= glademm-2.4:${PORTSDIR}/devel/libglademm24 \
- gnet-2.0:${PORTSDIR}/net/gnet2 \
- uuid.1:${PORTSDIR}/misc/e2fsprogs-libuuid \
- tar.0:${PORTSDIR}/devel/libtar
+LICENSE= GPLv3
+
+LIB_DEPENDS= glademm-2:${PORTSDIR}/devel/libglademm24 \
+ gnet-2:${PORTSDIR}/net/gnet2 \
+ uuid:${PORTSDIR}/misc/e2fsprogs-libuuid \
+ tar:${PORTSDIR}/devel/libtar
BUILD_DEPENDS= bjam:${PORTSDIR}/devel/boost-jam \
${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
USE_GETTEXT= yes
-USE_GCC= 4.2+
USE_GMAKE= yes
USE_GNOME= intltool
-USE_SDL= sdl image
+USE_SDL= sdl image mixer
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
-LICENSE= GPLv3
-
-OPTIONS= SOUND "Enable sound" on
-
-.include <bsd.port.options.mk>
-
CONFIGURE_ARGS+=--disable-nls \
--with-boost-includedir=${LOCALBASE}/include/
-.if !defined(WITHOUT_SOUND)
-USE_SDL+= mixer
-.else
-CONFIGURE_ARGS+=--disable-sound
-.endif
-
CONFIGURE_ENV+= LIBS="${PTHREAD_LIBS}"
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/security/dropbear/Makefile b/security/dropbear/Makefile
index abc9aa0c4295..ce4f301b972c 100644
--- a/security/dropbear/Makefile
+++ b/security/dropbear/Makefile
@@ -17,13 +17,20 @@ GNU_CONFIGURE= YES
USE_BZIP2= YES
USE_GMAKE= YES
-OPTIONS= STATIC "Build statically" off
-
USE_RC_SUBR= ${PORTNAME}
-.include <bsd.port.pre.mk>
+PLIST_FILES= bin/dbclient \
+ bin/dropbearkey \
+ bin/dropbearconvert \
+ sbin/dropbear
+
+PLIST_DIRSTRY= etc/dropbear
+
+OPTIONS_DEFINE= STATIC
+
+.include <bsd.port.options.mk>
-.if defined(WITH_STATIC)
+.if ${PORT_OPTIONS:MSTATIC}
LDFLAGS+= -static
.endif
@@ -36,6 +43,5 @@ post-patch:
post-install:
@${MKDIR} ${PREFIX}/etc/dropbear
- @${ECHO_MSG} ""
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/dropbear/pkg-plist b/security/dropbear/pkg-plist
deleted file mode 100644
index 3e3a2088830c..000000000000
--- a/security/dropbear/pkg-plist
+++ /dev/null
@@ -1,5 +0,0 @@
-bin/dbclient
-bin/dropbearkey
-bin/dropbearconvert
-sbin/dropbear
-@dirrmtry etc/dropbear