aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2016-12-14 16:04:43 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2016-12-14 16:04:43 +0000
commit7d308fae0c97111ade6f17cdff0bfd136ba48fc3 (patch)
tree0c7d8f858022d8bc9cd8cfc24cf7b5a4cc620b5d
parent462423df9dfebed2a224af514e1309b2ab7ed54f (diff)
downloadports-7d308fae0c97111ade6f17cdff0bfd136ba48fc3.tar.gz
ports-7d308fae0c97111ade6f17cdff0bfd136ba48fc3.zip
FiSHLiM is a HexChat plugin for FiSH IRC encryption.
* Sending/receiving messages * Topic decryption * Using unecrypted keys / keys without a password from blow.ini * Pure protocol-level filtering (works with highlighting, nick coloring etc) * Partially encrypted messages (i.e. prefixed with nickname by a bouncer) * CBC mode WWW: http://fishlim.kodafritt.se/
Notes
Notes: svn path=/head/; revision=428568
-rw-r--r--irc/Makefile1
-rw-r--r--irc/hexchat-fish/Makefile37
-rw-r--r--irc/hexchat-fish/distinfo3
-rw-r--r--irc/hexchat-fish/pkg-descr10
4 files changed, 51 insertions, 0 deletions
diff --git a/irc/Makefile b/irc/Makefile
index 4ef47b4701e6..c7a7bedb51d9 100644
--- a/irc/Makefile
+++ b/irc/Makefile
@@ -29,6 +29,7 @@
SUBDIR += gruftistats
SUBDIR += gseen.mod
SUBDIR += hexchat
+ SUBDIR += hexchat-fish
SUBDIR += hybserv
SUBDIR += icbirc
SUBDIR += ii
diff --git a/irc/hexchat-fish/Makefile b/irc/hexchat-fish/Makefile
new file mode 100644
index 000000000000..f8e4ac9ad0f3
--- /dev/null
+++ b/irc/hexchat-fish/Makefile
@@ -0,0 +1,37 @@
+# $FreeBSD$
+
+PORTNAME= fishlim
+PORTVERSION= 0.0.19
+CATEGORIES= irc security
+MASTER_SITES= http://git.fishlim.kodafritt.se/fishlim/snapshot/
+PKGNAMEPREFIX= hexchat-
+DISTNAME= fishlim-f952f6f21f6b7786e10d06a5ca90749f6e9f1f40
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Encryption plugin for Hexchat
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= hexchat:irc/hexchat
+
+USES= tar:bz2 pkgconfig ssl
+USE_GNOME= glib20
+
+CFLAGS+= -I${LOCALBASE}/include/glib-2.0
+CFLAGS+= -I${OPENSSLINC}
+LDFLAGS+= -L${OPENSSLLIB} -lcrypto
+
+PLIST_FILES= lib/hexchat/plugins/fishlim.so
+
+post-patch:
+ # base eopnssl has no libcrypto.pc
+ ${REINPLACE_CMD} -e 's| libcrypto||' \
+ ${WRKSRC}/Makefile
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/lib/hexchat/plugins
+ ${INSTALL_PROGRAM} ${WRKSRC}/fishlim.so \
+ ${STAGEDIR}${PREFIX}/lib/hexchat/plugins/
+
+.include <bsd.port.mk>
diff --git a/irc/hexchat-fish/distinfo b/irc/hexchat-fish/distinfo
new file mode 100644
index 000000000000..eaa4b13c7c82
--- /dev/null
+++ b/irc/hexchat-fish/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1481727978
+SHA256 (fishlim-f952f6f21f6b7786e10d06a5ca90749f6e9f1f40.tar.bz2) = fc036d94f814028127dcf6a8ac20b6037719082f9035d77dd27a2166842f215e
+SIZE (fishlim-f952f6f21f6b7786e10d06a5ca90749f6e9f1f40.tar.bz2) = 20362
diff --git a/irc/hexchat-fish/pkg-descr b/irc/hexchat-fish/pkg-descr
new file mode 100644
index 000000000000..9b59e6060eb7
--- /dev/null
+++ b/irc/hexchat-fish/pkg-descr
@@ -0,0 +1,10 @@
+FiSHLiM is a HexChat plugin for FiSH IRC encryption.
+
+ * Sending/receiving messages
+ * Topic decryption
+ * Using unecrypted keys / keys without a password from blow.ini
+ * Pure protocol-level filtering (works with highlighting, nick coloring etc)
+ * Partially encrypted messages (i.e. prefixed with nickname by a bouncer)
+ * CBC mode
+
+WWW: http://fishlim.kodafritt.se/