aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2017-08-29 11:16:57 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2017-08-29 11:16:57 +0000
commit8db77b1a6bebc3cc610b71ec226ea8b7675a6483 (patch)
tree412c2e09398dd717bd913a8b3f3e2a0bcfb5cc96
parenta12a4ed11417ed102d71d264757514a98d8011e2 (diff)
downloadports-8db77b1a6bebc3cc610b71ec226ea8b7675a6483.tar.gz
ports-8db77b1a6bebc3cc610b71ec226ea8b7675a6483.zip
- Fix comment
- Fix shebangs - Add missing run-depends - Switch to options helpers
Notes
Notes: svn path=/head/; revision=448905
-rw-r--r--net-mgmt/pftabled/Makefile45
1 files changed, 21 insertions, 24 deletions
diff --git a/net-mgmt/pftabled/Makefile b/net-mgmt/pftabled/Makefile
index 840e8dbe82dd..31c162269ae4 100644
--- a/net-mgmt/pftabled/Makefile
+++ b/net-mgmt/pftabled/Makefile
@@ -3,42 +3,39 @@
PORTNAME= pftabled
PORTVERSION= 1.09
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-mgmt
MASTER_SITES= http://www.wolfermann.org/
MAINTAINER= ports@FreeBSD.org
-COMMENT= The pftabled is a tool to manage your pf tables remotely
+COMMENT= Tool to manage pf tables remotely
-USE_RC_SUBR= pftabled
-
-PLIST_FILES= bin/pftabled-client man/man1/pftabled.1.gz sbin/pftabled
+LICENSE= BSD2CLAUSE
-GNU_CONFIGURE= yes
USES= gmake shebangfix
-SHEBANG_FILES= pftabled-client.pl
+SHEBANG_FILES= pftabled-client.pl \
+ pftabled-client.py
+GNU_CONFIGURE= yes
-OPTIONS_DEFINE= PERLC PYTHONC
-OPTIONS_DEFAULT= PERLC PYTHONC
-PERLC_DESC= A Sample Perl Client
-PYTHONC_DESC= A Sample Python Client
+USE_RC_SUBR= pftabled
-.include <bsd.port.pre.mk>
+PLIST_FILES= bin/pftabled-client man/man1/pftabled.1.gz sbin/pftabled
-.if ${PORT_OPTIONS:MPERLC}
-PLIST_FILES+= bin/pftabled-client.pl
-.endif
+OPTIONS_DEFINE= PERLC PYTHONC
+OPTIONS_DEFAULT=PERLC PYTHONC
-.if ${PORT_OPTIONS:MPYTHONC}
-PLIST_FILES+= bin/pftabled-client.py
-.endif
+PERLC_DESC= Install sample Perl client
+PERLC_PLIST_FILES= bin/pftabled-client.pl
+PERLC_USES= perl5
+PERLC_USE= PERL5=run
+PYTHONC_DESC= Install sample Python client
+PYTHONC_PLIST_FILES= bin/pftabled-client.py
+PYTHONC_USES= python:run
-post-install:
-.if ${PORT_OPTIONS:MPERLC}
+post-install-PERLC-on:
${INSTALL_SCRIPT} ${WRKSRC}/pftabled-client.pl ${STAGEDIR}${PREFIX}/bin/
-.endif
-.if ${PORT_OPTIONS:MPYTHONC}
+
+post-install-PYTHONC-on:
${INSTALL_SCRIPT} ${WRKSRC}/pftabled-client.py ${STAGEDIR}${PREFIX}/bin/
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>