aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-01-27 13:05:07 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-01-27 13:05:07 +0000
commitc4993423867af638c34770f1fc1545f289a30326 (patch)
treec31dea8f91c98b7ac3c1362ee96a821411fe0dae
parentc92d6d4b9cc7289896264e718ccb0caf8654e855 (diff)
downloadports-c4993423867af638c34770f1fc1545f289a30326.tar.gz
ports-c4993423867af638c34770f1fc1545f289a30326.zip
Support stage
Use compiler.mk to determine which compiler is being used Remove license_file for well known license
Notes
Notes: svn path=/head/; revision=341396
-rw-r--r--devel/bam/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/devel/bam/Makefile b/devel/bam/Makefile
index b6dc65eb012d..150c523b3433 100644
--- a/devel/bam/Makefile
+++ b/devel/bam/Makefile
@@ -7,18 +7,19 @@ CATEGORIES= devel
MASTER_SITES= http://github.com/downloads/matricks/bam/
MAINTAINER= beyert@cs.ucr.edu
-COMMENT= A fast and flexible build system using Lua
+COMMENT= Fast and flexible build system using Lua
LICENSE= ZLIB
-LICENSE_FILE= ${WRKSRC}/license.txt
+USES= compiler
USE_BZIP2= yes
PLIST_FILES= bin/bam
-NO_STAGE= yes
+.include <bsd.port.pre.mk>
+
do-build:
-.if defined(CC) && ${CC:T:Mclang}
+.if ${COMPILER_TYPE} == clang
@${REINPLACE_CMD} -e 's|-ldl||g' ${WRKSRC}/make_unix_clang.sh
(cd ${WRKSRC} && ${SH} make_unix_clang.sh)
.else
@@ -27,6 +28,6 @@ do-build:
.endif
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/bam ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/bam ${STAGEDIR}${PREFIX}/bin
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>