aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2006-05-14 07:23:25 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2006-05-14 07:23:25 +0000
commitd97844c36315356ed5cb687fcec9dd7497eceeef (patch)
treed4e9035db59845a0e903d7b33a28a7ac3f335687
parent069ca947f93f5bc8ccd8de332ee3068bb9e2668b (diff)
downloadports-d97844c36315356ed5cb687fcec9dd7497eceeef.tar.gz
ports-d97844c36315356ed5cb687fcec9dd7497eceeef.zip
Add p5-POE-Filter-IRCD: A POE-based parser for the IRC protocol
PR: ports/96848 Submitted by: sat Approved by: krion (mentor)
Notes
Notes: svn path=/head/; revision=162292
-rw-r--r--irc/Makefile1
-rw-r--r--irc/p5-POE-Filter-IRCD/Makefile24
-rw-r--r--irc/p5-POE-Filter-IRCD/distinfo3
-rw-r--r--irc/p5-POE-Filter-IRCD/pkg-descr5
-rw-r--r--irc/p5-POE-Filter-IRCD/pkg-plist4
5 files changed, 37 insertions, 0 deletions
diff --git a/irc/Makefile b/irc/Makefile
index de1dddb5c795..abaecd1268ea 100644
--- a/irc/Makefile
+++ b/irc/Makefile
@@ -71,6 +71,7 @@
SUBDIR += p5-IRC
SUBDIR += p5-POE-Component-IRC
SUBDIR += p5-POE-Component-IRC-Object
+ SUBDIR += p5-POE-Filter-IRCD
SUBDIR += party
SUBDIR += pear-Net_SmartIRC
SUBDIR += pircbot
diff --git a/irc/p5-POE-Filter-IRCD/Makefile b/irc/p5-POE-Filter-IRCD/Makefile
new file mode 100644
index 000000000000..525ace80425f
--- /dev/null
+++ b/irc/p5-POE-Filter-IRCD/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-POE-Filter-IRCD
+# Date created: 6 May 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-Filter-IRCD
+PORTVERSION= 1.5
+CATEGORIES= irc devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= POE
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= A POE-based parser for the IRC protocol
+
+BUILD_DEPENDS= ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+MAN3= POE::Filter::IRCD.3
+
+.include <bsd.port.mk>
diff --git a/irc/p5-POE-Filter-IRCD/distinfo b/irc/p5-POE-Filter-IRCD/distinfo
new file mode 100644
index 000000000000..47c6f207dcb8
--- /dev/null
+++ b/irc/p5-POE-Filter-IRCD/distinfo
@@ -0,0 +1,3 @@
+MD5 (POE-Filter-IRCD-1.5.tar.gz) = 70081e2795d78001f86c90daf2cb851e
+SHA256 (POE-Filter-IRCD-1.5.tar.gz) = dbb368aeba794eb985068cf2edcc4724adb3c8332025fbfc21f0671030827749
+SIZE (POE-Filter-IRCD-1.5.tar.gz) = 3958
diff --git a/irc/p5-POE-Filter-IRCD/pkg-descr b/irc/p5-POE-Filter-IRCD/pkg-descr
new file mode 100644
index 000000000000..8682cac804f0
--- /dev/null
+++ b/irc/p5-POE-Filter-IRCD/pkg-descr
@@ -0,0 +1,5 @@
+POE::Filter::IRCD is a POE-based parser for the IRC protocol.
+It provides a convenient way of parsing and creating IRC
+protocol lines.
+
+WWW: http://search.cpan.org/dist/POE-Filter-IRCD/
diff --git a/irc/p5-POE-Filter-IRCD/pkg-plist b/irc/p5-POE-Filter-IRCD/pkg-plist
new file mode 100644
index 000000000000..99bd54f31c05
--- /dev/null
+++ b/irc/p5-POE-Filter-IRCD/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/POE/Filter/IRCD.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Filter/IRCD/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Filter/IRCD
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Filter