aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2015-03-15 14:55:44 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2015-03-15 14:55:44 +0000
commitddc1d1d9a0f790b654d15fada41e38127ec3fe69 (patch)
treed16da22d0ee2083cfb6aee11acec0dcdddf22c8c
parentd31212aa6f2cd9121b20c0aefb427bbeaf636e13 (diff)
downloadports-ddc1d1d9a0f790b654d15fada41e38127ec3fe69.tar.gz
ports-ddc1d1d9a0f790b654d15fada41e38127ec3fe69.zip
- Allow building with clang 3.6 [1]
- Use autoreconf - Strip shared library - Remove unused Makefile PR: 197867 [1] Submitted by: dim [1] Approved by: maintainer timeout (osa, 23 days) [1]
Notes
Notes: svn path=/head/; revision=381335
-rw-r--r--devel/libeio/Makefile9
-rw-r--r--devel/libeio/files/Makefile10
-rw-r--r--devel/libeio/files/patch-ecb.h13
3 files changed, 16 insertions, 16 deletions
diff --git a/devel/libeio/Makefile b/devel/libeio/Makefile
index 7ee58800331b..14950faf7dd0 100644
--- a/devel/libeio/Makefile
+++ b/devel/libeio/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libeio
PORTVERSION= 4.18.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MAINTAINER= osa@FreeBSD.org
@@ -13,13 +13,10 @@ USE_GITHUB= yes
GH_ACCOUNT= scunningham
GH_TAGNAME= ${GH_COMMIT}
GH_COMMIT= e1a62ab
-USE_AUTOTOOLS= libtoolize aclocal autoconf autoheader automake
-USES= alias libtool
+USES= alias autoreconf libtool
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-
-ACLOCAL_ARGS= -I ${LOCALBASE}/share/aclocal
-AUTOMAKE_ARGS= --add-missing
+INSTALL_TARGET= install-strip
PLIST_FILES= include/eio.h lib/libeio.a lib/libeio.so \
lib/libeio.so.1 lib/libeio.so.1.0.0
diff --git a/devel/libeio/files/Makefile b/devel/libeio/files/Makefile
deleted file mode 100644
index e109b8b5e096..000000000000
--- a/devel/libeio/files/Makefile
+++ /dev/null
@@ -1,10 +0,0 @@
-# $FreeBSD$
-
-LIB = libeio
-SRCS= eio.c
-INCS=
-
-LIBDIR= ${PREFIX}/lib
-INCLUDEDIR= ${PREFIX}/include
-
-.include <bsd.lib.mk>
diff --git a/devel/libeio/files/patch-ecb.h b/devel/libeio/files/patch-ecb.h
new file mode 100644
index 000000000000..2372dbf690d3
--- /dev/null
+++ b/devel/libeio/files/patch-ecb.h
@@ -0,0 +1,13 @@
+--- ecb.h.orig 2012-10-16 20:30:08 UTC
++++ ecb.h
+@@ -472,8 +472,8 @@ ecb_inline uint64_t ecb_rotr64 (uint64_t
+ #define ecb_unreachable() __builtin_unreachable ()
+ #else
+ /* this seems to work fine, but gcc always emits a warning for it :/ */
+- ecb_inline void ecb_unreachable (void) ecb_noreturn;
+- ecb_inline void ecb_unreachable (void) { }
++ ecb_inline ecb_noreturn void ecb_unreachable (void);
++ ecb_inline ecb_noreturn void ecb_unreachable (void) { }
+ #endif
+
+ /* try to tell the compiler that some condition is definitely true */