aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEitan Adler <eadler@FreeBSD.org>2012-01-09 04:01:17 +0000
committerEitan Adler <eadler@FreeBSD.org>2012-01-09 04:01:17 +0000
commite1925f71024fbbbc6356957304ac960ac4147bc9 (patch)
tree3777e9d6cc7f1da1d6f88da18b7f50e27a967c2a
parent6f72b01686444c8cf2067f9dce6d7b7087341907 (diff)
downloadports-e1925f71024fbbbc6356957304ac960ac4147bc9.tar.gz
ports-e1925f71024fbbbc6356957304ac960ac4147bc9.zip
- Remove outdated version checks
Reviewed by: nox
Notes
Notes: svn path=/head/; revision=288805
-rw-r--r--archivers/bsdar/Makefile4
-rw-r--r--cad/chipmunk/Makefile2
-rw-r--r--devel/ace/Makefile6
-rw-r--r--devel/ecos-tools/Makefile2
-rw-r--r--devel/linuxthreads/Makefile10
-rw-r--r--devel/pwlib/Makefile4
-rw-r--r--devel/py-ncurses/Makefile2
-rw-r--r--devel/titano/Makefile2
-rw-r--r--editors/lfhex/Makefile2
-rw-r--r--ftp/ncftpd/Makefile11
-rw-r--r--games/empire/Makefile2
-rw-r--r--graphics/enfle/Makefile6
-rw-r--r--graphics/enfle/pkg-plist80
-rw-r--r--graphics/plasma-kmod/Makefile2
-rw-r--r--graphics/raster3d/Makefile2
-rw-r--r--mail/mahogany/Makefile2
-rw-r--r--math/yacas/Makefile2
-rw-r--r--net-mgmt/bsd-airtools/Makefile7
-rw-r--r--net/gatekeeper/Makefile4
-rw-r--r--net/nepim/Makefile4
-rw-r--r--security/isakmpd/Makefile2
-rw-r--r--security/saferpay/Makefile2
-rw-r--r--security/srp/Makefile2
-rw-r--r--sysutils/k3b/Makefile2
-rw-r--r--textproc/opensched/Makefile2
-rw-r--r--textproc/xerces-c2/Makefile4
-rw-r--r--www/bookmarkbridge/Makefile8
-rw-r--r--www/openvrml/Makefile4
-rw-r--r--x11-toolkits/xscoop/Makefile2
29 files changed, 50 insertions, 134 deletions
diff --git a/archivers/bsdar/Makefile b/archivers/bsdar/Makefile
index 8a8540c7a86e..acbe8aa23e17 100644
--- a/archivers/bsdar/Makefile
+++ b/archivers/bsdar/Makefile
@@ -23,10 +23,6 @@ MAN1= ar.1 ranlib.1
DEPRECATED= part of the base system
EXPIRATION_DATE=2013-02-28
-.if ${OSVERSION} < 700055
-IGNORE= does not compile
-.endif
-
.if ${OSVERSION} >= 800022
IGNORE= bsdar is now part of the base system as /usr/bin/ar
.endif
diff --git a/cad/chipmunk/Makefile b/cad/chipmunk/Makefile
index 8f298e5c647f..c6c8715813db 100644
--- a/cad/chipmunk/Makefile
+++ b/cad/chipmunk/Makefile
@@ -30,7 +30,7 @@ USE_GMAKE= yes
.if ${ARCH} == "alpha"
BROKEN= Broken pkg-plist on alpha
-.elif ${ARCH} == "sparc64" && ${OSVERSION} >= 700042
+.elif ${ARCH} == "sparc64"
BROKEN= Fails to install
.endif
diff --git a/devel/ace/Makefile b/devel/ace/Makefile
index a7eb3bee2a41..bf0a7b87ee57 100644
--- a/devel/ace/Makefile
+++ b/devel/ace/Makefile
@@ -36,11 +36,9 @@ MAN1= ace-gperf.1
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700015
EXTRA_PATCHES+= ${FILESDIR}/extra-ace-OS_NS_netdb.inl
-.endif
-.if ${OSVERSION} >= 700110 && ${OSVERSION} < 800000
+.if ${OSVERSION} < 800000
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-ace-OS_NS_Thread.h
.endif
@@ -50,7 +48,7 @@ post-extract:
post-patch:
@${FIND} ${WRKSRC} -name "Makefile.in*" | ${XARGS} ${REINPLACE_CMD} -e \
's|@libdir@/pkgconfig|@prefix@/libdata/pkgconfig|g'
-.if (${OSVERSION} >= 700110 && ${OSVERSION} < 800000) || ${OSVERSION} >= 800024
+.if (${OSVERSION} < 800000) || ${OSVERSION} >= 800024
@${REINPLACE_CMD} -e 's|cpu_set_t|cpuset_t|g' ${WRKSRC}/ace/OS_NS_Thread.cpp \
${WRKSRC}/ace/OS_NS_Thread.h
.endif
diff --git a/devel/ecos-tools/Makefile b/devel/ecos-tools/Makefile
index 580596de6033..e73755ec6144 100644
--- a/devel/ecos-tools/Makefile
+++ b/devel/ecos-tools/Makefile
@@ -79,10 +79,8 @@ post-install:
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700042
.if ${ARCH} == "amd64" || ${ARCH} == "sparc64"
BROKEN= Does not compile with GCC 4.2
.endif
-.endif
.include <bsd.port.post.mk>
diff --git a/devel/linuxthreads/Makefile b/devel/linuxthreads/Makefile
index eecbff7bdcd9..6387bf4e0c89 100644
--- a/devel/linuxthreads/Makefile
+++ b/devel/linuxthreads/Makefile
@@ -31,13 +31,9 @@ BROKEN= does not build
# This port only works on i386 right now.
ONLY_FOR_ARCHS= i386
-.if ${OSVERSION} >= 700042
USING_GCC4= true
MAKE_ENV+= USING_GCC4=true
-.else
-USING_GCC3= true
-MAKE_ENV+= USING_GCC3=true
-.endif
+
.if defined(LINUXTHREADS_INSTALL_LIBLTHREAD_PIC_ARCHIVE)
MAKE_ENV+= INSTALL_LIBLTHREAD_PIC_ARCHIVE=yes
.endif
@@ -282,10 +278,6 @@ PLIST_SUB+= LTHREADSHMAJOR:="4"
PLIST_SUB+= LTHREADSHMAJOR:="2"
.endif
.endif
-.if ${OSVERSION} >= 700042
PLIST_SUB+= LIBSTDCPPMAJOR:="6"
-.else
-PLIST_SUB+= LIBSTDCPPMAJOR:="5"
-.endif
.include <bsd.port.post.mk>
diff --git a/devel/pwlib/Makefile b/devel/pwlib/Makefile
index 11c4bbe17334..158e44368be0 100644
--- a/devel/pwlib/Makefile
+++ b/devel/pwlib/Makefile
@@ -41,11 +41,7 @@ MAKE_ENV= STDCCFLAGS+="-I${LOCALBASE}"
CPPFLAGS+= -O1 -I${WRKSRC}/include -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-.if ${OSVERSION} >= 700042
CONFIGURE_ENV+= ATOMICITY_H="<ext/atomicity.h>"
-.else
-CONFIGURE_ENV+= ATOMICITY_H="<bits/atomicity.h>"
-.endif
# if explicitely asked for, depend upon it
.if defined(WITH_SDL)
diff --git a/devel/py-ncurses/Makefile b/devel/py-ncurses/Makefile
index 853949f2ccb9..f7901b4eb0b1 100644
--- a/devel/py-ncurses/Makefile
+++ b/devel/py-ncurses/Makefile
@@ -27,9 +27,7 @@ post-patch:
@${REINPLACE_CMD} -e '45s,^.*$$,#include "py_curses.h",' \
${WRKSRC}/ncurses/${f}
.endfor
-.if ${OSVERSION} > 700033
@${REINPLACE_CMD} -e '/^extern int define_key(/d' \
${WRKSRC}/ncurses/_curses_wrap.c
-.endif
.include <bsd.port.post.mk>
diff --git a/devel/titano/Makefile b/devel/titano/Makefile
index 47a7c05b1a0b..376c405b8f79 100644
--- a/devel/titano/Makefile
+++ b/devel/titano/Makefile
@@ -24,11 +24,9 @@ GNU_CONFIGURE= yes
EXTRA_PATCHES+= ${FILESDIR}/gcc3-*
-.if ${OSVERSION} >= 700042
.if ${ARCH} == "amd64" || ${ARCH} == "sparc64"
BROKEN= Does not compile with GCC 4.2
.endif
-.endif
pre-patch: .SILENT
${REINPLACE_CMD} -e 's|malloc\.h|stdlib\.h|' \
diff --git a/editors/lfhex/Makefile b/editors/lfhex/Makefile
index 25dff93ef7a4..62968f8cd07f 100644
--- a/editors/lfhex/Makefile
+++ b/editors/lfhex/Makefile
@@ -31,9 +31,7 @@ LICENSE_FILES= ${WRKSRC}/../COPYING
post-patch:
@${REINPLACE_CMD} -e 's|^DEFINES|# DEFINES|g' ${WRKSRC}/lfhex.pro
-.if ${OSVERSION} >= 700042
@${REINPLACE_CMD} -e 's| abs| llabs|g' ${WRKSRC}/reader.cpp
-.endif
do-configure:
@cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${QMAKE} ${QMAKEFLAGS}
diff --git a/ftp/ncftpd/Makefile b/ftp/ncftpd/Makefile
index 9063be361317..3c147bd6dcbe 100644
--- a/ftp/ncftpd/Makefile
+++ b/ftp/ncftpd/Makefile
@@ -29,19 +29,16 @@ PORTDOCS= install.html README README.freebsd LICENSE
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 800000
+.if ${OSVERSION} >= 900000
+BINVER= 9.0
+.elif ${OSVERSION} >= 800000
BINVER= 8.0
-.elif ${OSVERSION} >= 700000
-BINVER= 7.0
.else
-BINVER= 6.0
+BINVER= 7.0
.endif
.if ${ARCH} == amd64
DIST_ARCH= x86_64
-.if ${BINVER} == "6.0"
-BINVER= 6.2
-.endif
.else
DIST_ARCH= i386
.endif
diff --git a/games/empire/Makefile b/games/empire/Makefile
index 641b06c76dd9..b9e4e1984515 100644
--- a/games/empire/Makefile
+++ b/games/empire/Makefile
@@ -24,9 +24,7 @@ USE_GMAKE= yes
.include <bsd.port.pre.mk>
post-patch:
-.if ${OSVERSION} >= 700042
@${REINPLACE_CMD} -e 's/static void/void/g' ${WRKSRC}/game.c
-.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/vms-empire ${PREFIX}/bin/empire
diff --git a/graphics/enfle/Makefile b/graphics/enfle/Makefile
index 38181ce8be9f..c5383989bb9b 100644
--- a/graphics/enfle/Makefile
+++ b/graphics/enfle/Makefile
@@ -58,12 +58,6 @@ CONFIGURE_ARGS+= --disable-mmx --disable-sse
BROKEN= Does not compile on ia64, powerpc, or sparc64
.endif
-.if ${OSVERSION} < 700000
-PLIST_SUB+= DISABLED="@comment "
-.else
-PLIST_SUB+= DISABLED=""
-.endif
-
.if defined(WITH_AVCODEC)
LIB_DEPENDS+= avcodec:${PORTSDIR}/multimedia/ffmpeg
PLIST_SUB+= AVCODEC=""
diff --git a/graphics/enfle/pkg-plist b/graphics/enfle/pkg-plist
index 729d3b1f5547..604b108eb546 100644
--- a/graphics/enfle/pkg-plist
+++ b/graphics/enfle/pkg-plist
@@ -5,9 +5,9 @@ lib/enfle/plugins/archiver/archiver_arc.so
lib/enfle/plugins/archiver/archiver_rar.a
lib/enfle/plugins/archiver/archiver_rar.la
lib/enfle/plugins/archiver/archiver_rar.so
-%%DISABLED%%lib/enfle/plugins/archiver/archiver_tar.a
-%%DISABLED%%lib/enfle/plugins/archiver/archiver_tar.la
-%%DISABLED%%lib/enfle/plugins/archiver/archiver_tar.so
+lib/enfle/plugins/archiver/archiver_tar.a
+lib/enfle/plugins/archiver/archiver_tar.la
+lib/enfle/plugins/archiver/archiver_tar.so
lib/enfle/plugins/audio/audio_esd.a
lib/enfle/plugins/audio/audio_esd.la
lib/enfle/plugins/audio/audio_esd.so
@@ -17,33 +17,33 @@ lib/enfle/plugins/audio/audio_oss.so
%%AVCODEC%%lib/enfle/plugins/audiodecoder/audiodecoder_avcodec.a
%%AVCODEC%%lib/enfle/plugins/audiodecoder/audiodecoder_avcodec.la
%%AVCODEC%%lib/enfle/plugins/audiodecoder/audiodecoder_avcodec.so
-%%DISABLED%%lib/enfle/plugins/audiodecoder/audiodecoder_mad.a
-%%DISABLED%%lib/enfle/plugins/audiodecoder/audiodecoder_mad.la
-%%DISABLED%%lib/enfle/plugins/audiodecoder/audiodecoder_mad.so
-%%DISABLED%%lib/enfle/plugins/audiodecoder/audiodecoder_mpglib.a
-%%DISABLED%%lib/enfle/plugins/audiodecoder/audiodecoder_mpglib.la
-%%DISABLED%%lib/enfle/plugins/audiodecoder/audiodecoder_mpglib.so
-%%DISABLED%%lib/enfle/plugins/audiodecoder/audiodecoder_vorbis.a
-%%DISABLED%%lib/enfle/plugins/audiodecoder/audiodecoder_vorbis.la
-%%DISABLED%%lib/enfle/plugins/audiodecoder/audiodecoder_vorbis.so
-%%DISABLED%%lib/enfle/plugins/demultiplexer/demultiplexer_avi.a
-%%DISABLED%%lib/enfle/plugins/demultiplexer/demultiplexer_avi.la
-%%DISABLED%%lib/enfle/plugins/demultiplexer/demultiplexer_avi.so
-%%DISABLED%%lib/enfle/plugins/demultiplexer/demultiplexer_mp3.a
-%%DISABLED%%lib/enfle/plugins/demultiplexer/demultiplexer_mp3.la
-%%DISABLED%%lib/enfle/plugins/demultiplexer/demultiplexer_mp3.so
-%%DISABLED%%lib/enfle/plugins/demultiplexer/demultiplexer_mpeg.a
-%%DISABLED%%lib/enfle/plugins/demultiplexer/demultiplexer_mpeg.la
-%%DISABLED%%lib/enfle/plugins/demultiplexer/demultiplexer_mpeg.so
-%%DISABLED%%lib/enfle/plugins/demultiplexer/demultiplexer_ogg.a
-%%DISABLED%%lib/enfle/plugins/demultiplexer/demultiplexer_ogg.la
-%%DISABLED%%lib/enfle/plugins/demultiplexer/demultiplexer_ogg.so
-%%DISABLED%%lib/enfle/plugins/effect/effect_gamma.a
-%%DISABLED%%lib/enfle/plugins/effect/effect_gamma.la
-%%DISABLED%%lib/enfle/plugins/effect/effect_gamma.so
-%%DISABLED%%lib/enfle/plugins/effect/effect_rotate.a
-%%DISABLED%%lib/enfle/plugins/effect/effect_rotate.la
-%%DISABLED%%lib/enfle/plugins/effect/effect_rotate.so
+lib/enfle/plugins/audiodecoder/audiodecoder_mad.a
+lib/enfle/plugins/audiodecoder/audiodecoder_mad.la
+lib/enfle/plugins/audiodecoder/audiodecoder_mad.so
+lib/enfle/plugins/audiodecoder/audiodecoder_mpglib.a
+lib/enfle/plugins/audiodecoder/audiodecoder_mpglib.la
+lib/enfle/plugins/audiodecoder/audiodecoder_mpglib.so
+lib/enfle/plugins/audiodecoder/audiodecoder_vorbis.a
+lib/enfle/plugins/audiodecoder/audiodecoder_vorbis.la
+lib/enfle/plugins/audiodecoder/audiodecoder_vorbis.so
+lib/enfle/plugins/demultiplexer/demultiplexer_avi.a
+lib/enfle/plugins/demultiplexer/demultiplexer_avi.la
+lib/enfle/plugins/demultiplexer/demultiplexer_avi.so
+lib/enfle/plugins/demultiplexer/demultiplexer_mp3.a
+lib/enfle/plugins/demultiplexer/demultiplexer_mp3.la
+lib/enfle/plugins/demultiplexer/demultiplexer_mp3.so
+lib/enfle/plugins/demultiplexer/demultiplexer_mpeg.a
+lib/enfle/plugins/demultiplexer/demultiplexer_mpeg.la
+lib/enfle/plugins/demultiplexer/demultiplexer_mpeg.so
+lib/enfle/plugins/demultiplexer/demultiplexer_ogg.a
+lib/enfle/plugins/demultiplexer/demultiplexer_ogg.la
+lib/enfle/plugins/demultiplexer/demultiplexer_ogg.so
+lib/enfle/plugins/effect/effect_gamma.a
+lib/enfle/plugins/effect/effect_gamma.la
+lib/enfle/plugins/effect/effect_gamma.so
+lib/enfle/plugins/effect/effect_rotate.a
+lib/enfle/plugins/effect/effect_rotate.la
+lib/enfle/plugins/effect/effect_rotate.so
lib/enfle/plugins/loader/loader_bmp.a
lib/enfle/plugins/loader/loader_bmp.la
lib/enfle/plugins/loader/loader_bmp.so
@@ -122,24 +122,24 @@ lib/enfle/plugins/video/video_Xlib.so
%%AVCODEC%%lib/enfle/plugins/videodecoder/videodecoder_avcodec.a
%%AVCODEC%%lib/enfle/plugins/videodecoder/videodecoder_avcodec.la
%%AVCODEC%%lib/enfle/plugins/videodecoder/videodecoder_avcodec.so
-%%DISABLED%%lib/enfle/plugins/videodecoder/videodecoder_libmpeg2.a
-%%DISABLED%%lib/enfle/plugins/videodecoder/videodecoder_libmpeg2.la
-%%DISABLED%%lib/enfle/plugins/videodecoder/videodecoder_libmpeg2.so
-%%DISABLED%%lib/enfle/plugins/videodecoder/videodecoder_raw.a
-%%DISABLED%%lib/enfle/plugins/videodecoder/videodecoder_raw.la
-%%DISABLED%%lib/enfle/plugins/videodecoder/videodecoder_raw.so
+lib/enfle/plugins/videodecoder/videodecoder_libmpeg2.a
+lib/enfle/plugins/videodecoder/videodecoder_libmpeg2.la
+lib/enfle/plugins/videodecoder/videodecoder_libmpeg2.so
+lib/enfle/plugins/videodecoder/videodecoder_raw.a
+lib/enfle/plugins/videodecoder/videodecoder_raw.la
+lib/enfle/plugins/videodecoder/videodecoder_raw.so
%%DATADIR%%/enfle.rc
@dirrm %%DATADIR%%
-%%DISABLED%%@dirrm lib/enfle/plugins/videodecoder
+@dirrm lib/enfle/plugins/videodecoder
@dirrm lib/enfle/plugins/video
@dirrm lib/enfle/plugins/ui
@dirrm lib/enfle/plugins/streamer
@dirrm lib/enfle/plugins/saver
@dirrm lib/enfle/plugins/player
@dirrm lib/enfle/plugins/loader
-%%DISABLED%%@dirrm lib/enfle/plugins/effect
-%%DISABLED%%@dirrm lib/enfle/plugins/demultiplexer
-%%DISABLED%%@dirrm lib/enfle/plugins/audiodecoder
+@dirrm lib/enfle/plugins/effect
+@dirrm lib/enfle/plugins/demultiplexer
+@dirrm lib/enfle/plugins/audiodecoder
@dirrm lib/enfle/plugins/audio
@dirrm lib/enfle/plugins/archiver
@dirrm lib/enfle/plugins
diff --git a/graphics/plasma-kmod/Makefile b/graphics/plasma-kmod/Makefile
index b6f1c3eb40ac..bed813e840a6 100644
--- a/graphics/plasma-kmod/Makefile
+++ b/graphics/plasma-kmod/Makefile
@@ -29,11 +29,9 @@ post-install:
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700042
.if ${ARCH} == "amd64"
BROKEN= Does not configure
.endif
-.endif
.if ${OSVERSION} >= 800000
BROKEN= Does not build
.endif
diff --git a/graphics/raster3d/Makefile b/graphics/raster3d/Makefile
index 038f5f4fa0ed..292ee4e82d0c 100644
--- a/graphics/raster3d/Makefile
+++ b/graphics/raster3d/Makefile
@@ -36,11 +36,9 @@ FFLAGS+= -fno-range-check -ffixed-line-length-132
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700042
.if ${ARCH} == "sparc64"
BROKEN= Does not compile with GCC 4.2: internal compiler error
.endif
-.endif
.if defined(WITHOUT_IMAGEMAGICK)
PLIST_SUB+= IMAGEMAGICK="@comment "
diff --git a/mail/mahogany/Makefile b/mail/mahogany/Makefile
index 5b2bbfa68e6a..5b6dc34bc4a5 100644
--- a/mail/mahogany/Makefile
+++ b/mail/mahogany/Makefile
@@ -29,11 +29,9 @@ MAN1= M.1 mahogany.1
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700042
.if ${ARCH} == "amd64" || ${ARCH} == "sparc64"
BROKEN= Does not compile with GCC 4.2
.endif
-.endif
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
diff --git a/math/yacas/Makefile b/math/yacas/Makefile
index 1ca06b89d77e..2cf66b979553 100644
--- a/math/yacas/Makefile
+++ b/math/yacas/Makefile
@@ -30,11 +30,9 @@ CONFIGURE_ARGS+= --enable-html-doc --with-html-dir=${DOCSDIR}
CONFIGURE_ARGS+= --disable-html-doc
.endif
-.if ${OSVERSION} >= 700042
.if ${ARCH} == "amd64" || ${ARCH} == "sparc64"
BROKEN= Does not compile with GCC 4.2
.endif
-.endif
test: build
@cd ${WRKSRC} && ${GMAKE} test
diff --git a/net-mgmt/bsd-airtools/Makefile b/net-mgmt/bsd-airtools/Makefile
index 59c6570a496d..2eee1d8ea796 100644
--- a/net-mgmt/bsd-airtools/Makefile
+++ b/net-mgmt/bsd-airtools/Makefile
@@ -38,10 +38,5 @@ do-install:
${DOCSDIR}/README.`${BASENAME} ${TOOL}`
.endfor
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 700052
IGNORE= broken by removal of wicontrol ioctls from if_wavelan_ieee.h
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/gatekeeper/Makefile b/net/gatekeeper/Makefile
index 76bb8284dda7..f0d2a26c62ad 100644
--- a/net/gatekeeper/Makefile
+++ b/net/gatekeeper/Makefile
@@ -41,10 +41,6 @@ EXAMPLESDIR= ${PREFIX}/share/examples/openh323
.include <bsd.port.pre.mk>
-.if ${ARCH} == sparc64 && ${OSVERSION} <= 700003
-BROKEN= does not link due to missing symbol in default thread library
-.endif
-
.if defined(WITH_FDSET)
CONFIGURE_ARGS+= --with-large-fdset=${WITH_FDSET}
.endif
diff --git a/net/nepim/Makefile b/net/nepim/Makefile
index ae951936587a..2c422bbc6c82 100644
--- a/net/nepim/Makefile
+++ b/net/nepim/Makefile
@@ -30,11 +30,7 @@ do-install:
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 700048
-CFLAGS+= -DHAVE_IP_MREQ -DHAVE_IPV6_MREQ
-.else
CFLAGS+= -DHAVE_IP_MREQ -DHAVE_IPV6_MREQ -DHAVE_IP_MREQN \
-DHAVE_GROUP_SOURCE_REQ
-.endif
.include <bsd.port.post.mk>
diff --git a/security/isakmpd/Makefile b/security/isakmpd/Makefile
index 84c18cbf38e6..740e8ac25d65 100644
--- a/security/isakmpd/Makefile
+++ b/security/isakmpd/Makefile
@@ -45,9 +45,7 @@ post-patch:
.for f in conf.h ike_auth.c isakmpd.8 isakmpd.conf.5 isakmpd.policy.5 policy.h
${REINPLACE_CMD} -e "s!/etc/!${PREFIX}/etc/!" ${WRKSRC}/${f}
.endfor
-.if ${OSVERSION} > 700050
@${REINPLACE_CMD} -e "s!netinet6/ipsec.h!netipsec/ipsec.h!" \
${WRKSRC}/sysdep/freebsd/sysdep-os.h
-.endif
.include <bsd.port.post.mk>
diff --git a/security/saferpay/Makefile b/security/saferpay/Makefile
index 28e88179154c..a58763a79dc7 100644
--- a/security/saferpay/Makefile
+++ b/security/saferpay/Makefile
@@ -48,10 +48,8 @@ post-install:
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700042
.if ${ARCH} == "sparc64"
BROKEN= Does not compile with GCC 4.2
.endif
-.endif
.include <bsd.port.post.mk>
diff --git a/security/srp/Makefile b/security/srp/Makefile
index 32761a6bb9f7..b16eb1ebc169 100644
--- a/security/srp/Makefile
+++ b/security/srp/Makefile
@@ -30,9 +30,7 @@ BROKEN= fails to build with new utmpx
post-patch:
@${GREP} -slR "malloc\.h" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
's|malloc\.h|stdlib\.h|g'
-.if ${OSVERSION} >= 700042
@${REINPLACE_CMD} -e 's/^struct.*\*sgetspent.*(const.*//' ${WRKSRC}/base/lib/shadow_.h
-.endif
post-install:
.if !defined(NOPORTDOCS)
diff --git a/sysutils/k3b/Makefile b/sysutils/k3b/Makefile
index 067c29df43c4..bba0c7312acc 100644
--- a/sysutils/k3b/Makefile
+++ b/sysutils/k3b/Makefile
@@ -59,9 +59,7 @@ showinfo:
BROKEN= does not compile on FreeBSD 9.X
.endif
-.if ${OSVERSION} > 700000
PKGMESSAGE= ${PKGDIR}/pkg-message-7
-.endif
.if defined(WITH_FLAC)
PLIST_SUB+= FLAC=""
diff --git a/textproc/opensched/Makefile b/textproc/opensched/Makefile
index 77e45a08c2db..37d594153bf7 100644
--- a/textproc/opensched/Makefile
+++ b/textproc/opensched/Makefile
@@ -23,11 +23,9 @@ PLIST_FILES= bin/opensched
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700042
.if ${ARCH} == "i386"
BROKEN= Does not install
.endif
-.endif
.if ${ARCH} == "alpha"
BROKEN= Does not compile
diff --git a/textproc/xerces-c2/Makefile b/textproc/xerces-c2/Makefile
index f0fe6729d4cb..5666639415ca 100644
--- a/textproc/xerces-c2/Makefile
+++ b/textproc/xerces-c2/Makefile
@@ -142,10 +142,6 @@ post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' \
${WRKSRC}/src/xercesc/Makefile.incl \
${WRKSRC}/src/xercesc/runConfigure
-.if ${OSVERSION} < 700000
- @${REINPLACE_CMD} -e 's,-lgcc,-lgcc_pic,' \
- ${WRKSRC}/src/xercesc/Makefile.incl
-.endif
pre-configure:
@${CHMOD} 700 ${CONFIGURE_WRKSRC}/runConfigure
diff --git a/www/bookmarkbridge/Makefile b/www/bookmarkbridge/Makefile
index e8bd8a882d53..601ce69b633e 100644
--- a/www/bookmarkbridge/Makefile
+++ b/www/bookmarkbridge/Makefile
@@ -25,10 +25,4 @@ USE_GMAKE= yes
USE_AUTOTOOLS= aclocal automake autoconf
ACLOCAL_ARGS= -I ${LOCALBASE}/share/aclocal
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 700042
-QTCFGLIBS+= ${PTHREAD_LIBS}
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/openvrml/Makefile b/www/openvrml/Makefile
index 7e9769d3c2d5..e77094a358c6 100644
--- a/www/openvrml/Makefile
+++ b/www/openvrml/Makefile
@@ -49,10 +49,6 @@ PORTDOCS= *
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/www/firefox/Makefile.webplugins"
-.if ${OSVERSION} < 700042
-BROKEN= Does not compile
-.endif
-
.if ${ARCH} == "sparc64"
BROKEN= Gets internal gcc error on ${ARCH}
.endif
diff --git a/x11-toolkits/xscoop/Makefile b/x11-toolkits/xscoop/Makefile
index f5e91241aa99..b4304ad9c4e5 100644
--- a/x11-toolkits/xscoop/Makefile
+++ b/x11-toolkits/xscoop/Makefile
@@ -23,9 +23,7 @@ ONLY_FOR_ARCHS= i386
.include <bsd.port.pre.mk>
-.if ${OSVERSION} > 700042
LIB_DEPENDS+= c.6:${PORTSDIR}/misc/compat6x
-.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/xscoop6 ${PREFIX}/bin/xscoop