aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-07-07 19:03:09 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-07-07 19:03:09 +0000
commitfa5570affeaa5cd9b7392246f1b81358f602cc92 (patch)
treee07d85357795a153fec60c4f175738784fabde45
parent975e6d3af400ae3a4da9df9299882bb137cd536d (diff)
downloadports-fa5570affeaa5cd9b7392246f1b81358f602cc92.tar.gz
ports-fa5570affeaa5cd9b7392246f1b81358f602cc92.zip
- Add staging support
- Remove leading article from COMMENT - Convert to new options framework
Notes
Notes: svn path=/head/; revision=361118
-rw-r--r--security/ssh-gui/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/security/ssh-gui/Makefile b/security/ssh-gui/Makefile
index d23613685789..a0027ebc59e6 100644
--- a/security/ssh-gui/Makefile
+++ b/security/ssh-gui/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= security
MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
-COMMENT= A front-end for ssh which can open multiple xterms
+COMMENT= Front-end for ssh which can open multiple xterms
USE_GNOME= gtk12
@@ -17,7 +17,8 @@ ALL_TARGET= ssh-gui
PLIST_FILES= bin/ssh-gui
PORTDOCS= README
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.pre.mk>
.if !exists(/usr/bin/ssh) && !exists(${LOCALBASE}/bin/ssh)
@@ -30,12 +31,8 @@ post-patch:
${BUILD_WRKSRC}/Makefile
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
-
-post-install:
-.ifndef(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
-.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.post.mk>