aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-11-14 15:07:24 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-11-14 15:07:24 +0000
commit334b5c7f5f746dc1ad76bb6c3bf3d5588e8684ce (patch)
tree5b1e0edeaf54f7189c0207384f382ba260855e8e
parentf1cdb5444c6bdd54f5092015f04e73e6ebe216e1 (diff)
downloadports-334b5c7f5f746dc1ad76bb6c3bf3d5588e8684ce.tar.gz
ports-334b5c7f5f746dc1ad76bb6c3bf3d5588e8684ce.zip
- Add games/brumbrumrally
Brum Brum Rally is a 2D racing game with a new track each time you play and support for up to 8 players. The cars can be controlled using keyboard, mouse or game controllers. The tracks are autogenerated on the fly which means you never have to be bored playing the same tracks over and over again. There are three game modes to choose from: - Single Race and Tournament can be played against the computer or with other human players, on the same computer or over the network (LAN or Internet). - The Time Trial mode on the other hand is played by one player at a time. The task is to finish the race as fast as possible in order to beat your own best time or end up on the overall top list. WWW: http://dataapa.net/brumbrumrally/
Notes
Notes: svn path=/head/; revision=426109
-rw-r--r--games/Makefile1
-rw-r--r--games/brumbrumrally/Makefile33
-rw-r--r--games/brumbrumrally/distinfo3
-rw-r--r--games/brumbrumrally/files/patch-Makefile23
-rw-r--r--games/brumbrumrally/files/patch-src_Menu.cpp10
-rw-r--r--games/brumbrumrally/files/patch-src_hqx_common.h15
-rw-r--r--games/brumbrumrally/pkg-descr18
-rw-r--r--games/brumbrumrally/pkg-plist3
8 files changed, 106 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 94ac1ecf220a..21544d5c8a2a 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -106,6 +106,7 @@
SUBDIR += brickshooter
SUBDIR += brikx
SUBDIR += briquolo
+ SUBDIR += brumbrumrally
SUBDIR += brutalchess
SUBDIR += bs
SUBDIR += bsdgames
diff --git a/games/brumbrumrally/Makefile b/games/brumbrumrally/Makefile
new file mode 100644
index 000000000000..e347e74dd100
--- /dev/null
+++ b/games/brumbrumrally/Makefile
@@ -0,0 +1,33 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= brumbrumrally
+PORTVERSION= 0.6
+CATEGORIES= games
+MASTER_SITES= http://dataapa.net/brumbrumrally/files/
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Tacing game with randomized tracks
+
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= dos2unix gmake
+DOS2UNIX_FILES= src/hqx/common.h
+USE_SDL= sdl image net
+
+PORTDOCS= NEWS README
+PORTDATA= *
+
+OPTIONS_DEFINE= DOCS
+
+post-build:
+ @${STRIP_CMD} ${WRKSRC}/${PORTNAME}
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}/
+.endfor
+
+.include <bsd.port.mk>
diff --git a/games/brumbrumrally/distinfo b/games/brumbrumrally/distinfo
new file mode 100644
index 000000000000..3ccef9c9d2e0
--- /dev/null
+++ b/games/brumbrumrally/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1478621231
+SHA256 (brumbrumrally-0.6.tar.gz) = 1315e9c5af96d45f413e5c6f0ceec51dc7104ec6d766e3f676c0b7e8952bbe7d
+SIZE (brumbrumrally-0.6.tar.gz) = 150193
diff --git a/games/brumbrumrally/files/patch-Makefile b/games/brumbrumrally/files/patch-Makefile
new file mode 100644
index 000000000000..2c24860625cf
--- /dev/null
+++ b/games/brumbrumrally/files/patch-Makefile
@@ -0,0 +1,23 @@
+--- Makefile.orig 2016-03-23 12:05:46 UTC
++++ Makefile
+@@ -1,17 +1,14 @@
+ OBJS := $(patsubst %.cpp,%.o,$(wildcard src/*.cpp src/hqx/*.cpp))
+
+-DESTDIR =
+-PREFIX = /usr/local
++PREFIX ?= /usr/local
+ DATADIR = $(PREFIX)/share
+ BINDIR = $(PREFIX)/bin
+ ICONDIR = $(DATADIR)/pixmaps
+ APPDIR = $(DATADIR)/applications
+
+-CXX = g++
++CXX ?= g++
+
+-CXXFLAGS = -Wall -std=c++98 -pedantic `sdl-config --cflags` -pipe
+-all : CXXFLAGS += -O2 -s -DNDEBUG -fno-threadsafe-statics -march=native -fomit-frame-pointer -ffast-math -fno-exceptions -fno-rtti
+-debug : CXXFLAGS += -O0 -g
++CXXFLAGS += -Wall -std=c++98 -pedantic `sdl-config --cflags`
+
+ LDFLAGS = `sdl-config --libs` -lSDL_image -lSDL_net
+
diff --git a/games/brumbrumrally/files/patch-src_Menu.cpp b/games/brumbrumrally/files/patch-src_Menu.cpp
new file mode 100644
index 000000000000..4434cd32c0e7
--- /dev/null
+++ b/games/brumbrumrally/files/patch-src_Menu.cpp
@@ -0,0 +1,10 @@
+--- src/Menu.cpp.orig 2016-03-23 11:34:58 UTC
++++ src/Menu.cpp
+@@ -27,6 +27,7 @@
+ #include <cassert>
+ #include <algorithm>
+ #include <cmath>
++#include <cstdlib>
+
+ Menu::Menu()
+ : selectedItem(0),
diff --git a/games/brumbrumrally/files/patch-src_hqx_common.h b/games/brumbrumrally/files/patch-src_hqx_common.h
new file mode 100644
index 000000000000..a7a2b42a09df
--- /dev/null
+++ b/games/brumbrumrally/files/patch-src_hqx_common.h
@@ -0,0 +1,15 @@
+--- src/hqx/common.h.orig 2014-10-03 16:27:22 UTC
++++ src/hqx/common.h
+@@ -50,9 +50,9 @@ static inline uint32_t rgb_to_yuv(uint32
+
+ /* Test if there is difference in color */
+ static inline int yuv_diff(uint32_t yuv1, uint32_t yuv2) {
+- return (( abs((yuv1 & Ymask) - (yuv2 & Ymask)) > trY ) ||
+- ( abs((yuv1 & Umask) - (yuv2 & Umask)) > trU ) ||
+- ( abs((yuv1 & Vmask) - (yuv2 & Vmask)) > trV ) );
++ return (( abs((int)(yuv1 & Ymask) - (int)(yuv2 & Ymask)) > trY ) ||
++ ( abs((int)(yuv1 & Umask) - (int)(yuv2 & Umask)) > trU ) ||
++ ( abs((int)(yuv1 & Vmask) - (int)(yuv2 & Vmask)) > trV ) );
+ }
+
+ static inline int Diff(uint32_t c1, uint32_t c2)
diff --git a/games/brumbrumrally/pkg-descr b/games/brumbrumrally/pkg-descr
new file mode 100644
index 000000000000..3e8d3aaf30cd
--- /dev/null
+++ b/games/brumbrumrally/pkg-descr
@@ -0,0 +1,18 @@
+Brum Brum Rally is a 2D racing game with a new track each time you
+play and support for up to 8 players.
+
+The cars can be controlled using keyboard, mouse or game controllers.
+The tracks are autogenerated on the fly which means you never have
+to be bored playing the same tracks over and over again.
+
+There are three game modes to choose from:
+
+- Single Race and Tournament can be played against the computer or
+ with other human players, on the same computer or over the network
+ (LAN or Internet).
+
+- The Time Trial mode on the other hand is played by one player at
+ a time. The task is to finish the race as fast as possible in order
+ to beat your own best time or end up on the overall top list.
+
+WWW: http://dataapa.net/brumbrumrally/
diff --git a/games/brumbrumrally/pkg-plist b/games/brumbrumrally/pkg-plist
new file mode 100644
index 000000000000..2319dae34e2d
--- /dev/null
+++ b/games/brumbrumrally/pkg-plist
@@ -0,0 +1,3 @@
+bin/brumbrumrally
+share/applications/brumbrumrally.desktop
+share/pixmaps/brumbrumrally.png