aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2016-10-20 17:00:18 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2016-10-20 17:00:18 +0000
commit5cd538e2ac39ce72f9a44cc20aea841ce99b534a (patch)
treeeb0d7f9b0c0626d4af375aac3c2eaead3ab192d6
parent366a97ec378567f23e179cc772f822ba4db8f104 (diff)
downloadports-5cd538e2ac39ce72f9a44cc20aea841ce99b534a.tar.gz
ports-5cd538e2ac39ce72f9a44cc20aea841ce99b534a.zip
Add py-keystone 10.0.0, OpenStack Keystone
PR: 213542 Submitted by: Alexander Nusov <alexander.nusov@nfvexpress.com>
Notes
Notes: svn path=/head/; revision=424340
-rw-r--r--GIDs2
-rw-r--r--UIDs2
-rw-r--r--security/Makefile1
-rw-r--r--security/py-keystone/Makefile83
-rw-r--r--security/py-keystone/distinfo3
-rw-r--r--security/py-keystone/pkg-descr6
-rw-r--r--security/py-keystone/pkg-plist8
7 files changed, 103 insertions, 2 deletions
diff --git a/GIDs b/GIDs
index c432e34df16d..618fe6b3ec76 100644
--- a/GIDs
+++ b/GIDs
@@ -131,7 +131,7 @@ dnslog:*:186:
swift:*:187:
netxms:*:188:
leofs:*:189:
-# free: 190
+keystone:*:190
# free: 191
moinmoin:*:192:
cups:*:193:
diff --git a/UIDs b/UIDs
index 5c8668d4bb91..3266fdad2fe4 100644
--- a/UIDs
+++ b/UIDs
@@ -136,7 +136,7 @@ dnslog:*:186:186::0:0:dnslog pseudo-user:/nonexistent:/usr/sbin/nologin
swift:*:187:187::0:0:Swift daemon pseudo-user:/nonexistent:/usr/sbin/nologin
netxms:*:188:188::0:0:netxms pseudo-user:/nonexistent:/usr/sbin/nologin
leofs:*:189:189::0:0:LeoFS daemons pseudo-user:/var/db/leofs:/usr/sbin/nologin
-# free: 190
+keystone:*:190:190::0:0:Keystone pseudo-user:/var/lib/keystone:/usr/sbin/nologin
# free: 191
moinmoin:*:192:192::0:0:MoinMoin User:/nonexistent:/usr/sbin/nologin
cups:*:193:193::0:0:Cups Owner:/nonexistent:/usr/sbin/nologin
diff --git a/security/Makefile b/security/Makefile
index bf683c1efb14..fd5c5770497c 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -870,6 +870,7 @@
SUBDIR += py-keyczar
SUBDIR += py-keyring
SUBDIR += py-keyrings.alt
+ SUBDIR += py-keystone
SUBDIR += py-libnacl
SUBDIR += py-m2crypto
SUBDIR += py-mcrypt
diff --git a/security/py-keystone/Makefile b/security/py-keystone/Makefile
new file mode 100644
index 000000000000..7c53e986d0fc
--- /dev/null
+++ b/security/py-keystone/Makefile
@@ -0,0 +1,83 @@
+# Created by: Alexander Nusov <alexander.nusov@nfvexpress.com>
+# $FreeBSD$
+
+PORTNAME= keystone
+PORTVERSION= 10.0.0
+CATEGORIES= security python
+MASTER_SITES= https://fossies.org/linux/misc/openstack/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= alexander.nusov@nfvexpress.com
+COMMENT= OpenStack Keystone
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pbr>=1.6:devel/py-pbr
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}Babel>=2.3.4:devel/py-babel \
+ ${PYTHON_PKGNAMEPREFIX}webob>=1.2.3:www/py-webob \
+ ${PYTHON_PKGNAMEPREFIX}PasteDeploy>=1.5.0:www/py-pastedeploy \
+ ${PYTHON_PKGNAMEPREFIX}Paste>=0:www/py-paste \
+ ${PYTHON_PKGNAMEPREFIX}routes>=0:www/py-routes \
+ ${PYTHON_PKGNAMEPREFIX}cryptography>=0:security/py-cryptography \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.9.0:devel/py-six \
+ ${PYTHON_PKGNAMEPREFIX}sqlalchemy10>=0:databases/py-sqlalchemy10 \
+ ${PYTHON_PKGNAMEPREFIX}sqlalchemy-migrate>=0.9.6:databases/py-sqlalchemy-migrate \
+ ${PYTHON_PKGNAMEPREFIX}stevedore>=1.16.0:devel/py-stevedore \
+ ${PYTHON_PKGNAMEPREFIX}passlib>=1.6:security/py-passlib \
+ ${PYTHON_PKGNAMEPREFIX}keystoneclient>=0:net/py-keystoneclient \
+ ${PYTHON_PKGNAMEPREFIX}keystonemiddleware>=0:devel/py-keystonemiddleware \
+ ${PYTHON_PKGNAMEPREFIX}oslo.cache>=1.5.0:devel/py-oslo.cache \
+ ${PYTHON_PKGNAMEPREFIX}oslo.concurrency>=3.8.0:devel/py-oslo.concurrency \
+ ${PYTHON_PKGNAMEPREFIX}oslo.config>=3.14.0:devel/py-oslo.config \
+ ${PYTHON_PKGNAMEPREFIX}oslo.context>=2.9.0:devel/py-oslo.context \
+ ${PYTHON_PKGNAMEPREFIX}oslo.messaging>=5.2.0:devel/py-oslo.messaging \
+ ${PYTHON_PKGNAMEPREFIX}oslo.db>=0:devel/py-oslo.db \
+ ${PYTHON_PKGNAMEPREFIX}oslo.i18n>=2.1.0:devel/py-oslo.i18n \
+ ${PYTHON_PKGNAMEPREFIX}oslo.log>=1.14.0:devel/py-oslo.log \
+ ${PYTHON_PKGNAMEPREFIX}oslo.middleware>=3.0.0:devel/py-oslo.middleware \
+ ${PYTHON_PKGNAMEPREFIX}oslo.policy>=1.9.0:devel/py-oslo.policy \
+ ${PYTHON_PKGNAMEPREFIX}oslo.serialization>=1.10.0:devel/py-oslo.serialization \
+ ${PYTHON_PKGNAMEPREFIX}oslo.utils>=3.16.0:devel/py-oslo.utils \
+ ${PYTHON_PKGNAMEPREFIX}oauthlib>=0.6:security/py-oauthlib \
+ ${PYTHON_PKGNAMEPREFIX}pysaml2>=0:security/py-pysaml2 \
+ ${PYTHON_PKGNAMEPREFIX}dogpile.cache>=0.6.2:devel/py-dogpile.cache \
+ ${PYTHON_PKGNAMEPREFIX}jsonschema>=0:devel/py-jsonschema \
+ ${PYTHON_PKGNAMEPREFIX}pycadf>=0:devel/py-pycadf \
+ ${PYTHON_PKGNAMEPREFIX}msgpack-python>=0.4.0:devel/py-msgpack-python \
+ ${PYTHON_PKGNAMEPREFIX}osprofiler>=1.4.0:devel/py-osprofiler \
+ ${PYTHON_PKGNAMEPREFIX}sqlparse>=0:databases/py-sqlparse \
+ ${PYTHON_PKGNAMEPREFIX}python-editor>=0:devel/py-python-editor
+
+NO_ARCH= yes
+
+USES= python
+USE_PYTHON= autoplist distutils noegginfo
+
+USERS= keystone
+GROUPS= keystone
+
+post-patch:
+ ${REINPLACE_CMD} -e "s|/etc/keystone|${PREFIX}/etc/${PORTNAME}|g" \
+ ${WRKSRC}/doc/source/apache-httpd.rst \
+ ${WRKSRC}/doc/source/api_curl_examples.rst \
+ ${WRKSRC}/doc/source/configuration.rst \
+ ${WRKSRC}/doc/source/event_notifications.rst \
+ ${WRKSRC}/doc/source/federation/configure_federation.rst \
+ ${WRKSRC}/doc/source/http-api.rst \
+ ${WRKSRC}/doc/source/installing.rst \
+ ${WRKSRC}/doc/source/upgrading.rst \
+ ${WRKSRC}/etc/keystone.conf.sample \
+ ${WRKSRC}/keystone/tests/unit/test_ldap_tls_livetest.py \
+ ${WRKSRC}/keystone/conf/fernet_tokens.py \
+ ${WRKSRC}/keystone/conf/signing.py \
+ ${WRKSRC}/keystone/conf/saml.py \
+ ${WRKSRC}/keystone/conf/identity.py \
+ ${WRKSRC}/keystone/conf/constants.py \
+ ${WRKSRC}/keystone/conf/credential.py \
+ ${WRKSRC}/keystone/conf/federation.py \
+ ${WRKSRC}/keystone/common/profiler.py
+
+post-install:
+ ${MKDIR} ${STAGEDIR}${ETCDIR}
+ ${CP} -R ${WRKSRC}/etc/ ${STAGEDIR}${ETCDIR}
+
+.include <bsd.port.mk>
diff --git a/security/py-keystone/distinfo b/security/py-keystone/distinfo
new file mode 100644
index 000000000000..641967becb57
--- /dev/null
+++ b/security/py-keystone/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1476962582
+SHA256 (keystone-10.0.0.tar.gz) = 5317c7a0c67ec5184e3efabd513ed7bd2eb3a5d537e24d781bc252035f46ae63
+SIZE (keystone-10.0.0.tar.gz) = 1355520
diff --git a/security/py-keystone/pkg-descr b/security/py-keystone/pkg-descr
new file mode 100644
index 000000000000..55db1fc50788
--- /dev/null
+++ b/security/py-keystone/pkg-descr
@@ -0,0 +1,6 @@
+Keystone provides authentication, authorization and service discovery
+mechanisms via HTTP primarily for use by projects in the OpenStack family.
+It is most commonly deployed as an HTTP interface to existing identity systems,
+such as LDAP.
+
+WWW: http://openstack.org/keystone
diff --git a/security/py-keystone/pkg-plist b/security/py-keystone/pkg-plist
new file mode 100644
index 000000000000..55ba37fca33a
--- /dev/null
+++ b/security/py-keystone/pkg-plist
@@ -0,0 +1,8 @@
+@owner keystone
+@dir %%ETCDIR%%
+@sample %%ETCDIR%%/keystone.conf.sample
+@sample %%ETCDIR%%/logging.conf.sample
+%%ETCDIR%%/default_catalog.templates
+%%ETCDIR%%/keystone-paste.ini
+%%ETCDIR%%/policy.json
+%%ETCDIR%%/sso_callback_template.html